aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2013-12-21 05:49:30 +0800
committercrees <crees@FreeBSD.org>2013-12-21 05:49:30 +0800
commit7b3ffcde72073fd12e58d4ac1b35b904715cb024 (patch)
tree50098ae7aa48d5a24ca96433de57989230aedb3d
parente3b1aa69a453e6cb81453634b24e1c6c2e395249 (diff)
downloadfreebsd-ports-gnome-7b3ffcde72073fd12e58d4ac1b35b904715cb024.tar.gz
freebsd-ports-gnome-7b3ffcde72073fd12e58d4ac1b35b904715cb024.tar.zst
freebsd-ports-gnome-7b3ffcde72073fd12e58d4ac1b35b904715cb024.zip
Update to 0.18.5
Musicpd has been rewritten in c++, and now unfortunately requires a modern gcc to build. While here, remove duplicate LICENSE line pointed out by danfe...
-rw-r--r--audio/musicpd/Makefile4
-rw-r--r--audio/musicpd/distinfo4
-rw-r--r--audio/musicpd/files/patch-ffmpeg219
3 files changed, 4 insertions, 23 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index bb50959b4e7d..4b542d3f9d40 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= musicpd
-PORTVERSION= 0.17.6
+PORTVERSION= 0.18.5
CATEGORIES= audio ipv6
MASTER_SITES= http://www.musicpd.org/download/mpd/${PORTVERSION:R}/
DISTNAME= mpd-${PORTVERSION}
@@ -10,12 +10,12 @@ MAINTAINER= crees@FreeBSD.org
COMMENT= Remote-controllable music daemon
LICENSE= GPLv2
-LICENSE= GPLv2
LIB_DEPENDS+= libmad.so:${PORTSDIR}/audio/libmad \
libcurl.so:${PORTSDIR}/ftp/curl
USES= gmake pkgconfig
+USE_GCC= 4.7+
USE_XZ= yes
GNU_CONFIGURE= yes
USE_GNOME= glib20
diff --git a/audio/musicpd/distinfo b/audio/musicpd/distinfo
index c0e1225f1fc6..9c75aa70284d 100644
--- a/audio/musicpd/distinfo
+++ b/audio/musicpd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mpd-0.17.6.tar.xz) = defd23931bd3f0aaee82a079a0583278e51e25f480509a93bc5f70de7f421906
-SIZE (mpd-0.17.6.tar.xz) = 537580
+SHA256 (mpd-0.18.5.tar.xz) = 3424a520f76da90a6869039eb7e89e1e6e3973a6da9e89ffdadf1c4a4ac6e11c
+SIZE (mpd-0.18.5.tar.xz) = 580332
diff --git a/audio/musicpd/files/patch-ffmpeg2 b/audio/musicpd/files/patch-ffmpeg2
deleted file mode 100644
index 01db84eb0b2f..000000000000
--- a/audio/musicpd/files/patch-ffmpeg2
+++ /dev/null
@@ -1,19 +0,0 @@
-Fix build with FFmpeg 2.0.
-
-Upstream status: Better patch sent and merged upstream.
-
-Index: src/decoder/ffmpeg_decoder_plugin.c
-===================================================================
---- src/decoder/ffmpeg_decoder_plugin.c.orig
-+++ src/decoder/ffmpeg_decoder_plugin.c
-@@ -47,6 +47,10 @@
- #undef G_LOG_DOMAIN
- #define G_LOG_DOMAIN "ffmpeg"
-
-+#ifndef AVCODEC_MAX_AUDIO_FRAME_SIZE
-+#define AVCODEC_MAX_AUDIO_FRAME_SIZE 192000 // 1 second of 48khz 32bit audio
-+#endif
-+
- static GLogLevelFlags
- level_ffmpeg_to_glib(int level)
- {