aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2004-07-07 08:59:39 +0800
committerade <ade@FreeBSD.org>2004-07-07 08:59:39 +0800
commit7bd3ba54f9d314f1d85fbf598242ceb4970b9192 (patch)
tree81eb17703d9fef7bcdb218374dd4f6432878e64a
parentdbc8b662b079ae17cdd787a945bad0f2aef17149 (diff)
downloadfreebsd-ports-gnome-7bd3ba54f9d314f1d85fbf598242ceb4970b9192.tar.gz
freebsd-ports-gnome-7bd3ba54f9d314f1d85fbf598242ceb4970b9192.tar.zst
freebsd-ports-gnome-7bd3ba54f9d314f1d85fbf598242ceb4970b9192.zip
(note automake15 not yet connected to the build)
Fix so that aclocal looks in all appropriate ../share/aclocal* directories.
-rw-r--r--devel/automake15/Makefile8
-rw-r--r--devel/automake15/files/patch-aclocal.in12
2 files changed, 18 insertions, 2 deletions
diff --git a/devel/automake15/Makefile b/devel/automake15/Makefile
index c776339d87f3..2ffb5beb986b 100644
--- a/devel/automake15/Makefile
+++ b/devel/automake15/Makefile
@@ -19,12 +19,14 @@ COMMENT= GNU Standards-compliant Makefile generator (version 1.5)
DEPRECATED= Please use devel/automake18 instead
EXPIRATION_DATE=31st December 2004
+WANT_AUTOCONF_VER=253
+WANT_AUTOCONF_RUN=253
BUILD_VERSION= 15
PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
LATEST_LINK= automake${BUILD_VERSION}
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= PERL=${PERL5}
+CONFIGURE_ENV= AUTOCONF=autoconf253 AUTOHEADER=autoheader253 MAKEINFO=makeinfo
CONFIGURE_ARGS= --program-suffix=${BUILD_VERSION}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_REINPLACE= yes
@@ -44,7 +46,9 @@ post-patch:
${RM} -f *.info && \
${MV} automake.texi automake${BUILD_VERSION}.texi && \
${REINPLACE_CMD} -E 's,(automake)\.(info),\1${BUILD_VERSION}\.\2,g' automake${BUILD_VERSION}.texi && \
- ${REINPLACE_CMD} -E 's,(automake)\.(info|texi),\1${BUILD_VERSION}\.\2,g' Makefile.in \
+ ${REINPLACE_CMD} -E 's,(automake)\.(info|texi),\1${BUILD_VERSION}\.\2,g' Makefile.in && \
+ ${REINPLACE_CMD} -e 's,%%BUILD_VERSION%%,${BUILD_VERSION},g; \
+ s,%%X11BASE%%,${X11BASE},g' aclocal.in \
)
.include <bsd.port.mk>
diff --git a/devel/automake15/files/patch-aclocal.in b/devel/automake15/files/patch-aclocal.in
new file mode 100644
index 000000000000..8492c92e4e19
--- /dev/null
+++ b/devel/automake15/files/patch-aclocal.in
@@ -0,0 +1,12 @@
+--- aclocal.in.orig Tue Jul 17 05:36:23 2001
++++ aclocal.in Tue Jul 6 21:30:44 2004
+@@ -35,2 +35,4 @@
+ $acdir = "@datadir@/aclocal";
++$acdir_ver = "@datadir@/aclocal%%BUILD_VERSION%%";
++$acdir_x11 = '%%X11BASE%%/share/aclocal';
+
+@@ -210,2 +212,4 @@
+ push (@dirlist, $acdir);
++ push (@dirlist, $acdir_ver) if (-d "$acdir_ver/.");
++ push (@dirlist, $acdir_x11) if (-d "$acdir_x11/.");
+