aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-09-24 22:50:22 +0800
committerwg <wg@FreeBSD.org>2013-09-24 22:50:22 +0800
commit7c626e85ce381cd5493924334ee4d7411a535869 (patch)
treec6a642797d534a47afd9625458c49e7ce1a43b9c
parentc309018b0b1e6d7992fa74856d2f2b4646e04d38 (diff)
downloadfreebsd-ports-gnome-7c626e85ce381cd5493924334ee4d7411a535869.tar.gz
freebsd-ports-gnome-7c626e85ce381cd5493924334ee4d7411a535869.tar.zst
freebsd-ports-gnome-7c626e85ce381cd5493924334ee4d7411a535869.zip
sysutils/ataidle: allow staging
- Allow staging
-rw-r--r--sysutils/ataidle/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/sysutils/ataidle/Makefile b/sysutils/ataidle/Makefile
index 582e7b210ce9..3cba6d8ce895 100644
--- a/sysutils/ataidle/Makefile
+++ b/sysutils/ataidle/Makefile
@@ -10,21 +10,20 @@ MAINTAINER= wg@FreeBSD.org
COMMENT= Utility to spin down ATA drives
USE_RC_SUBR= ${PORTNAME}
-MAN8= ataidle.8
PORTDOCS= COPYING Changelog README
-PLIST_FILES= sbin/ataidle
+PLIST_FILES= sbin/ataidle \
+ man/man8/ataidle.8.gz
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/ataidle ${PREFIX}/sbin
- ${INSTALL_MAN} ${WRKSRC}/ataidle.8 ${MAN8PREFIX}/man/man8
+ ${INSTALL_PROGRAM} ${WRKSRC}/ataidle ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/ataidle.8 ${STAGEDIR}${MAN8PREFIX}/man/man8
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>