aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>2001-03-14 05:11:38 +0800
committerandreas <andreas@FreeBSD.org>2001-03-14 05:11:38 +0800
commit7c9c202a97becfa7ef0da48cbcde9a6b50c773ad (patch)
treef14de62070f6c17a7289555fab48fea5c2575d87
parente8e20769a5180e5c362ab71d996cde1c27f2c872 (diff)
downloadfreebsd-ports-gnome-7c9c202a97becfa7ef0da48cbcde9a6b50c773ad.tar.gz
freebsd-ports-gnome-7c9c202a97becfa7ef0da48cbcde9a6b50c773ad.tar.zst
freebsd-ports-gnome-7c9c202a97becfa7ef0da48cbcde9a6b50c773ad.zip
new port p5-HTML-Table
HTML::Table is used to generate HTML tables for CGI scripts. By using the methods provided fairly complex tables can be created, manipulated, then printed from Perl scripts. The module also greatly simplifies creating tables within tables from Perl. It is possible to create an entire table using the methods provided and never use an HTML tag. HTML::Table also allows for creating dynamically sized tables via its addRow and addCol methods. These methods automatically resize the table if passed more cell values than will fit in the current table grid. Methods are provided for nearly all valid table, row, and cell tags specified for HTML 3.0. WWW: http://www.chime.ucl.ac.uk/~rmhiajp/htmltable.htm
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTML-Table/Makefile22
-rw-r--r--www/p5-HTML-Table/distinfo1
-rw-r--r--www/p5-HTML-Table/pkg-comment1
-rw-r--r--www/p5-HTML-Table/pkg-descr16
-rw-r--r--www/p5-HTML-Table/pkg-plist5
6 files changed, 46 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 59ba9622fa13..20e20efe29c5 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -172,6 +172,7 @@
SUBDIR += p5-HTML-QuickCheck
SUBDIR += p5-HTML-Stream
SUBDIR += p5-HTML-Summary
+ SUBDIR += p5-HTML-Table
SUBDIR += p5-HTML-TableExtract
SUBDIR += p5-HTML-TableLayout
SUBDIR += p5-HTML-Tagset
diff --git a/www/p5-HTML-Table/Makefile b/www/p5-HTML-Table/Makefile
new file mode 100644
index 000000000000..cdd07f5b744b
--- /dev/null
+++ b/www/p5-HTML-Table/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-HTML-Table
+# Date created: Di 13 Mär 2001 19:37:25 CET
+# Whom: Andreas Klemm <andreas@klemm.gtn.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Table
+PORTVERSION= 1.07b
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+PERL_CONFIGURE= YES
+
+MAN3= HTML::Table.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Table/distinfo b/www/p5-HTML-Table/distinfo
new file mode 100644
index 000000000000..eef29dfacaf1
--- /dev/null
+++ b/www/p5-HTML-Table/distinfo
@@ -0,0 +1 @@
+MD5 (HTML-Table-1.07b.tar.gz) = eae407a30e78a56b0c63da3e69c0f90c
diff --git a/www/p5-HTML-Table/pkg-comment b/www/p5-HTML-Table/pkg-comment
new file mode 100644
index 000000000000..784659ef965c
--- /dev/null
+++ b/www/p5-HTML-Table/pkg-comment
@@ -0,0 +1 @@
+Generate HTML tables for CGI scripts
diff --git a/www/p5-HTML-Table/pkg-descr b/www/p5-HTML-Table/pkg-descr
new file mode 100644
index 000000000000..037aa3b664a8
--- /dev/null
+++ b/www/p5-HTML-Table/pkg-descr
@@ -0,0 +1,16 @@
+HTML::Table is used to generate HTML tables for CGI scripts. By
+using the methods provided fairly complex tables can be created,
+manipulated, then printed from Perl scripts. The module also greatly
+simplifies creating tables within tables from Perl. It is possible
+to create an entire table using the methods provided and never use
+an HTML tag.
+
+HTML::Table also allows for creating dynamically sized tables via
+its addRow and addCol methods. These methods automatically resize
+the table if passed more cell values than will fit in the current
+table grid.
+
+Methods are provided for nearly all valid table, row, and cell tags
+specified for HTML 3.0.
+
+WWW: http://www.chime.ucl.ac.uk/~rmhiajp/htmltable.htm
diff --git a/www/p5-HTML-Table/pkg-plist b/www/p5-HTML-Table/pkg-plist
new file mode 100644
index 000000000000..137253f03b64
--- /dev/null
+++ b/www/p5-HTML-Table/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML/Table/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/HTML/Table.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML/Table
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/HTML