aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-01-08 05:41:12 +0800
committerNeel Chauhan <nc@FreeBSD.org>2021-01-08 05:41:12 +0800
commit7d915170a3ab69a4c523ad3a259b4d97ae02db32 (patch)
treea194f05a1030206300ae9fe97dac405f9dd3f580
parent39a783569020ff68f22c2282e8968d7c2edd8094 (diff)
downloadfreebsd-ports-gnome-7d915170a3ab69a4c523ad3a259b4d97ae02db32.tar.gz
freebsd-ports-gnome-7d915170a3ab69a4c523ad3a259b4d97ae02db32.tar.zst
freebsd-ports-gnome-7d915170a3ab69a4c523ad3a259b4d97ae02db32.zip
New port: mail/pysasl: Pure Python SASL client and server library
Reviewed by: 0mp (mentor) Approved by: 0mp (mentor) Differential Revision: https://reviews.freebsd.org/D28024
-rw-r--r--mail/Makefile1
-rw-r--r--mail/py-pysasl/Makefile28
-rw-r--r--mail/py-pysasl/distinfo3
-rw-r--r--mail/py-pysasl/pkg-descr8
4 files changed, 40 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index bd5c4a0c2112..a8b217f1f1f4 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -505,6 +505,7 @@
SUBDIR += py-postfix-mta-sts-resolver
SUBDIR += py-premailer
SUBDIR += py-pymailq
+ SUBDIR += py-pysasl
SUBDIR += py-pyspf
SUBDIR += py-pyzmail
SUBDIR += py-spf-engine
diff --git a/mail/py-pysasl/Makefile b/mail/py-pysasl/Makefile
new file mode 100644
index 000000000000..eb680df777cb
--- /dev/null
+++ b/mail/py-pysasl/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= pysasl
+DISTVERSION= 0.8.0
+CATEGORIES= mail security
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nc@FreeBSD.org
+COMMENT= Pure Python SASL client and server library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=0:devel/py-typing-extensions@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+OPTIONS_DEFINE= PASSLIB
+OPTIONS_DEFAULT= PASSLIB
+
+PASSLIB_DESC= Password hashing support
+
+PASSLIB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}passlib>=0:security/py-passlib@${PY_FLAVOR}
+
+.include <bsd.port.mk>
diff --git a/mail/py-pysasl/distinfo b/mail/py-pysasl/distinfo
new file mode 100644
index 000000000000..14f452c0093b
--- /dev/null
+++ b/mail/py-pysasl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609988672
+SHA256 (pysasl-0.8.0.tar.gz) = e6eff599093a179ea7aad4ff10a4be139ed2ba338fb9a2c225f828151ef38264
+SIZE (pysasl-0.8.0.tar.gz) = 17126
diff --git a/mail/py-pysasl/pkg-descr b/mail/py-pysasl/pkg-descr
new file mode 100644
index 000000000000..4842a98f16d4
--- /dev/null
+++ b/mail/py-pysasl/pkg-descr
@@ -0,0 +1,8 @@
+pysasl is a Pure Python SASL client and server library. The design of the
+library is intended to be agnostic of the protocol or network library.
+
+The library currently offers PLAIN, LOGIN, and CRAM-MD5 mechanisms by
+default. The EXTERNAL and XOAUTH2 mechanisms are also available for
+special circumstances.
+
+WWW: https://pypi.org/project/pysasl/