aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2013-11-01 07:44:49 +0800
committergarga <garga@FreeBSD.org>2013-11-01 07:44:49 +0800
commit7dac8b4eb5fb3e187fd51e555908fb28263a163f (patch)
tree1db52bcaf1322fadcbbc0b19e6901691154d4292
parenta848ddb6336a7ab6cfb7bed2309aa4f269761b33 (diff)
downloadfreebsd-ports-gnome-7dac8b4eb5fb3e187fd51e555908fb28263a163f.tar.gz
freebsd-ports-gnome-7dac8b4eb5fb3e187fd51e555908fb28263a163f.tar.zst
freebsd-ports-gnome-7dac8b4eb5fb3e187fd51e555908fb28263a163f.zip
. Simplify Makefile
. Use space on WWW line
-rw-r--r--security/scanhill/Makefile19
-rw-r--r--security/scanhill/files/patch-configure11
-rw-r--r--security/scanhill/pkg-descr2
3 files changed, 17 insertions, 15 deletions
diff --git a/security/scanhill/Makefile b/security/scanhill/Makefile
index 14140056fad4..42602d28b409 100644
--- a/security/scanhill/Makefile
+++ b/security/scanhill/Makefile
@@ -19,12 +19,8 @@ PORTDOCS= README.txt INSTALL.txt mysql.sql
OPTIONS_DEFINE= MYSQL DOCS
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MMYSQL}
-CONFIGURE_ARGS+= --enable-mysql
-USE_MYSQL= yes
-.endif
+MYSQL_USE= MYSQL=yes
+MYSQL_CONFIGURE_ENABLE= mysql
post-patch:
@${REINPLACE_CMD} -e 's/-liconv/${ICONV_LIB}/' ${WRKSRC}/configure
@@ -32,14 +28,9 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/scanhill ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/scanhill.conf ${STAGEDIR}${PREFIX}/etc/scanhill.conf-dist
-.if !exists(${PREFIX}/etc/scanhill.conf)
- ${INSTALL_DATA} ${WRKSRC}/scanhill.conf ${STAGEDIR}${PREFIX}/etc/
-.endif
-.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
-. for f in ${PORTDOCS}
+.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
-. endfor
-.endif
+.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/scanhill/files/patch-configure b/security/scanhill/files/patch-configure
new file mode 100644
index 000000000000..b27329cf0d28
--- /dev/null
+++ b/security/scanhill/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2013-10-30 11:38:52.000000000 -0200
++++ configure 2013-10-30 11:39:25.000000000 -0200
+@@ -975,7 +975,7 @@
+ done
+
+ # Check whether --enable-mysql or --disable-mysql was given.
+-if test "${enable_mysql+set}" = set; then
++if test "${enable_mysql}" = "yes"; then
+ enableval="$enable_mysql"
+
+ for ac_hdr in mysql/mysql.h
diff --git a/security/scanhill/pkg-descr b/security/scanhill/pkg-descr
index d7002fd5257f..fa5496254ac4 100644
--- a/security/scanhill/pkg-descr
+++ b/security/scanhill/pkg-descr
@@ -5,4 +5,4 @@ used, stored instant messages can be read through a browser interface that is
written in PHP language. Please see the INSTALL.txt file for instructions on
how to install, configure and run EnderUNIX scanhill.
-WWW: http://www.enderunix.org/scanhill/
+WWW: http://www.enderunix.org/scanhill/