aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2005-02-14 21:53:55 +0800
committerclement <clement@FreeBSD.org>2005-02-14 21:53:55 +0800
commit7dbdee0c1518b627500afec9e6a2e010c7704030 (patch)
tree0f5f0cd158528a38b379783275faf0e6fb255166
parent4af1eb174f7f479314f808de18f547f139fca446 (diff)
downloadfreebsd-ports-gnome-7dbdee0c1518b627500afec9e6a2e010c7704030.tar.gz
freebsd-ports-gnome-7dbdee0c1518b627500afec9e6a2e010c7704030.tar.zst
freebsd-ports-gnome-7dbdee0c1518b627500afec9e6a2e010c7704030.zip
- fix plist
-rw-r--r--www/apache13-modperl/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/www/apache13-modperl/Makefile b/www/apache13-modperl/Makefile
index a2d3173d8ab3..5490452d9b05 100644
--- a/www/apache13-modperl/Makefile
+++ b/www/apache13-modperl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= apache+mod_perl
PORTVERSION= ${VERSION_APACHE}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD:S/$/:apache/} \
${MASTER_SITE_PERL_CPAN:S/$/Apache\/:modperl/}
@@ -146,11 +146,15 @@ MAN3= Apache.3 Apache::Constants.3 Apache::ExtUtils.3 \
Apache::RegistryLoader.3 Apache::StatINC.3 Apache::Include.3 \
Apache::PerlSections.3 cgi_to_mod_perl.3 \
mod_perl_cvs.3 mod_perl_method_handlers.3 mod_perl_traps.3 \
- mod_perl_tuning.3 Apache::MyConfig.3
+ mod_perl_tuning.3
MAN8= ab.8 apachectl.8 apxs.8 httpd.8 logresolve.8 rotatelogs.8 \
${SUEXEC_MAN}
+.if ${PERL_LEVEL} >= 500800
+MAN3+= Apache::MyConfig.3
+.endif
+
post-extract:
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/apache.sh > ${WRKSRC}/apache.sh
@@ -160,6 +164,10 @@ pre-configure:
${PERL5} Makefile.PL EVERYTHING=1 APACHE_SRC=../apache_${VERSION_APACHE}\
USE_APACI=1 PREP_HTTPD=1 DO_HTTPD=1
+post-configure:
+ @cd ${WRKSRC_MODPERL}/ && \
+ ${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
+
pre-build:
@ cd ${WRKSRC_MODPERL}; \
${MAKE}