aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2016-11-27 18:21:33 +0800
committerBernard Spil <brnrd@FreeBSD.org>2016-11-27 18:21:33 +0800
commit7f25f7e97d87a2ce5cb007122048a69c3fb1b310 (patch)
tree3eed97eaa796bdedd88fe667ac2964945efa3de1
parentaecf56591998fc5ee15e502023df93d42d6d9cdd (diff)
downloadfreebsd-ports-gnome-7f25f7e97d87a2ce5cb007122048a69c3fb1b310.tar.gz
freebsd-ports-gnome-7f25f7e97d87a2ce5cb007122048a69c3fb1b310.tar.zst
freebsd-ports-gnome-7f25f7e97d87a2ce5cb007122048a69c3fb1b310.zip
www/mod_spdy: IGNORE with LibreSSL
- IGNORE when built with security/libressl(-devel) - Move from USE_OPENSSL to USES= ssl - Update WWW PR: 210773 Approved by: maintainer timeout
-rw-r--r--www/mod_spdy/Makefile7
-rw-r--r--www/mod_spdy/pkg-descr2
2 files changed, 6 insertions, 3 deletions
diff --git a/www/mod_spdy/Makefile b/www/mod_spdy/Makefile
index 2d71f6d86490..c4dad68a148d 100644
--- a/www/mod_spdy/Makefile
+++ b/www/mod_spdy/Makefile
@@ -25,9 +25,8 @@ BUILD_DEPENDS= python:lang/python \
bash:shells/bash
ONLY_FOR_ARCHS= amd64 i386
-USE_OPENSSL= yes
USE_APACHE= 22
-USES= compiler execinfo gmake python:2 tar:xz
+USES= compiler execinfo gmake python:2 ssl tar:xz
REINPLACE_ARGS= -i ""
WRKSRC= ${WRKDIR}/${PORTNAME}_source_${PORTVERSION}/mod_spdy/src
@@ -85,6 +84,10 @@ MAKE_ENV+= BUILDTYPE=${BUILDTYPE}
.include <bsd.port.pre.mk>
+.if defined(OPENSSL_PORT) && "${OPENSSL_PORT:M*libressl*}" != ""
+IGNORE= ${PORTNAME} is incompatible with LibreSSL, please use www/apache24 with mod_http2
+.endif
+
.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 36
CXXFLAGS+= -Wno-unused-local-typedef
.endif
diff --git a/www/mod_spdy/pkg-descr b/www/mod_spdy/pkg-descr
index 604093c61acb..eb1851cf4a21 100644
--- a/www/mod_spdy/pkg-descr
+++ b/www/mod_spdy/pkg-descr
@@ -3,4 +3,4 @@ Apache HTTPD web server. Because mod_spdy is an Apache module, it can be
loaded into currently deployed Apache HTTPD 2.x web servers using mod_so.
-WWW: http://code.google.com/p/mod-spdy/
+WWW: https://developers.google.com/speed/spdy/mod_spdy/