aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2011-05-12 22:38:12 +0800
committerache <ache@FreeBSD.org>2011-05-12 22:38:12 +0800
commit7f409ef1219e79adfd38ec798e9d5cb3bd5b8d7e (patch)
tree601717e54ea7004a8b38bfa459ddcd7cb1e304af
parentd295484d179b6ed56bc3a1d89d4a7840ed936b8b (diff)
downloadfreebsd-ports-gnome-7f409ef1219e79adfd38ec798e9d5cb3bd5b8d7e.tar.gz
freebsd-ports-gnome-7f409ef1219e79adfd38ec798e9d5cb3bd5b8d7e.tar.zst
freebsd-ports-gnome-7f409ef1219e79adfd38ec798e9d5cb3bd5b8d7e.zip
amd64 fixes (types sizes)
Submitted by: Christian Gusenbauer <c47g@gmx.at>
-rw-r--r--misc/astrolog/Makefile2
-rw-r--r--misc/astrolog/files/patch-ab13
-rw-r--r--misc/astrolog/files/patch-placalc.c11
3 files changed, 25 insertions, 1 deletions
diff --git a/misc/astrolog/Makefile b/misc/astrolog/Makefile
index a2936771ea1a..7f51838cab6a 100644
--- a/misc/astrolog/Makefile
+++ b/misc/astrolog/Makefile
@@ -10,7 +10,7 @@
PORTNAME= astrolog
PORTVERSION= 5.40
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= misc
MASTER_SITES= http://www.astrolog.org/ftp/ephem/:ephem \
http://www.astrolog.org/ftp/:dist
diff --git a/misc/astrolog/files/patch-ab b/misc/astrolog/files/patch-ab
index adc639f16d4e..5d2c79c73c1a 100644
--- a/misc/astrolog/files/patch-ab
+++ b/misc/astrolog/files/patch-ab
@@ -40,3 +40,16 @@
#else
#define DEFAULT_DIR "C:\\ASTROLOG"
#endif
+@@ -1046,9 +1050,9 @@
+ */
+
+ #define byte unsigned char
+-#define word unsigned short
+-#define dword unsigned long
+-#define word4 long
++#define word u_int16_t
++#define dword u_int32_t
++#define word4 int32_t
+ #define real double
+ #define _char unsigned char
+ #define _int unsigned int
diff --git a/misc/astrolog/files/patch-placalc.c b/misc/astrolog/files/patch-placalc.c
new file mode 100644
index 000000000000..28ca306f6cfc
--- /dev/null
+++ b/misc/astrolog/files/patch-placalc.c
@@ -0,0 +1,11 @@
+--- placalc.c.orig 2011-05-11 16:19:54.000000000 +0000
++++ placalc.c 2011-05-11 16:20:31.000000000 +0000
+@@ -900,7 +900,7 @@
+ static double last_j0_outer = HUGE8;
+ static double last_j0_chiron = HUGE8;
+ static double last_j0_aster = HUGE8;
+- static long icoord[6][5][3], chicoord[6][3], ascoord[6][4][3];
++ static word4 icoord[6][5][3], chicoord[6][3], ascoord[6][4][3];
+ REAL8 j0, jd, jfrac;
+ REAL8 l[6], r[6], z[6];
+ int n, order, p;