aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2008-11-27 07:10:03 +0800
committerglarkin <glarkin@FreeBSD.org>2008-11-27 07:10:03 +0800
commit7f4e07dd968944ba9ca0f991d377dec8e71259a6 (patch)
tree7f42cf01a355c273468b4fc2fde5af9eb0e72c09
parent95e8f305f905a3be81297f4cd1b2c18e2a028068 (diff)
downloadfreebsd-ports-gnome-7f4e07dd968944ba9ca0f991d377dec8e71259a6.tar.gz
freebsd-ports-gnome-7f4e07dd968944ba9ca0f991d377dec8e71259a6.tar.zst
freebsd-ports-gnome-7f4e07dd968944ba9ca0f991d377dec8e71259a6.zip
- Added new port for http://trac-hacks.org/wiki/RevtreePlugin
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-revtree/Makefile34
-rw-r--r--www/trac-revtree/distinfo3
-rw-r--r--www/trac-revtree/pkg-descr17
-rw-r--r--www/trac-revtree/pkg-message13
-rw-r--r--www/trac-revtree/pkg-plist1
6 files changed, 69 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 524efa9a61de..a3d4cbfecb18 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1401,6 +1401,7 @@
SUBDIR += trac-privatetickets
SUBDIR += trac-remind
SUBDIR += trac-restrictedarea
+ SUBDIR += trac-revtree
SUBDIR += trac-robotstxt
SUBDIR += trac-simpleticket
SUBDIR += trac-spam-filter
diff --git a/www/trac-revtree/Makefile b/www/trac-revtree/Makefile
new file mode 100644
index 000000000000..4337fd46c49c
--- /dev/null
+++ b/www/trac-revtree/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: trac-revtree
+# Date created: Nov 10 2008
+# Whom: glarkin
+#
+# $FreeBSD$
+#
+
+PORTNAME= revtree
+PORTVERSION= 0.6.2
+CATEGORIES= www devel python
+MASTER_SITES= http://www.sourcehosting.net/freebsd/distfiles/ \
+ LOCAL/glarkin
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= Graphical representation of an SVN repository
+
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
+
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin/0.11
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= TracRevtreePlugin
+PYDISTUTILS_PKGVERSION= ${PORTVERSION}dev
+PLIST_SUB+= EGGVERSION="${PORTVERSION}dev" PYTHONVERSION=${_PYTHON_VERSION}
+PYDISTUTILS_NOEGGINFO= yes
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/trac-revtree/distinfo b/www/trac-revtree/distinfo
new file mode 100644
index 000000000000..bef42d5b4df6
--- /dev/null
+++ b/www/trac-revtree/distinfo
@@ -0,0 +1,3 @@
+MD5 (revtreeplugin-0.6.2.zip) = d60ff008596c0e28d67fb85390f48d6b
+SHA256 (revtreeplugin-0.6.2.zip) = 195094db07657ade32152a2d6f10f1fce451c5a6db6f37ea8e889fbaef42c5a8
+SIZE (revtreeplugin-0.6.2.zip) = 125010
diff --git a/www/trac-revtree/pkg-descr b/www/trac-revtree/pkg-descr
new file mode 100644
index 000000000000..f8955809c67a
--- /dev/null
+++ b/www/trac-revtree/pkg-descr
@@ -0,0 +1,17 @@
+This Trac plugin renders a graphical representation of the repository.
+The plugin collects the repository's revisions and rebuilds the
+branches based on the names of the files changed in each revision.
+
+Filters can be used to choose which branches and which revisions
+are to be displayed. Each depicted changeset is a clickable item
+that redirects the browser to the appropriate changeset view.
+
+Whenever the mouse cursor is hovered over a revtree changeset, the
+browser opens a tool tip box that shows the revision number, the
+author and the date of the revision along with the wiki-formatted
+log message.
+
+The plugin also shows branch cloning/tagging operations, and can
+be extended to render other kinds of operations such as merging.
+
+WWW: http://trac-hacks.org/wiki/RevtreePlugin
diff --git a/www/trac-revtree/pkg-message b/www/trac-revtree/pkg-message
new file mode 100644
index 000000000000..935858e941d1
--- /dev/null
+++ b/www/trac-revtree/pkg-message
@@ -0,0 +1,13 @@
+**************************************************
+To complete the installation, please add:
+
+[components]
+revtree.* = enabled
+
+to your trac.ini to enable the plugin.
+
+Next, visit:
+http://trac-hacks.org/wiki/RevtreePlugin#Configuration
+
+for additional configuration instructions.
+**************************************************
diff --git a/www/trac-revtree/pkg-plist b/www/trac-revtree/pkg-plist
new file mode 100644
index 000000000000..794fc2df9d97
--- /dev/null
+++ b/www/trac-revtree/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/TracRevtreePlugin-%%EGGVERSION%%-py%%PYTHONVERSION%%.egg