aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2018-11-19 20:20:38 +0800
committergahr <gahr@FreeBSD.org>2018-11-19 20:20:38 +0800
commit7fff9aa2343e6f6b377792d6b026a3fc22241f1b (patch)
tree46136c070e645cef74b78641cab0676e25a74ccd
parentb74cd7ae8c477e887dbc6952950f902c4a67a69c (diff)
downloadfreebsd-ports-gnome-7fff9aa2343e6f6b377792d6b026a3fc22241f1b.tar.gz
freebsd-ports-gnome-7fff9aa2343e6f6b377792d6b026a3fc22241f1b.tar.zst
freebsd-ports-gnome-7fff9aa2343e6f6b377792d6b026a3fc22241f1b.zip
lang/itcl4: update to 4.1.2
-rw-r--r--lang/itcl4/Makefile5
-rw-r--r--lang/itcl4/distinfo6
-rw-r--r--lang/itcl4/files/patch-Makefile.in27
3 files changed, 17 insertions, 21 deletions
diff --git a/lang/itcl4/Makefile b/lang/itcl4/Makefile
index bed780925480..8f10f9f11be1 100644
--- a/lang/itcl4/Makefile
+++ b/lang/itcl4/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= itcl4
-PORTVERSION= 4.1.1
+PORTVERSION= 4.1.2
PORTREVISION= 0
CATEGORIES= lang
-MASTER_SITES= SF/incrtcl/%5Bincr%20Tcl_Tk%5D-4-source/itcl%20${PORTVERSION}/
+MASTER_SITES= SF/tcl/Tcl/8.6.9
DISTNAME= itcl${PORTVERSION}
MAINTAINER= tcltk@FreeBSD.org
@@ -15,6 +15,7 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/license.terms
USES+= tcl:86,tea
+
CONFIGURE_ARGS+=--includedir=${PREFIX}/include/itcl${PORTVERSION:R}
PLIST_SUB+= PKGVER=${PORTVERSION} \
SHORT_PKGVER=${PORTVERSION:R}
diff --git a/lang/itcl4/distinfo b/lang/itcl4/distinfo
index 8a56084ce531..5b417bd8f473 100644
--- a/lang/itcl4/distinfo
+++ b/lang/itcl4/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1514890218
-SHA256 (itcl4.1.1.tar.gz) = 46671d43ef3cd9f87be48ca773e890d074ca291d2da3ac082dbbf93a98c9d359
-SIZE (itcl4.1.1.tar.gz) = 436718
+TIMESTAMP = 1542629308
+SHA256 (itcl4.1.2.tar.gz) = 9ce37c31f601326fdd3bbe4b524936196ab469f18b083e310267781155681ed8
+SIZE (itcl4.1.2.tar.gz) = 435701
diff --git a/lang/itcl4/files/patch-Makefile.in b/lang/itcl4/files/patch-Makefile.in
index e35eb0087687..7108bb55cdef 100644
--- a/lang/itcl4/files/patch-Makefile.in
+++ b/lang/itcl4/files/patch-Makefile.in
@@ -1,18 +1,13 @@
---- Makefile.in.orig 2013-11-21 20:49:06 UTC
-+++ Makefile.in
-@@ -222,11 +222,12 @@ install-doc: doc
- @$(INSTALL_DATA_DIR) $(DESTDIR)$(mandir)/mann
- @echo "Installing documentation in $(DESTDIR)$(mandir)"
- @cd $(srcdir)/doc; for i in *.n; do \
-+ sfxname=`basename $$i | sed -e 's|.n$$|.i4|'`; \
- echo "Installing $$i"; \
-- rm -f $(DESTDIR)$(mandir)/mann/`basename $$i`; \
-+ rm -f $(DESTDIR)$(mandir)/mann/$$sfxname; \
- sed -e '/man\.macros/r man.macros' -e '/man\.macros/d' \
-- $$i > $(DESTDIR)$(mandir)/mann/$$i; \
-- chmod 444 $(DESTDIR)$(mandir)/mann/$$i; \
-+ $$i > $(DESTDIR)$(mandir)/mann/$$sfxname; \
-+ chmod 444 $(DESTDIR)$(mandir)/mann/$$sfxname; \
+--- Makefile.in.orig 2018-11-19 12:13:00.434900000 +0000
++++ Makefile.in 2018-11-19 12:14:16.591273000 +0000
+@@ -240,8 +240,9 @@
+ if test X"$$i" = X'$(srcdir)/doc/*.n'; then break; fi; \
+ bi=`basename $$i`; \
+ echo "Installing $$bi"; \
++ sfxname=`echo $$bi | sed -e 's|.n$$|.i4|'`; \
+ sed -e '/man\.macros/r $(srcdir)/doc/man.macros' -e '/man\.macros/d' $$i > $$bi.tmp \
+- && $(INSTALL_DATA) $$bi.tmp $(DESTDIR)$(mandir)/mann/$$bi \
++ && $(INSTALL_DATA) $$bi.tmp $(DESTDIR)$(mandir)/mann/$$sfxname \
+ && rm -f $$bi.tmp; \
done
- test: binaries libraries