aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2015-02-16 00:52:23 +0800
committerpi <pi@FreeBSD.org>2015-02-16 00:52:23 +0800
commit806ee3a277f23756e49874af29ee300498d54cad (patch)
tree2550e32622cde3ccc5985de5eacb7d89fa28acb8
parentb17c317d63a0d3e8fc9c56fcf7a596dfe4b49b32 (diff)
downloadfreebsd-ports-gnome-806ee3a277f23756e49874af29ee300498d54cad.tar.gz
freebsd-ports-gnome-806ee3a277f23756e49874af29ee300498d54cad.tar.zst
freebsd-ports-gnome-806ee3a277f23756e49874af29ee300498d54cad.zip
databases/cego: 2.20.19 -> 2.20.20
- Added fork+setsid system calls to daemon mode - rc.d script is now part of the distribution Submitted by: lemke@lemke-it.com (author)
-rw-r--r--databases/cego/Makefile6
-rw-r--r--databases/cego/distinfo4
-rw-r--r--databases/cego/files/cego.in110
-rw-r--r--databases/cego/pkg-plist1
4 files changed, 7 insertions, 114 deletions
diff --git a/databases/cego/Makefile b/databases/cego/Makefile
index 78060fde3608..181b29b36fcd 100644
--- a/databases/cego/Makefile
+++ b/databases/cego/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= cego
-PORTVERSION= 2.20.19
+PORTVERSION= 2.20.20
CATEGORIES= databases
MASTER_SITES= http://www.lemke-it.com/
@@ -17,7 +17,6 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
USE_LDCONFIG= yes
-USE_RC_SUBR= cego
USES= ncurses readline libtool
@@ -35,6 +34,9 @@ post-patch:
post-install:
${MKDIR} ${STAGEDIR}${DATADIR}
${CP} ${WRKSRC}/tools/* ${STAGEDIR}${DATADIR}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/rc.d
+ ${REINPLACE_CMD} -e 's/%%USER%%/${USERS}/g' ${WRKSRC}/samples/rc/cego
+ ${CP} ${WRKSRC}/samples/rc/cego ${STAGEDIR}${PREFIX}/etc/rc.d/
post-stage:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcego.so.1.0.0
diff --git a/databases/cego/distinfo b/databases/cego/distinfo
index 65024eaf2aeb..1fd19aed1e3f 100644
--- a/databases/cego/distinfo
+++ b/databases/cego/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cego-2.20.19.tar.gz) = ce4c41b618594cc39f8f4d7aad8918a1bf3ec2d26a0dbfff1a0864855bee14ba
-SIZE (cego-2.20.19.tar.gz) = 924463
+SHA256 (cego-2.20.20.tar.gz) = 7f006656d5fc60ffe415e5c607be4a4578518acf1f9b90f143f337b8e9478bb9
+SIZE (cego-2.20.20.tar.gz) = 924349
diff --git a/databases/cego/files/cego.in b/databases/cego/files/cego.in
deleted file mode 100644
index 138079bb9a3b..000000000000
--- a/databases/cego/files/cego.in
+++ /dev/null
@@ -1,110 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: cego
-# REQUIRE: LOGIN cleanvar
-# KEYWORD: shutdown
-
-#
-# Add the following lines to /etc/rc.conf to enable cego:
-# cego_enable (bool): Set to "NO" by default.
-# Set it to "YES" to enable cego
-# cego_profiles (str): Set to "" by default.
-# Define your profiles here.
-# cego_tablespc (str): Set it to the tablespace
-# cego_flags (str): Set to "" by default.
-# Extra flags passed to start command.
-
-. /etc/rc.subr
-
-name="cego"
-rcvar=cego_enable
-
-command="%%PREFIX%%/bin/cego"
-
-: ${cego_enable="NO"}
-: ${cego_conf="%%PREFIX%%/cego"}
-: ${cego_root="%%PREFIX%%/cego"}
-: ${cego_user="%%USER%%"}
-
-flags="--mode=daemon"
-
-_pidprefix="/var/run/cego"
-pidfile="${_pidprefix}.pid"
-
-command_arg="--mode=daemon"
-_pidprefix="/var/run/cego"
-
-flags="--mode=daemon"
-
-load_rc_config $name
-
-if [ -n "$2" ]; then
- profile="$2"
- if [ "x${cego_profiles}" != "x" ]; then
- pidfile="${_pidprefix}.${profile}.pid"
-
- echo profile is $profile
-
- eval cego_tablespc="\${cego_${profile}_tablespc:-}"
- if [ "x${cego_tablespc}" = "x" ]; then
- err 1 "You must define a tableset for db instance cego_${profile}_tablespc"
- fi
-
- eval cego_conf="\${cego_${profile}_conf:-${cego_conf}}"
- eval cego_root="\${cego_${profile}_root:-${cego_root}}"
-
- required_files="${cego_conf}/${profile}.xml"
- eval cego_enable="\${cego_${profile}_enable:-${cego_enable}}"
- command_args="--dbxml=${required_files} --tableset=${cego_tablespc} --lockfile=${cego_root}/${profile}.lck --logfile=${cego_root}/${profile}.log"
- echo "Setting command_args $command_args"
- else
- warn "$0: extra argument ignored"
- fi
-else
- if [ "x${cego_profiles}" != "x" -a "x$1" != "x" ]; then
- for profile in ${cego_profiles}; do
- eval _enable="\${cego_${profile}_enable}"
- case "x${_enable:-${cego_enable}}" in
- x|x[Nn][Oo]|x[Nn][Oo][Nn][Ee])
- continue
- ;;
- x[Yy][Ee][Ss])
- ;;
- *)
- if test -z "$_enable"; then
- _var=cego_enable
- else
- _var=cego_"${profile}"_enable
- fi
- warn "Bad value" \
- "'${_enable:-${cego_enable}}'" \
- "for ${_var}. " \
- "Profile ${profile} skipped."
- continue
- ;;
- esac
- echo "===> cego profile: ${profile}"
- %%PREFIX%%/etc/rc.d/cego $1 ${profile}
- retcode="$?"
- if [ "0${retcode}" -ne 0 ]; then
- failed="${profile} (${retcode}) ${failed:-}"
- else
- success="${profile} ${success:-}"
- fi
- done
- exit 0
- fi
-fi
-
-
-cego_requirepidfile()
-{
- if [ ! "0`check_pidfile ${pidfile} ${command}`" -gt 1 ]; then
- err 1 "${name} not running? (check $pidfile)."
- fi
-}
-
-run_rc_command "$1"
diff --git a/databases/cego/pkg-plist b/databases/cego/pkg-plist
index f74c1f45eccf..75e214401389 100644
--- a/databases/cego/pkg-plist
+++ b/databases/cego/pkg-plist
@@ -3,6 +3,7 @@ bin/cgadm
bin/cgblow
bin/cgclt
bin/cglog
+etc/rc.d/cego
include/cego/CegoAdmNet.h
include/cego/CegoAdminHandler.h
include/cego/CegoBlob.h