aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-07-21 06:02:50 +0800
committerbapt <bapt@FreeBSD.org>2012-07-21 06:02:50 +0800
commit808860d132076afd166386427f572cb193fa8956 (patch)
tree2b7d428dee6f8c3a1d2610bf860744907b7b2420
parent00b22b3072c553db1d657c3d5081a94e84346362 (diff)
downloadfreebsd-ports-gnome-808860d132076afd166386427f572cb193fa8956.tar.gz
freebsd-ports-gnome-808860d132076afd166386427f572cb193fa8956.tar.zst
freebsd-ports-gnome-808860d132076afd166386427f572cb193fa8956.zip
Convert to new options framework
-rw-r--r--net/ccxstream/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/net/ccxstream/Makefile b/net/ccxstream/Makefile
index b91ea1ea7934..e86b427f4652 100644
--- a/net/ccxstream/Makefile
+++ b/net/ccxstream/Makefile
@@ -14,17 +14,20 @@ MASTER_SITES= SF/xbplayer/XStream%20Servers/ccXStream%20${PORTVERSION}%20for%20
MAINTAINER= ports@FreeBSD.org
COMMENT= Stream media files to XBox Media Center via XBMSP
-OPTIONS= SO_KEEPALIVE "Build with SO_KEEPALIVE" ON \
- TCP_NODELAY "Build with TCP_NODELAY" OFF
+OPTIONS_DEFINE= SO_KEEPALIVE TCP_NODELAY DOCS
+OPTIONS_DEFAULT= SO_KEEPALIVE
+SO_KEEPALIVE_DESC= Build with SO_KEEPALIVE
+TCP_NODELAY_DESC= Build with TCP_NODELAY
USE_GMAKE= yes
USE_RC_SUBR= ccxstream
-PLIST_FILES= \
- bin/ccxtest \
+PLIST_FILES= bin/ccxtest \
sbin/ccxstream
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= README ChangeLog TODO xbmsp-xml.txt xbmsp.txt
.endif
@@ -42,16 +45,14 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
-
# enable SO_KEEPALIVE
-.if defined(WITH_SO_KEEPALIVE)
+.if ${PORT_OPTIONS:MSO_KEEPALIVE}
CFLAGS+= -DSO_KEEPALIVE
.endif
# enable TCP_NODELAY
-.if defined(WITH_TCP_NODELAY)
+.if ${PORT_OPTIONS:MTCP_NODELAY}
CFLAGS+= -DTCP_NODELAY
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>