aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-04-07 09:58:56 +0800
committerWen Heping <wen@FreeBSD.org>2010-04-07 09:58:56 +0800
commit8144e4e7b8a2c1d101fa7594b03f20bcc51585af (patch)
tree30e94c32aad3eb99e0922ac38464873f80a2db60
parente995d60859a9b9ac53587e0173ec28b5e5afc28f (diff)
downloadfreebsd-ports-gnome-8144e4e7b8a2c1d101fa7594b03f20bcc51585af.tar.gz
freebsd-ports-gnome-8144e4e7b8a2c1d101fa7594b03f20bcc51585af.tar.zst
freebsd-ports-gnome-8144e4e7b8a2c1d101fa7594b03f20bcc51585af.zip
python-jabberbot is a Jabber bot framework for Python that enables you
to easily write simple Jabber bots. You can use your Jabber bots to provide information about your running systems, to make your website interact with your visitors or notify you about updates or changes you monitor with your Python scripts. WWW: http://thpinfo.com/2007/python-jabberbot/ PR: ports/145428 Submitted by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/py-jabberbot/Makefile26
-rw-r--r--net-im/py-jabberbot/distinfo3
-rw-r--r--net-im/py-jabberbot/pkg-descr7
-rw-r--r--net-im/py-jabberbot/pkg-plist3
5 files changed, 40 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index dda947db24f5..ec7c7bf98fa1 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -130,6 +130,7 @@
SUBDIR += prosody
SUBDIR += psi
SUBDIR += py-jabber
+ SUBDIR += py-jabberbot
SUBDIR += py-msnp
SUBDIR += py-punjab
SUBDIR += py-pyxmpp
diff --git a/net-im/py-jabberbot/Makefile b/net-im/py-jabberbot/Makefile
new file mode 100644
index 000000000000..169cff1043f5
--- /dev/null
+++ b/net-im/py-jabberbot/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: py-jabberbot
+# Date created: 2010-04-04
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jabberbot
+PORTVERSION= 0.9
+CATEGORIES= net-im python
+MASTER_SITES= http://thpinfo.com/2007/python-jabberbot/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= A simple Jabber Bot for Python
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/xmpp/auth.py:${PORTSDIR}/net-im/py-xmpppy
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+
+post-patch:
+ @${GREP} -lr '/usr/bin/python' ${WRKSRC} | \
+ ${XARGS} ${REINPLACE_CMD} -e "s,^#!/usr/bin/python,#!${PYTHON_CMD},"
+
+.include <bsd.port.mk>
diff --git a/net-im/py-jabberbot/distinfo b/net-im/py-jabberbot/distinfo
new file mode 100644
index 000000000000..48bab0a1fc86
--- /dev/null
+++ b/net-im/py-jabberbot/distinfo
@@ -0,0 +1,3 @@
+MD5 (jabberbot-0.9.tar.gz) = 2262df265f6ba387f1ace1bf417d0275
+SHA256 (jabberbot-0.9.tar.gz) = 6a67acb441a8e80b54078967c1277f48034dee4e42a61ab6faae2f04c7eaa4dd
+SIZE (jabberbot-0.9.tar.gz) = 20003
diff --git a/net-im/py-jabberbot/pkg-descr b/net-im/py-jabberbot/pkg-descr
new file mode 100644
index 000000000000..ad3a4aab7702
--- /dev/null
+++ b/net-im/py-jabberbot/pkg-descr
@@ -0,0 +1,7 @@
+python-jabberbot is a Jabber bot framework for Python that enables you
+to easily write simple Jabber bots. You can use your Jabber bots to
+provide information about your running systems, to make your website
+interact with your visitors or notify you about updates or changes
+you monitor with your Python scripts.
+
+WWW: http://thpinfo.com/2007/python-jabberbot/
diff --git a/net-im/py-jabberbot/pkg-plist b/net-im/py-jabberbot/pkg-plist
new file mode 100644
index 000000000000..b2625272c997
--- /dev/null
+++ b/net-im/py-jabberbot/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/jabberbot.py
+%%PYTHON_SITELIBDIR%%/jabberbot.pyc
+%%PYTHON_SITELIBDIR%%/jabberbot.pyo