aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-06 18:47:30 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-06 18:47:30 +0800
commit81470361420a04f046c2a88fc9c5ceb075656226 (patch)
tree7d7d0c706f97596f5c42dce4c55910a68b5a67a9
parent89b5fb7419baea667d2943c19762e56cc9442862 (diff)
downloadfreebsd-ports-gnome-81470361420a04f046c2a88fc9c5ceb075656226.tar.gz
freebsd-ports-gnome-81470361420a04f046c2a88fc9c5ceb075656226.tar.zst
freebsd-ports-gnome-81470361420a04f046c2a88fc9c5ceb075656226.zip
- Support staging
- Convert to new options framework - Use shebangfix
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/Makefile16
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/pkg-plist3
2 files changed, 10 insertions, 9 deletions
diff --git a/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/Makefile b/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/Makefile
index 3694c08abafd..0e1fca38bae6 100644
--- a/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/Makefile
@@ -20,16 +20,18 @@ RUN_DEPENDS:= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
p5-Net-IP>=1.25:${PORTSDIR}/net-mgmt/p5-Net-IP
PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= configure
-MAN3= POE::Component::IRC::Plugin::QueryDNSBL.3
+SHEBANG_FILES= examples/*.pl
+PORTEXAMPLES= *
+
+OPTIONS_DEFINE= EXAMPLES
+
+.include <bsd.port.options.mk>
-NO_STAGE= yes
post-install:
-.ifndef(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/pkg-plist b/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/pkg-plist
index 0fc61ebe531c..7797eb46e898 100644
--- a/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/pkg-plist
+++ b/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/pkg-plist
@@ -1,7 +1,6 @@
%%SITE_PERL%%/POE/Component/IRC/Plugin/QueryDNSBL.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/QueryDNSBL/.packlist
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/synopsis.pl
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PERL5_MAN3%%/POE::Component::IRC::Plugin::QueryDNSBL.3.gz
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/QueryDNSBL
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC