aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2012-07-23 19:47:11 +0800
committervd <vd@FreeBSD.org>2012-07-23 19:47:11 +0800
commit81da431d62995c28e5fce2d65d8898931973dd55 (patch)
treeeab5dc23ec25170b7ae743b505b66662868732d1
parent018a18ad467359d77b25fc8e83b500a2f4a961f5 (diff)
downloadfreebsd-ports-gnome-81da431d62995c28e5fce2d65d8898931973dd55.tar.gz
freebsd-ports-gnome-81da431d62995c28e5fce2d65d8898931973dd55.tar.zst
freebsd-ports-gnome-81da431d62995c28e5fce2d65d8898931973dd55.zip
Upgrade graphics/enblend from 3.1 to 4.0.
Pass maintainership to submitter. Submitted by: grog@
-rw-r--r--graphics/enblend/Makefile29
-rw-r--r--graphics/enblend/distinfo4
-rw-r--r--graphics/enblend/files/patch-png.cxx67
3 files changed, 52 insertions, 48 deletions
diff --git a/graphics/enblend/Makefile b/graphics/enblend/Makefile
index 1e3c3b3836f5..15b8b7052f61 100644
--- a/graphics/enblend/Makefile
+++ b/graphics/enblend/Makefile
@@ -6,26 +6,31 @@
#
PORTNAME= enblend
-PORTVERSION= 3.1.r20080615
-PORTREVISION= 7
+PORTVERSION= 4.0
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= vd/enblend
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= enblend/enblend-enfuse/enblend-enfuse-${PORTVERSION}
+DISTNAME= enblend-enfuse-${PORTVERSION}
-MAINTAINER= vd@FreeBSD.org
+MAINTAINER= grog@FreeBSD.org
COMMENT= A tool for image blending with multiresolution splines
BUILD_DEPENDS= ${LOCALBASE}/include/boost/pool/pool.hpp:${PORTSDIR}/devel/boost-libs \
+ ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo \
OpenEXR>=1.0:${PORTSDIR}/graphics/OpenEXR
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
lcms:${PORTSDIR}/graphics/lcms \
- xmi.1:${PORTSDIR}/graphics/plotutils \
- tiff.4:${PORTSDIR}/graphics/tiff
+ xmi:${PORTSDIR}/graphics/plotutils \
+ tiff:${PORTSDIR}/graphics/tiff
RUN_DEPENDS= OpenEXR>=1.0:${PORTSDIR}/graphics/OpenEXR
-USE_BZIP2= yes
+WRKSRC= ${WRKDIR}/enblend-enfuse-4.0-753b534c819d
USE_AUTOTOOLS= automake:env autoconf:env
+USE_GMAKE= yes
+# We need a newer version of makinfo for this.
+# Remove this line when we remove texinfo from the base system.
+CONFIGURE_ARGS= MAKEINFO="${LOCALBASE}/bin/makeinfo"
# GCC 4.2 has some problems, see
# http://groups.google.com/group/hugin-ptx/browse_thread/thread/725b1581c9889e37/50abe3387d61541a#50abe3387d61541a
@@ -33,14 +38,14 @@ USE_AUTOTOOLS= automake:env autoconf:env
USE_GCC= 4.4+
USE_GL= glew glut
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAN1= enblend.1 enfuse.1
PLIST_FILES= bin/enblend bin/enfuse
# run autotools
-pre-configure:
- cd ${WRKSRC} && ${MAKE} -f Makefile.cvs
+#pre-configure:
+# cd ${WRKSRC} && ${MAKE} -f Makefile.cvs
.include <bsd.port.mk>
diff --git a/graphics/enblend/distinfo b/graphics/enblend/distinfo
index 71ef081d7ee4..74b23745bbed 100644
--- a/graphics/enblend/distinfo
+++ b/graphics/enblend/distinfo
@@ -1,2 +1,2 @@
-SHA256 (enblend-3.1.r20080615.tar.bz2) = 12c8518815a12c10ff12058f1ece8858ae4a0ee40c670656d0cfd8be11ca8ae2
-SIZE (enblend-3.1.r20080615.tar.bz2) = 502116
+SHA256 (enblend-enfuse-4.0.tar.gz) = a12a44c2a07894f27e1d5a1675728175a943c89b91c1ac9abacce62f08c253c4
+SIZE (enblend-enfuse-4.0.tar.gz) = 1046677
diff --git a/graphics/enblend/files/patch-png.cxx b/graphics/enblend/files/patch-png.cxx
index 44c19933dc57..b8ec1bd5147f 100644
--- a/graphics/enblend/files/patch-png.cxx
+++ b/graphics/enblend/files/patch-png.cxx
@@ -1,14 +1,6 @@
---- src/vigra_impex/png.cxx.orig 2007-11-25 00:46:55.000000000 +0100
-+++ src/vigra_impex/png.cxx 2012-05-27 11:57:18.000000000 +0200
-@@ -64,6 +64,7 @@
- extern "C"
- {
- #include <png.h>
-+#include <pngpriv.h>
- }
-
- #if PNG_LIBPNG_VER < 10201
-@@ -82,7 +83,7 @@
+--- ./src/vigra_impex/png.cxx.orig 2009-12-20 17:32:28.000000000 +0200
++++ ./src/vigra_impex/png.cxx 2012-07-23 14:20:14.000000000 +0300
+@@ -81,7 +81,7 @@
static void PngError( png_structp png_ptr, png_const_charp error_msg )
{
png_error_message = std::string(error_msg);
@@ -17,7 +9,7 @@
}
// called on non-fatal errors
-@@ -214,7 +215,7 @@
+@@ -213,7 +213,7 @@
vigra_postcondition( png != 0, "could not create the read struct." );
// create info struct
@@ -26,7 +18,7 @@
png_destroy_read_struct( &png, &info, NULL );
vigra_postcondition( false, png_error_message.insert(0, "error in png_create_info_struct(): ").c_str() );
}
-@@ -222,14 +223,14 @@
+@@ -221,14 +221,14 @@
vigra_postcondition( info != 0, "could not create the info struct." );
// init png i/o
@@ -43,7 +35,7 @@
png_destroy_read_struct( &png, &info, NULL );
vigra_postcondition( false, png_error_message.insert(0, "error in png_set_sig_bytes(): ").c_str() );
}
-@@ -245,13 +246,13 @@
+@@ -244,13 +244,13 @@
void PngDecoderImpl::init()
{
// read all chunks up to the image data
@@ -59,7 +51,7 @@
vigra_postcondition( false, png_error_message.insert(0, "error in png_get_IHDR(): ").c_str() );
png_get_IHDR( png, info, &width, &height, &bit_depth, &color_type,
&interlace_method, &compression_method, &filter_method );
-@@ -265,7 +266,7 @@
+@@ -264,7 +264,7 @@
// transform palette to rgb
if ( color_type == PNG_COLOR_TYPE_PALETTE) {
@@ -68,7 +60,7 @@
vigra_postcondition( false, png_error_message.insert(0, "error in png_palette_to_rgb(): ").c_str() );
png_set_palette_to_rgb(png);
color_type = PNG_COLOR_TYPE_RGB;
-@@ -274,9 +275,9 @@
+@@ -273,9 +273,9 @@
// expand gray values to at least one byte size
if ( color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8 ) {
@@ -80,7 +72,7 @@
bit_depth = 8;
}
-@@ -284,7 +285,7 @@
+@@ -283,7 +283,7 @@
#if 0
// strip alpha channel
if ( color_type & PNG_COLOR_MASK_ALPHA ) {
@@ -89,16 +81,23 @@
vigra_postcondition( false, png_error_message.insert(0, "error in png_set_strip_alpha(): ").c_str() );
png_set_strip_alpha(png);
color_type ^= PNG_COLOR_MASK_ALPHA;
-@@ -326,7 +327,7 @@
+@@ -325,12 +325,9 @@
#if (PNG_LIBPNG_VER > 10008) && defined(PNG_READ_iCCP_SUPPORTED)
char * dummyName;
int dummyCompType;
- char * profilePtr;
-+ png_byte * profilePtr;
- png_uint_32 profileLen;
- if (info->valid & PNG_INFO_iCCP) {
- png_get_iCCP(png, info, &dummyName, &dummyCompType, &profilePtr, &profileLen) ;
-@@ -341,7 +342,7 @@
+- png_uint_32 profileLen;
+- if (info->valid & PNG_INFO_iCCP) {
+- png_get_iCCP(png, info, &dummyName, &dummyCompType, &profilePtr, &profileLen) ;
+- iccProfilePtr = (unsigned char *) profilePtr;
+- iccProfileLength = profileLen;
++ if (png_get_valid(png, info, PNG_INFO_iCCP)) {
++ png_get_iCCP(png, info, &dummyName, &dummyCompType,
++ (unsigned char **) &iccProfilePtr, &iccProfileLength) ;
+ }
+ #endif
+
+@@ -340,7 +337,7 @@
// image gamma
double image_gamma = 0.45455;
if ( png_get_valid( png, info, PNG_INFO_gAMA ) ) {
@@ -107,7 +106,7 @@
vigra_postcondition( false, png_error_message.insert(0, "error in png_get_gAMA(): ").c_str() );
png_get_gAMA( png, info, &image_gamma );
}
-@@ -350,26 +351,26 @@
+@@ -349,26 +346,26 @@
double screen_gamma = 2.2;
// set gamma correction
@@ -139,7 +138,7 @@
vigra_postcondition( false,png_error_message.insert(0, "error in png_get_rowbytes(): ").c_str());
rowsize = png_get_rowbytes(png, info);
-@@ -380,7 +381,7 @@
+@@ -379,7 +376,7 @@
void PngDecoderImpl::nextScanline()
{
for (int i=0; i < n_interlace_passes; i++) {
@@ -148,7 +147,7 @@
vigra_postcondition( false,png_error_message.insert(0, "error in png_read_row(): ").c_str());
png_read_row(png, row_data.begin(), NULL);
}
-@@ -546,7 +547,7 @@
+@@ -545,7 +542,7 @@
vigra_postcondition( png != 0, "could not create the write struct." );
// create info struct
@@ -157,7 +156,7 @@
png_destroy_write_struct( &png, &info );
vigra_postcondition( false, png_error_message.insert(0, "error in png_info_struct(): ").c_str() );
}
-@@ -557,7 +558,7 @@
+@@ -556,7 +553,7 @@
}
// init png i/o
@@ -166,7 +165,7 @@
png_destroy_write_struct( &png, &info );
vigra_postcondition( false, png_error_message.insert(0, "error in png_init_io(): ").c_str() );
}
-@@ -572,7 +573,7 @@
+@@ -571,7 +568,7 @@
void PngEncoderImpl::finalize()
{
// write the IHDR
@@ -175,16 +174,16 @@
vigra_postcondition( false, png_error_message.insert(0, "error in png_set_IHDR(): ").c_str() );
png_set_IHDR( png, info, width, height, bit_depth, color_type,
PNG_INTERLACE_NONE, PNG_COMPRESSION_TYPE_DEFAULT,
-@@ -580,7 +581,7 @@
+@@ -579,7 +576,7 @@
// set resolution
if (x_resolution > 0 && y_resolution > 0) {
- if (setjmp(png->jmpbuf))
+ if (setjmp(png_jmpbuf(png)))
vigra_postcondition( false, png_error_message.insert(0, "error in png_set_pHYs(): ").c_str() );
- png_set_pHYs(png, info, (png_uint_32) (x_resolution * 254 + 0.5),
- (png_uint_32) (y_resolution * 254 + 0.5),
-@@ -589,7 +590,7 @@
+ png_set_pHYs(png, info, (png_uint_32) (x_resolution / 0.0254 + 0.5),
+ (png_uint_32) (y_resolution / 0.0254 + 0.5),
+@@ -588,7 +585,7 @@
// set offset
if (position.x > 0 && position.y > 0) {
@@ -193,7 +192,7 @@
vigra_postcondition( false, png_error_message.insert(0, "error in png_set_oFFs(): ").c_str() );
png_set_oFFs(png, info, position.x, position.y, PNG_OFFSET_PIXEL);
}
-@@ -598,12 +599,12 @@
+@@ -597,12 +594,12 @@
// set icc profile
if (iccProfile.size() > 0) {
png_set_iCCP(png, info, "icc", 0,
@@ -208,7 +207,7 @@
vigra_postcondition( false, png_error_message.insert(0, "error in png_write_info(): ").c_str() );
png_write_info( png, info );
-@@ -635,10 +636,10 @@
+@@ -634,10 +631,10 @@
}
// write the whole image