aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2011-06-22 07:13:11 +0800
committerehaupt <ehaupt@FreeBSD.org>2011-06-22 07:13:11 +0800
commit82860081442133bb5cbbf9dd3b19515d9e181900 (patch)
tree8be1edc906f8ce021bc898207a58e18c2b999ce7
parent26e93388f6e6cf24b6d2fb889798e1b88b166270 (diff)
downloadfreebsd-ports-gnome-82860081442133bb5cbbf9dd3b19515d9e181900.tar.gz
freebsd-ports-gnome-82860081442133bb5cbbf9dd3b19515d9e181900.tar.zst
freebsd-ports-gnome-82860081442133bb5cbbf9dd3b19515d9e181900.zip
Make port build with clang. While we're here add an additional distfile
mirror and get rid of custom do-build target. PR: 158136 Submitted by: Niclas Zeising <niclas.zeising@gmail.com>
-rw-r--r--x11-fm/xdiskusage/Makefile11
-rw-r--r--x11-fm/xdiskusage/files/patch-xdiskusage.C26
2 files changed, 31 insertions, 6 deletions
diff --git a/x11-fm/xdiskusage/Makefile b/x11-fm/xdiskusage/Makefile
index fbef0fddf3f5..766dfb74b6c7 100644
--- a/x11-fm/xdiskusage/Makefile
+++ b/x11-fm/xdiskusage/Makefile
@@ -9,7 +9,8 @@ PORTNAME= xdiskusage
PORTVERSION= 1.48
PORTREVISION= 6
CATEGORIES= x11-fm
-MASTER_SITES= http://xdiskusage.sourceforge.net/
+MASTER_SITES= http://xdiskusage.sourceforge.net/ \
+ http://www.gnu-darwin.org/distfiles/
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
@@ -19,15 +20,17 @@ LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
USE_GMAKE= yes
+CXXFLAGS+= `fltk-config --cxxflags`
+LDFLAGS+= `fltk-config --ldflags`
+
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+
PLIST_FILES= bin/xdiskusage
MAN1= xdiskusage.1
post-patch:
${REINPLACE_CMD} -e '22,24d' ${WRKSRC}/Makefile
-do-build:
- cd ${WRKSRC} && ${GMAKE} CXXFLAGS="`fltk-config --cxxflags`" LDFLAGS="`fltk-config --ldflags`"
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xdiskusage ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/xdiskusage.1 ${MANPREFIX}/man/man1
diff --git a/x11-fm/xdiskusage/files/patch-xdiskusage.C b/x11-fm/xdiskusage/files/patch-xdiskusage.C
index 7a24da6f7b3f..2da95c129959 100644
--- a/x11-fm/xdiskusage/files/patch-xdiskusage.C
+++ b/x11-fm/xdiskusage/files/patch-xdiskusage.C
@@ -1,5 +1,27 @@
---- xdiskusage.C.orig 2008-09-15 19:21:03.000000000 +0000
-+++ xdiskusage.C 2008-09-15 19:23:54.000000000 +0000
+--- xdiskusage.C.orig 2004-09-21 07:23:14.000000000 +0200
++++ xdiskusage.C 2011-06-21 21:34:20.000000000 +0200
+@@ -392,8 +392,8 @@
+ strncpy(pathbuf, path, 1024);
+ for (int i=0; i<10; i++) {
+ char *p = (char*)fl_filename_name(pathbuf);
+- int i = readlink(pathbuf, p, 1024-(p-pathbuf));
+- if (i < 0) {
++ int j = readlink(pathbuf, p, 1024-(p-pathbuf));
++ if (j < 0) {
+ if (errno != EINVAL) {
+ strcat(pathbuf, ": no such file");
+ fl_alert(pathbuf);
+@@ -401,8 +401,8 @@
+ }
+ break;
+ }
+- if (*p == '/') {memmove(pathbuf, p, i); p = pathbuf;}
+- p[i] = 0;
++ if (*p == '/') {memmove(pathbuf, p, j); p = pathbuf;}
++ p[j] = 0;
+ path = pathbuf;
+ }
+ }
@@ -988,7 +988,7 @@
void OutputWindow::sort_cb(Fl_Widget* o, void*v) {
OutputWindow* d = (OutputWindow*)(o->window());