aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-11-15 23:59:23 +0800
committermat <mat@FreeBSD.org>2013-11-15 23:59:23 +0800
commit834d2875b30ca2302431a3a14fd5df86855dc3d0 (patch)
tree4f9cf907c88e2c6042261d603e8bb3e057bb5774
parent73c1151016c6f7ff9b4d2dc01820a1f4bd96334a (diff)
downloadfreebsd-ports-gnome-834d2875b30ca2302431a3a14fd5df86855dc3d0.tar.gz
freebsd-ports-gnome-834d2875b30ca2302431a3a14fd5df86855dc3d0.tar.zst
freebsd-ports-gnome-834d2875b30ca2302431a3a14fd5df86855dc3d0.zip
Add p5-Pod-WikiDoc 0.20, generate Pod from inline wiki style text.
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Pod-WikiDoc/Makefile25
-rw-r--r--textproc/p5-Pod-WikiDoc/distinfo2
-rw-r--r--textproc/p5-Pod-WikiDoc/pkg-descr7
-rw-r--r--textproc/p5-Pod-WikiDoc/pkg-plist14
5 files changed, 49 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 9e2bc6dc2dd6..bf3b6257e15a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -669,6 +669,7 @@
SUBDIR += p5-Pod-Stripper
SUBDIR += p5-Pod-Tree
SUBDIR += p5-Pod-WSDL
+ SUBDIR += p5-Pod-WikiDoc
SUBDIR += p5-Pod-XML
SUBDIR += p5-Pod-Xhtml
SUBDIR += p5-RADIUS-UserFile
diff --git a/textproc/p5-Pod-WikiDoc/Makefile b/textproc/p5-Pod-WikiDoc/Makefile
new file mode 100644
index 000000000000..5deb5aebbcd8
--- /dev/null
+++ b/textproc/p5-Pod-WikiDoc/Makefile
@@ -0,0 +1,25 @@
+# Created by: Mathieu Arnold <mat@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Pod-WikiDoc
+PORTVERSION= 0.20
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Generate Pod from inline wiki style text
+
+LICENSE= AL2
+
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-File-pushd>=0:${PORTSDIR}/devel/p5-File-pushd \
+ p5-Getopt-Lucid>=0.14:${PORTSDIR}/textproc/p5-Getopt-Lucid \
+ p5-IPC-Run3>=0.033:${PORTSDIR}/devel/p5-IPC-Run3 \
+ p5-Parse-RecDescent>=1.967.006:${PORTSDIR}/devel/p5-Parse-RecDescent \
+ p5-Probe-Perl>=0.01:${PORTSDIR}/sysutils/p5-Probe-Perl
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Pod-WikiDoc/distinfo b/textproc/p5-Pod-WikiDoc/distinfo
new file mode 100644
index 000000000000..5da2f17828c6
--- /dev/null
+++ b/textproc/p5-Pod-WikiDoc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Pod-WikiDoc-0.20.tar.gz) = 448c34604b41a5142f03d2c783cd18c00123458586c79d8bd1f1c550ace85dd9
+SIZE (Pod-WikiDoc-0.20.tar.gz) = 39431
diff --git a/textproc/p5-Pod-WikiDoc/pkg-descr b/textproc/p5-Pod-WikiDoc/pkg-descr
new file mode 100644
index 000000000000..ea3409dfef02
--- /dev/null
+++ b/textproc/p5-Pod-WikiDoc/pkg-descr
@@ -0,0 +1,7 @@
+Pod works well, but writing it can be time-consuming and tedious. For example,
+commonly used layouts like lists require numerous lines of text to make just a
+couple of simple points. An alternative approach is to write documentation in
+a wiki-text shorthand (referred to here as wikidoc) and use Pod::WikiDoc to
+extract it and convert it into its corresponding Pod as a separate .pod file.
+
+WWW: http://search.cpan.org/dist/Pod-WikiDoc/
diff --git a/textproc/p5-Pod-WikiDoc/pkg-plist b/textproc/p5-Pod-WikiDoc/pkg-plist
new file mode 100644
index 000000000000..460ddada1b80
--- /dev/null
+++ b/textproc/p5-Pod-WikiDoc/pkg-plist
@@ -0,0 +1,14 @@
+bin/wikidoc
+man/man1/wikidoc.1.gz
+%%PERL5_MAN3%%/Pod::WikiDoc.3.gz
+%%PERL5_MAN3%%/Pod::WikiDoc::Cookbook.3.gz
+%%PERL5_MAN3%%/Pod::WikiDoc::Parser.3.gz
+%%SITE_PERL%%/Pod/WikiDoc.pm
+%%SITE_PERL%%/Pod/WikiDoc/Cookbook.pod
+%%SITE_PERL%%/Pod/WikiDoc/Parser.pm
+%%SITE_PERL%%/Pod/WikiDoc/Parser.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/WikiDoc/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/WikiDoc
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod
+@dirrm %%SITE_PERL%%/Pod/WikiDoc
+@dirrmtry %%SITE_PERL%%/Pod