aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2003-11-11 12:09:42 +0800
committeranholt <anholt@FreeBSD.org>2003-11-11 12:09:42 +0800
commit838b13ace5aa31e39a0c4a001e2ee1d8ff567935 (patch)
tree91cc6e7ec764df6aedf2ac469487e98bb303bedf
parentd6c3efac7699eeda34946698d6617163e11b378b (diff)
downloadfreebsd-ports-gnome-838b13ace5aa31e39a0c4a001e2ee1d8ff567935.tar.gz
freebsd-ports-gnome-838b13ace5aa31e39a0c4a001e2ee1d8ff567935.tar.zst
freebsd-ports-gnome-838b13ace5aa31e39a0c4a001e2ee1d8ff567935.zip
Disable the patch from XFree86 bug 641 to copy the terminal's settings in
luit to its new pty. This code doesn't work for some reason and produces "Couldn't copy terminal settings" when luit is run manually or the symptom of an xterm -lc flashing on screen and exiting. Submitted by: Guido Berhoerster <ich@guido-berhoerster.org>
-rw-r--r--x11/XFree86-4-clients/Makefile2
-rw-r--r--x11/XFree86-4-libraries/files/patch-luit4
2 files changed, 3 insertions, 3 deletions
diff --git a/x11/XFree86-4-clients/Makefile b/x11/XFree86-4-clients/Makefile
index 6b9ae3f549a5..932afed3ee41 100644
--- a/x11/XFree86-4-clients/Makefile
+++ b/x11/XFree86-4-clients/Makefile
@@ -7,7 +7,7 @@
PORTNAME= clients
PORTVERSION= 4.3.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_XFREE}
MASTER_SITE_SUBDIR= 4.3.0
diff --git a/x11/XFree86-4-libraries/files/patch-luit b/x11/XFree86-4-libraries/files/patch-luit
index 2962f4e7a711..a86b255f889c 100644
--- a/x11/XFree86-4-libraries/files/patch-luit
+++ b/x11/XFree86-4-libraries/files/patch-luit
@@ -43,10 +43,10 @@ diff -u -u -r1.10 -r1.11
#endif
installHandler(SIGCHLD, sigchldHandler);
-+ rc = copyTermios(0, pty);
++ /*rc = copyTermios(0, pty);
+ if(rc < 0)
+ FatalError("Couldn't copy terminal settings\n");
-+
++ */ /* Disabled, appears to break luit. */
rc = setRawTermios();
if(rc < 0)
FatalError("Couldn't set terminal to raw\n");