aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormanu <manu@FreeBSD.org>2018-03-22 00:12:09 +0800
committermanu <manu@FreeBSD.org>2018-03-22 00:12:09 +0800
commit84014c87d91898ff958e474a1207e179998b7259 (patch)
tree89a535370b42308eca1f63f22742a332800be47c
parentbd1fda2510d8f364579a6a210d540eabb82fa08e (diff)
downloadfreebsd-ports-gnome-84014c87d91898ff958e474a1207e179998b7259.tar.gz
freebsd-ports-gnome-84014c87d91898ff958e474a1207e179998b7259.tar.zst
freebsd-ports-gnome-84014c87d91898ff958e474a1207e179998b7259.zip
Add PSCI monitor to sysutils/rpi-firmware
Build PSCI monitor and add it to common firmware files for RaspberrPi platform. This is pre-requisite for migration of sysutils/u-boot-rpi3 to u-boot-master framework. Submitted by: gonzo Reviewed by: bapt Approved by: bapt Differential Revision: https://reviews.freebsd.org/D14629
-rw-r--r--sysutils/rpi-firmware/Makefile18
-rw-r--r--sysutils/rpi-firmware/distinfo4
-rw-r--r--sysutils/rpi-firmware/pkg-plist1
3 files changed, 16 insertions, 7 deletions
diff --git a/sysutils/rpi-firmware/Makefile b/sysutils/rpi-firmware/Makefile
index eefcc3f584ca..58062151ffe0 100644
--- a/sysutils/rpi-firmware/Makefile
+++ b/sysutils/rpi-firmware/Makefile
@@ -2,7 +2,7 @@
PORTNAME= rpi-firmware
PORTVERSION= 1.20171029
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MAINTAINER= manu@freebsd.org
@@ -13,12 +13,17 @@ LICENSE_NAME= Broadcom Corporation
LICENSE_FILE= ${WRKSRC}/boot/LICENCE.broadcom
LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-accept
-USE_GITHUB= yes
-GH_ACCOUNT= raspberrypi
-GH_PROJECT= firmware
-
-NO_BUILD= yes
+BUILD_DEPENDS= aarch64-none-elf-gcc:devel/aarch64-none-elf-gcc
+USE_GITHUB= yes
+GH_ACCOUNT= raspberrypi gonzoua:pscimon
+GH_PROJECT= firmware rpi3-psci-monitor:pscimon
+PSCI_TAG= 2b8890a
+GH_TAGNAME= ${PSCI_TAG}:pscimon
+PSCI_MONITOR= rpi3-psci-monitor-${PSCI_TAG}
+PSCI_DIR= ${WRKDIR}/${PSCI_MONITOR}
+
+BUILD_WRKSRC= ${PSCI_DIR}
INSTALL_DIR= ${PREFIX}/share/${PORTNAME}
do-patch:
@@ -31,5 +36,6 @@ post-patch:
do-install:
${MKDIR} -p ${STAGEDIR}/${INSTALL_DIR}
cd ${WRKSRC}/boot && ${COPYTREE_SHARE} . ${STAGEDIR}/${INSTALL_DIR}/
+ ${INSTALL_DATA} ${PSCI_DIR}/armstub8.bin ${STAGEDIR}/${INSTALL_DIR}/
.include <bsd.port.mk>
diff --git a/sysutils/rpi-firmware/distinfo b/sysutils/rpi-firmware/distinfo
index 47cc190a4c21..58cb794706cf 100644
--- a/sysutils/rpi-firmware/distinfo
+++ b/sysutils/rpi-firmware/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1510423514
+TIMESTAMP = 1520553310
SHA256 (raspberrypi-firmware-1.20171029_GH0.tar.gz) = 46ce28c8d87ef22bdcc57ac1836ca3f04d1ec6f46580ff5a30bf76b3c0822117
SIZE (raspberrypi-firmware-1.20171029_GH0.tar.gz) = 120793811
+SHA256 (gonzoua-rpi3-psci-monitor-2b8890a_GH0.tar.gz) = a7b89678adea178359646a1e95a078d5c60d23821ba355f27f14ed7b28f32f4d
+SIZE (gonzoua-rpi3-psci-monitor-2b8890a_GH0.tar.gz) = 5115
diff --git a/sysutils/rpi-firmware/pkg-plist b/sysutils/rpi-firmware/pkg-plist
index b4921fc10967..5771ff092ed0 100644
--- a/sysutils/rpi-firmware/pkg-plist
+++ b/sysutils/rpi-firmware/pkg-plist
@@ -1,5 +1,6 @@
%%DATADIR%%/COPYING.linux
%%DATADIR%%/LICENCE.broadcom
+%%DATADIR%%/armstub8.bin
%%DATADIR%%/bcm2708-rpi-0-w.dtb
%%DATADIR%%/bcm2708-rpi-b-plus.dtb
%%DATADIR%%/bcm2708-rpi-b.dtb