aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-04-10 22:02:52 +0800
committerpav <pav@FreeBSD.org>2004-04-10 22:02:52 +0800
commit841bb0b251eb0062091d49ba57106d7f8d767dd5 (patch)
treea3cce68b0bd7752f026a4e2be58b619059671501
parent270cff4eae15aa2d82e033ad571c227fc2520075 (diff)
downloadfreebsd-ports-gnome-841bb0b251eb0062091d49ba57106d7f8d767dd5.tar.gz
freebsd-ports-gnome-841bb0b251eb0062091d49ba57106d7f8d767dd5.tar.zst
freebsd-ports-gnome-841bb0b251eb0062091d49ba57106d7f8d767dd5.zip
- Fix detect of wchar_t on FreeBSD. Using _BSD_CT_RUNE_T_ is not sufficient
for some version of FreeBSD, rather test on __FreeBSD__. This problem prevent other programs to include iodbc's header files on -STABLE systems. PR: ports/64743 Submitted by: eik Approved by: maintainer timeout (2 weeks)
-rw-r--r--databases/libiodbc/Makefile2
-rw-r--r--databases/libiodbc/files/patch-include::sqltypes.h10
2 files changed, 11 insertions, 1 deletions
diff --git a/databases/libiodbc/Makefile b/databases/libiodbc/Makefile
index c75ab3ab4bea..f52c1f610870 100644
--- a/databases/libiodbc/Makefile
+++ b/databases/libiodbc/Makefile
@@ -10,7 +10,7 @@
PORTNAME= libiodbc
PORTVERSION= 3.51.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= databases
MASTER_SITES= http://www.iodbc.org/downloads/iODBC/
diff --git a/databases/libiodbc/files/patch-include::sqltypes.h b/databases/libiodbc/files/patch-include::sqltypes.h
new file mode 100644
index 000000000000..b1f5ecbd2350
--- /dev/null
+++ b/databases/libiodbc/files/patch-include::sqltypes.h
@@ -0,0 +1,10 @@
+--- include/sqltypes.h.orig Fri Mar 26 08:33:24 2004
++++ include/sqltypes.h Fri Mar 26 08:33:37 2004
+@@ -409,6 +409,7 @@
+ # if defined(_WCHAR_T) || \
+ defined(_WCHAR_T_DEFINED) || \
+ defined(_WCHAR_T_DECLARED) || \
++ defined(__FreeBSD__) || \
+ defined(_BSD_WCHAR_T_DEFINED_)
+ typedef wchar_t SQLWCHAR;
+ # else