aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-03-24 21:26:18 +0800
committerbapt <bapt@FreeBSD.org>2014-03-24 21:26:18 +0800
commit8438e8b36b502c9305c0a116e79f3d5c218a6612 (patch)
tree4d431ffd8de2add1dbc55451498af8f29916efa3
parent287a32ae583277b1cb8dd6d024b56b282ab1d88d (diff)
downloadfreebsd-ports-gnome-8438e8b36b502c9305c0a116e79f3d5c218a6612.tar.gz
freebsd-ports-gnome-8438e8b36b502c9305c0a116e79f3d5c218a6612.tar.zst
freebsd-ports-gnome-8438e8b36b502c9305c0a116e79f3d5c218a6612.zip
Switch to wx 2.8
Support stage
-rw-r--r--misc/metalink-editor/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/misc/metalink-editor/Makefile b/misc/metalink-editor/Makefile
index 7b4cb5d0766e..de7bd212506b 100644
--- a/misc/metalink-editor/Makefile
+++ b/misc/metalink-editor/Makefile
@@ -15,13 +15,16 @@ COMMENT= GUI editor to create and edit metalinks
LICENSE= GPLv2
LICENSE_FILE= ${WRKDIR}/license.txt
+OPTIONS_DEFINE= DOCS
+
USES= dos2unix zip
DOS2UNIX_REGEX= .*\.txt
NO_WRKSUBDIR= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_EGGINFO= metalink_editor-${PORTVERSION}-py${PYTHON_VER}.egg-info
-USE_WX= 2.6
+USE_WX= 2.8
+WX_UNICODE= yes
WX_COMPS= python
DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
@@ -39,11 +42,8 @@ DESKTOP_ENTRIES= "Metalink editor" \
DOC_FILES= \
readme.txt
#
-.ifndef(NOPORTDOCS)
PORTDOCS= *
-.endif
-NO_STAGE= yes
post-extract:
# Create a package to avoid namespace pollution
@${MKDIR} ${WRKSRC}/Metalink_editor
@@ -66,16 +66,14 @@ pre-configure:
post-install:
# docs
-.ifndef(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ${DOC_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
# fix installation permissions for restritive umask(1)
@${FIND} \
- ${DATADIR} \
- ${PYTHONPREFIX_SITELIBDIR}/Metalink_editor \
+ ${STAGEDIR}${DATADIR} \
+ ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/Metalink_editor \
-type f -exec \
${CHMOD} ${SHAREMODE} {} \;