aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-12-15 06:19:14 +0800
committerAntoine Brodin <antoine@FreeBSD.org>2013-12-15 06:19:14 +0800
commit84895fe89fb1b1d048e9e67e8086be3650b001ed (patch)
tree31fdc3567b77b28ea33c3420a0fb2aba81754838
parent73d4f985b196890ea0a5ec1fd91665033a5a7d37 (diff)
downloadfreebsd-ports-gnome-84895fe89fb1b1d048e9e67e8086be3650b001ed.tar.gz
freebsd-ports-gnome-84895fe89fb1b1d048e9e67e8086be3650b001ed.tar.zst
freebsd-ports-gnome-84895fe89fb1b1d048e9e67e8086be3650b001ed.zip
- Update to 0.25
- No stage support yet, .elc files embed the path of the .el file, not sure if it is stage safe or not PR: ports/182563 Submitted by: Max Sterling Approved by: maintainer
-rw-r--r--devel/pymacs/Makefile24
-rw-r--r--devel/pymacs/distinfo4
-rw-r--r--devel/pymacs/pkg-message8
-rw-r--r--devel/pymacs/pkg-plist29
4 files changed, 19 insertions, 46 deletions
diff --git a/devel/pymacs/Makefile b/devel/pymacs/Makefile
index 3af3c99571cd..fd4cb50cb690 100644
--- a/devel/pymacs/Makefile
+++ b/devel/pymacs/Makefile
@@ -2,12 +2,9 @@
# $FreeBSD$
PORTNAME= Pymacs
-PORTVERSION= 0.22
-PORTREVISION= 6
+PORTVERSION= 0.25
CATEGORIES= devel editors python elisp
-MASTER_SITES= http://pymacs.progiciels-bpi.ca/archives/ \
- ${MASTER_SITE_GENTOO}
-MASTER_SITE_SUBDIR= distfiles
+MASTER_SITES= http://github.com/pinard/${PORTNAME}/archive/v${PORTVERSION}.tar.gz?dummy=/
MAINTAINER= mwm@mired.org
COMMENT= A Python package for scripting emacs
@@ -16,21 +13,18 @@ USE_PYTHON= yes
USE_PYDISTUTILS=yes
USE_PYTHON_PREFIX= yes
USE_EMACS= yes
-
-.if !defined(EMACS_PORT_NAME)
-EMACS_PORT_NAME=xemacs21
-.endif
+FETCH_ARGS= -Fpr
NO_STAGE= yes
-post-patch:
-.for f in __init__.py pymacs.py
- ${REINPLACE_CMD} -e 's,# Copyright,# coding:latin1 Copyright,g' \
- ${WRKSRC}/Pymacs/$f
-.endfor
+pre-configure:
+ @(cd ${WRKSRC}; \
+ ${PYTHON_CMD} pppp -C ppppconfig.py Pymacs.py.in \
+ pppp.rst.in pymacs.el.in pymacs.rst.in \
+ contrib tests)
# Install the emacs side of things
post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/pymacs.el ${PREFIX}/${EMACS_SITE_LISPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/pymacs.el ${PREFIX}/${EMACS_SITE_LISPDIR}
${EMACS_NAME} -batch -f batch-byte-compile \
${PREFIX}/${EMACS_SITE_LISPDIR}/pymacs.el
diff --git a/devel/pymacs/distinfo b/devel/pymacs/distinfo
index e049ed67cb53..9e993d89d393 100644
--- a/devel/pymacs/distinfo
+++ b/devel/pymacs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Pymacs-0.22.tar.gz) = 71b465f81366a4bea4a519781e1d9cb1ad067280e86f9b385d57b74c32bf7a75
-SIZE (Pymacs-0.22.tar.gz) = 363119
+SHA256 (Pymacs-0.25.tar.gz) = bcb1af7f55c5a4c050f41413e54d7d1f3c9bf8febebd99792f4aa45cd8f41c8f
+SIZE (Pymacs-0.25.tar.gz) = 120554
diff --git a/devel/pymacs/pkg-message b/devel/pymacs/pkg-message
index 9c9e5b3a7e1d..5b0e82acb11f 100644
--- a/devel/pymacs/pkg-message
+++ b/devel/pymacs/pkg-message
@@ -1,9 +1,11 @@
Add the following to your emacs initialization file to enable pymacs:
-(autoload 'pymacs-load "pymacs" nil t)
-(autoload 'pymacs-eval "pymacs" nil t)
(autoload 'pymacs-apply "pymacs")
(autoload 'pymacs-call "pymacs")
+(autoload 'pymacs-eval "pymacs" nil t)
+(autoload 'pymacs-exec "pymacs" nil t)
+(autoload 'pymacs-load "pymacs" nil t)
+(autoload 'pymacs-autoload "pymacs")
-See http://pymacs.progiciels-bpi.ca/manual/index.html for
+See http://pymacs.progiciels-bpi.ca/pymacs.html for
documentation on using pymacs.
diff --git a/devel/pymacs/pkg-plist b/devel/pymacs/pkg-plist
index 66f53433b062..fe54af018ee2 100644
--- a/devel/pymacs/pkg-plist
+++ b/devel/pymacs/pkg-plist
@@ -1,28 +1,5 @@
+%%PYTHON_SITELIBDIR%%/Pymacs.py
+%%PYTHON_SITELIBDIR%%/Pymacs.pyc
+%%PYTHON_SITELIBDIR%%/Pymacs.pyo
%%EMACS_SITE_LISPDIR%%/pymacs.el
%%EMACS_SITE_LISPDIR%%/pymacs.elc
-bin/pymacs-services
-bin/rebox
-%%PYTHON_SITELIBDIR%%/Pymacs/pymacs.py
-%%PYTHON_SITELIBDIR%%/Pymacs/__init__.py
-%%PYTHON_SITELIBDIR%%/Pymacs/Nn/nncourriel.py
-%%PYTHON_SITELIBDIR%%/Pymacs/Nn/folder.py
-%%PYTHON_SITELIBDIR%%/Pymacs/Nn/__init__.py
-%%PYTHON_SITELIBDIR%%/Pymacs/Nn/nncourriel.pyc
-%%PYTHON_SITELIBDIR%%/Pymacs/Nn/folder.pyc
-%%PYTHON_SITELIBDIR%%/Pymacs/Nn/__init__.pyc
-%%PYTHON_SITELIBDIR%%/Pymacs/Nn/nncourriel.pyo
-%%PYTHON_SITELIBDIR%%/Pymacs/Nn/folder.pyo
-%%PYTHON_SITELIBDIR%%/Pymacs/Nn/__init__.pyo
-%%PYTHON_SITELIBDIR%%/Pymacs/Rebox/__init__.py
-%%PYTHON_SITELIBDIR%%/Pymacs/Rebox/rebox.py
-%%PYTHON_SITELIBDIR%%/Pymacs/Rebox/__init__.pyc
-%%PYTHON_SITELIBDIR%%/Pymacs/Rebox/rebox.pyc
-%%PYTHON_SITELIBDIR%%/Pymacs/Rebox/__init__.pyo
-%%PYTHON_SITELIBDIR%%/Pymacs/Rebox/rebox.pyo
-%%PYTHON_SITELIBDIR%%/Pymacs/pymacs.pyc
-%%PYTHON_SITELIBDIR%%/Pymacs/__init__.pyc
-%%PYTHON_SITELIBDIR%%/Pymacs/pymacs.pyo
-%%PYTHON_SITELIBDIR%%/Pymacs/__init__.pyo
-@dirrm %%PYTHON_SITELIBDIR%%/Pymacs/Nn
-@dirrm %%PYTHON_SITELIBDIR%%/Pymacs/Rebox
-@dirrm %%PYTHON_SITELIBDIR%%/Pymacs