aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-04-17 08:30:58 +0800
committermaho <maho@FreeBSD.org>2007-04-17 08:30:58 +0800
commit8515c64ab7ad8ad11fd48d36238a788eef56c425 (patch)
treec4c79d221e933ef2364d6bc61a5ed324106cdd5b
parent8ad728d721c21cdf83306dc1129ebb3f22c7cdc7 (diff)
downloadfreebsd-ports-gnome-8515c64ab7ad8ad11fd48d36238a788eef56c425.tar.gz
freebsd-ports-gnome-8515c64ab7ad8ad11fd48d36238a788eef56c425.tar.zst
freebsd-ports-gnome-8515c64ab7ad8ad11fd48d36238a788eef56c425.zip
* Use gfortran
* portlint. Build was not verified. It has been known that it doesn't build with 6.2-RELEASE(?), even without modification, but pointyhat build cluster. Hope pointyhat builds without errors.
-rw-r--r--science/hdf/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/science/hdf/Makefile b/science/hdf/Makefile
index 80eb1792709a..8f755469edff 100644
--- a/science/hdf/Makefile
+++ b/science/hdf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hdf
PORTVERSION= 4.2r1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science archivers graphics
MASTER_SITES= ftp://ftp.ncsa.uiuc.edu/HDF/HDF/HDF${PORTVERSION}/src/:src \
ftp://ftp.ncsa.uiuc.edu/HDF/HDF/Documentation/HDF4.2r0/:doc \
@@ -26,9 +26,16 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
CONFLICTS= netcdf-*
+WANT_FORTRAN= yes
+#USE_GCC=4.2+
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS+=--with-jpeg="${LOCALBASE}" \
--with-szlib="${LOCALBASE}"
+CONFIGURE_ENV+= F77="${F77}" FFLAGS="${FFLAGS}"
DOCFILES= HDF41r5_SpecDG.pdf \
HDF42r0_RefMan.pdf \
HDF42r0_UserGd.pdf
@@ -37,12 +44,12 @@ SZIP_DOCFILE= SZIP_HDF4_2r1.pdf
MAN1= hdf.1 hdfunpac.1 ncdump.1 ncgen.1
MANCOMPRESSED= no
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386" && ${ARCH} != "alpha" && ${ARCH} != "amd64"
-BROKEN= "Does not compile on !i386, !amd64 and !alpha"
+BROKEN= Does not compile on !i386, !amd64 and !alpha
.endif
post-patch: