aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-07-06 01:37:24 +0800
committermadpilot <madpilot@FreeBSD.org>2013-07-06 01:37:24 +0800
commit853a23fd7eff60cb1c7c53a5dcf3e135c617d8ec (patch)
tree11d6b5bda550f2eec686f781273db03073633d0b
parent35e1241ad1eb6fd57136c8400f91e6391dff996c (diff)
downloadfreebsd-ports-gnome-853a23fd7eff60cb1c7c53a5dcf3e135c617d8ec.tar.gz
freebsd-ports-gnome-853a23fd7eff60cb1c7c53a5dcf3e135c617d8ec.tar.zst
freebsd-ports-gnome-853a23fd7eff60cb1c7c53a5dcf3e135c617d8ec.zip
- Fix build with new multiimedia/libva [1]
- Convert to USES=gmake Obtained from: http://lists.freedesktop.org/archives/libva/2013-July/001772.html [1]
-rw-r--r--multimedia/libva-vdpau-driver/Makefile4
-rw-r--r--multimedia/libva-vdpau-driver/files/patch-src-vdpau__dump.c13
2 files changed, 15 insertions, 2 deletions
diff --git a/multimedia/libva-vdpau-driver/Makefile b/multimedia/libva-vdpau-driver/Makefile
index bc1cb2887fd1..cbf5cf134c79 100644
--- a/multimedia/libva-vdpau-driver/Makefile
+++ b/multimedia/libva-vdpau-driver/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libva-vdpau-driver
PORTVERSION= 0.7.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= http://www.freedesktop.org/software/vaapi/releases/${PORTNAME}/
@@ -18,7 +18,7 @@ BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/libva.pc:${PORTSDIR}/multimedia/li
LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake
USE_GL= gl
GNU_CONFIGURE= yes
diff --git a/multimedia/libva-vdpau-driver/files/patch-src-vdpau__dump.c b/multimedia/libva-vdpau-driver/files/patch-src-vdpau__dump.c
new file mode 100644
index 000000000000..b9bb2b35f931
--- /dev/null
+++ b/multimedia/libva-vdpau-driver/files/patch-src-vdpau__dump.c
@@ -0,0 +1,13 @@
+--- src/vdpau_dump.c.orig 2012-10-05 17:02:58.000000000 +0200
++++ src/vdpau_dump.c 2013-07-05 10:12:10.976605992 +0200
+@@ -59,8 +59,8 @@
+ _(VAEncSequenceParameterBufferType);
+ _(VAEncPictureParameterBufferType);
+ _(VAEncSliceParameterBufferType);
+- _(VAEncH264VUIBufferType);
+- _(VAEncH264SEIBufferType);
++ // _(VAEncH264VUIBufferType);
++ // _(VAEncH264SEIBufferType);
+ #endif
+ #if VA_CHECK_VERSION(0,31,1)
+ _(VAQMatrixBufferType);