aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2005-02-12 16:43:32 +0800
committerthierry <thierry@FreeBSD.org>2005-02-12 16:43:32 +0800
commit857ebbf726407b057ba4973fc10a3eb7133ead95 (patch)
tree6d375894c7c56771c334f9fd994fd37ffce59dc7
parent88eae7f82826e9f08b19d7d64526aa8e4c57653c (diff)
downloadfreebsd-ports-gnome-857ebbf726407b057ba4973fc10a3eb7133ead95.tar.gz
freebsd-ports-gnome-857ebbf726407b057ba4973fc10a3eb7133ead95.tar.zst
freebsd-ports-gnome-857ebbf726407b057ba4973fc10a3eb7133ead95.zip
Add adstudio 4.0, a database query and administration tool.
Aqua Data Studio is a database query and administration tool that allows developers to easily create, edit, and execute SQL scripts, as well as browse and visually modify database structures. Aqua Data Studio provides an integrated database environment with a single consistent interface to all major relational databases. It is free for personal or educational use, but a commercial license is required for all other usages.
-rw-r--r--databases/Makefile1
-rw-r--r--databases/adstudio/Makefile45
-rw-r--r--databases/adstudio/distinfo2
-rw-r--r--databases/adstudio/files/patch-datastudio.sh17
-rw-r--r--databases/adstudio/pkg-descr11
-rw-r--r--databases/adstudio/pkg-message1
-rw-r--r--databases/adstudio/pkg-plist36
7 files changed, 113 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index cebc6d2c1973..df8b83c18ebc 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -5,6 +5,7 @@
SUBDIR += WWWdb
SUBDIR += adodb
+ SUBDIR += adstudio
SUBDIR += arcexplorer
SUBDIR += bbdb
SUBDIR += bbdb-emacs20
diff --git a/databases/adstudio/Makefile b/databases/adstudio/Makefile
new file mode 100644
index 000000000000..4422667036ab
--- /dev/null
+++ b/databases/adstudio/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: adstudio
+# Date created: 9 February 2005
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= adstudio
+PORTVERSION= 4.0
+CATEGORIES= databases devel java
+MASTER_SITES= http://aquafold.fileburst.com/download/linux/
+DISTNAME= ${PORTNAME}-novm
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= A database query and administration tool
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4
+NO_BUILD= yes
+USE_REINPLACE= yes
+
+RESTRICTED= "See <http://www.aquafold.com/licensing.html>"
+NO_CDROM= ${RESTRICTED}
+
+WRKSRC= ${WRKDIR}/datastudio
+
+INSTFILES= License.txt PAD_FILE.XML changelog.txt datastudio.gif \
+ datastudio.ico lib license
+
+pre-configure:
+ ${REINPLACE_CMD} -e "s|%%ADS_HOME%%|${DATADIR}|" \
+ -e "s|^java |${JAVA} -Xmx256M |" ${WRKSRC}/datastudio.sh
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${CP} -R ${INSTFILES:S|^|${WRKSRC}/|} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/datastudio.sh ${PREFIX}/bin
+
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/databases/adstudio/distinfo b/databases/adstudio/distinfo
new file mode 100644
index 000000000000..760f48087ecd
--- /dev/null
+++ b/databases/adstudio/distinfo
@@ -0,0 +1,2 @@
+MD5 (adstudio-4.0/adstudio-novm.tar.gz) = 4e4cd9289319f936473c796723b7ebd4
+SIZE (adstudio-4.0/adstudio-novm.tar.gz) = 16396028
diff --git a/databases/adstudio/files/patch-datastudio.sh b/databases/adstudio/files/patch-datastudio.sh
new file mode 100644
index 000000000000..154cbb297567
--- /dev/null
+++ b/databases/adstudio/files/patch-datastudio.sh
@@ -0,0 +1,17 @@
+--- datastudio.sh.orig Wed Aug 4 15:15:16 2004
++++ datastudio.sh Fri Feb 11 16:08:59 2005
+@@ -1,7 +1,7 @@
+ #!/bin/sh
+ #SET ADS_HOME to the root installation directory for DataStudio
+
+-ADS_HOME=`dirname $0`
++ADS_HOME=%%ADS_HOME%%
+
+ CLASSES=$ADS_HOME/lib/datastudio.jar
+ CLASSES=$ADS_HOME/lib/oracle.jar:$CLASSES
+@@ -20,4 +20,4 @@
+ CLASSES=$ADS_HOME/lib/mail.jar:$CLASSES
+ CLASSES=$ADS_HOME/lib/activation.jar:$CLASSES
+
+-java -cp $CLASSES com.aquafold.datastudio.DataStudio
++java -cp $CLASSES com.aquafold.datastudio.DataStudio &
diff --git a/databases/adstudio/pkg-descr b/databases/adstudio/pkg-descr
new file mode 100644
index 000000000000..6e34b648279f
--- /dev/null
+++ b/databases/adstudio/pkg-descr
@@ -0,0 +1,11 @@
+Aqua Data Studio is a database query and administration tool that allows
+developers to easily create, edit, and execute SQL scripts, as well as
+browse and visually modify database structures. Aqua Data Studio provides
+an integrated database environment with a single consistent interface to
+all major relational databases. This allows the database administrator or
+developer to tackle multiple tasks simultaneously from one application.
+
+It is free for personal or educational use, but a commercial license is
+required for all other usages.
+
+WWW: http://www.aquafold.com/
diff --git a/databases/adstudio/pkg-message b/databases/adstudio/pkg-message
new file mode 100644
index 000000000000..2c47b41f6647
--- /dev/null
+++ b/databases/adstudio/pkg-message
@@ -0,0 +1 @@
+Type datastudio.sh to run Aqua Data Studio.
diff --git a/databases/adstudio/pkg-plist b/databases/adstudio/pkg-plist
new file mode 100644
index 000000000000..e3bb79c38f92
--- /dev/null
+++ b/databases/adstudio/pkg-plist
@@ -0,0 +1,36 @@
+bin/datastudio.sh
+%%DATADIR%%/License.txt
+%%DATADIR%%/PAD_FILE.XML
+%%DATADIR%%/changelog.txt
+%%DATADIR%%/datastudio.gif
+%%DATADIR%%/datastudio.ico
+%%DATADIR%%/lib/activation.jar
+%%DATADIR%%/lib/datastudio.jar
+%%DATADIR%%/lib/db2java.jar
+%%DATADIR%%/lib/db2jcc.jar
+%%DATADIR%%/lib/db2jcc_license_cu.jar
+%%DATADIR%%/lib/ifxjdbc.jar
+%%DATADIR%%/lib/jconnect45.jar
+%%DATADIR%%/lib/jconnect55.jar
+%%DATADIR%%/lib/jtds.jar
+%%DATADIR%%/lib/mail.jar
+%%DATADIR%%/lib/mysql-jdbc.zip
+%%DATADIR%%/lib/mysql.jar
+%%DATADIR%%/lib/nlscharset12.jar
+%%DATADIR%%/lib/oracle.jar
+%%DATADIR%%/lib/postgresql.jar
+%%DATADIR%%/lib/xdb.jar
+%%DATADIR%%/lib/xmlparserv2.jar
+%%DATADIR%%/license/DB2-JDBC-LICENSE.txt
+%%DATADIR%%/license/JGoodies-LICENSE.txt
+%%DATADIR%%/license/JGraph-LICENSE.txt
+%%DATADIR%%/license/L2FProd-LICENSE.txt
+%%DATADIR%%/license/MySQL-JDBC-LICENSE.txt
+%%DATADIR%%/license/Oracle-JDBC-LICENSE.txt
+%%DATADIR%%/license/Postgresql-JDBC-LICENSE.txt
+%%DATADIR%%/license/SUN-SPL-LICENSE.txt
+%%DATADIR%%/license/jConnect-LICENSE.txt
+%%DATADIR%%/license/jTDS-LICENSE.txt
+@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%/license
+@dirrm %%DATADIR%%