aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2019-09-05 18:23:56 +0800
committertijl <tijl@FreeBSD.org>2019-09-05 18:23:56 +0800
commit85be272d9851d8857598aab5351fdecdc337bd20 (patch)
treecb91e2ffcea333ff2520223680b16e1847ac5f7b
parent4c4bdc2f47124e998e9784b56093cdbad8df722f (diff)
downloadfreebsd-ports-gnome-85be272d9851d8857598aab5351fdecdc337bd20.tar.gz
freebsd-ports-gnome-85be272d9851d8857598aab5351fdecdc337bd20.tar.zst
freebsd-ports-gnome-85be272d9851d8857598aab5351fdecdc337bd20.zip
- Make fetchable again. The checksum has changed. Since this is a binary
only port it's not known what that means. A timestamp in the selfextractor script is now a couple of hours after the previous one so it may simply be a release+facepalm+fix+rerelease. At least it is downloaded from the official site now. - Fix portlint warnings. - Add a .desktop file. - Change startup script so it runs the 64-bit version on amd64. PR: 239783 Submitted by: Hannes Hauswedell <h2+fbsdports@fsfe.org> (maintainer)
-rw-r--r--games/linux-unigine-heaven/Makefile28
-rw-r--r--games/linux-unigine-heaven/distinfo5
-rw-r--r--games/linux-unigine-heaven/pkg-plist1
3 files changed, 19 insertions, 15 deletions
diff --git a/games/linux-unigine-heaven/Makefile b/games/linux-unigine-heaven/Makefile
index 28f7cebda955..a1f28b589c11 100644
--- a/games/linux-unigine-heaven/Makefile
+++ b/games/linux-unigine-heaven/Makefile
@@ -3,13 +3,9 @@
PORTNAME= unigine-heaven
PORTVERSION= 4.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games benchmarks linux
-MASTER_SITES= http://de1-dl.techpowerup.com/Benchmarking/ \
- http://nl1-dl.techpowerup.com/Benchmarking/ \
- http://uk1-dl.techpowerup.com/Benchmarking/ \
- http://us1-dl.techpowerup.com/Benchmarking/ \
- http://us2-dl.techpowerup.com/Benchmarking/
+MASTER_SITES= https://assets.unigine.com/d/
PKGNAMEPREFIX= linux-
DISTNAME= Unigine_Heaven-${PORTVERSION}
EXTRACT_SUFX= .run
@@ -22,23 +18,29 @@ LICENSE_NAME= Unigine "Basic" License
LICENSE_TEXT= Binary only, License text not available. Free-to-use + no-redistribution implied from homepage
LICENSE_PERMS= no-dist-sell no-pkg-sell no-dist-mirror no-pkg-mirror
-ONLY_FOR_ARCHS= i386 amd64
-USES= linux
-USE_LINUX= dri openal-soft xorglibs
+ONLY_FOR_ARCHS= amd64 i386
+USES= linux shebangfix
+USE_LINUX= dri xorglibs
USE_LDCONFIG= yes
NO_BUILD= yes
+SHEBANG_FILES= heaven
+bash_CMD= ${LINUXBASE}/bin/bash
+
+DESKTOP_ENTRIES="Unigine Heaven" "${COMMENT}" "${DATADIR}/data/launcher/icon.png" \
+ "${PKGNAMEPREFIX}${PORTNAME}" "Game;" false
+
do-extract:
@${MKDIR} ${WRKSRC}
- cd ${WRKSRC} && ${TAIL} -n 1098568 ${_DISTDIR}/${DISTFILES} | ${TAR} zxf -
- ${PRINTF} "#\!/bin/sh\ncd ${DATADIR}/bin/\n" > ${WRKDIR}/${PORTNAME}
- ${ECHO} 'export LD_LIBRARY_PATH=./x86:$$LD_LIBRARY_PATH' >> ${WRKDIR}/${PORTNAME}
- ${ECHO} './browser_x86 -config ../data/launcher/launcher.xml' >> ${WRKDIR}/${PORTNAME}
+ cd ${WRKSRC} && ${TAIL} -n 1097642 ${_DISTDIR}/${DISTFILES} | ${TAR} zxf -
+ ${PRINTF} '#!/bin/sh\ncd ${DATADIR}\nexec\
+ ${LINUXBASE}/bin/bash ./heaven\n' > ${WRKDIR}/${PORTNAME}
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PKGNAMEPREFIX}${PORTNAME}
cd ${WRKSRC} && ${COPYTREE_SHARE} ./data ${STAGEDIR}${DATADIR}
cd ${WRKSRC} && ${COPYTREE_SHARE} ./bin ${STAGEDIR}${DATADIR}
cd ${WRKSRC} && ${COPYTREE_SHARE} ./documentation ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/heaven ${STAGEDIR}${DATADIR}/heaven
.include <bsd.port.mk>
diff --git a/games/linux-unigine-heaven/distinfo b/games/linux-unigine-heaven/distinfo
index 801185ca2fc9..1cf39e1de509 100644
--- a/games/linux-unigine-heaven/distinfo
+++ b/games/linux-unigine-heaven/distinfo
@@ -1,2 +1,3 @@
-SHA256 (Unigine_Heaven-4.0.run) = 90e6f95bb3c0d92f557a948ca6754b1b1bead07a063ec2af0ce03ef8e7ac74f3
-SIZE (Unigine_Heaven-4.0.run) = 286329188
+TIMESTAMP = 1565539326
+SHA256 (Unigine_Heaven-4.0.run) = 1bb0204a9bd9b0bdbf2fe23aa0c32129905cb387040098b815332ddb396f36a7
+SIZE (Unigine_Heaven-4.0.run) = 286326725
diff --git a/games/linux-unigine-heaven/pkg-plist b/games/linux-unigine-heaven/pkg-plist
index 262db4edacf2..8df5f77e9d7f 100644
--- a/games/linux-unigine-heaven/pkg-plist
+++ b/games/linux-unigine-heaven/pkg-plist
@@ -4,6 +4,7 @@ bin/linux-unigine-heaven
%%DATADIR%%/bin/browser_x86
%%DATADIR%%/bin/heaven_x64
%%DATADIR%%/bin/heaven_x86
+%%DATADIR%%/heaven
@mode
%%DATADIR%%/bin/libAppStereo_x64.so
%%DATADIR%%/bin/libAppStereo_x86.so