aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2013-06-28 21:10:29 +0800
committerehaupt <ehaupt@FreeBSD.org>2013-06-28 21:10:29 +0800
commit85ead4e68fbfe9cd66eb15e19ac4ffbe0dd69d96 (patch)
tree40fc3dfc39afcd7d1d43b93f1aafe3dbb49975a7
parentf644c91a22d8f1e7b4b3417b5b7b5720f85bc0f6 (diff)
downloadfreebsd-ports-gnome-85ead4e68fbfe9cd66eb15e19ac4ffbe0dd69d96.tar.gz
freebsd-ports-gnome-85ead4e68fbfe9cd66eb15e19ac4ffbe0dd69d96.tar.zst
freebsd-ports-gnome-85ead4e68fbfe9cd66eb15e19ac4ffbe0dd69d96.zip
Use ${CC} instead of 'clang' to detect whether /usr/bin/cc is gcc or clang.
-rw-r--r--audio/xmms-sapplug/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/audio/xmms-sapplug/Makefile b/audio/xmms-sapplug/Makefile
index d160a24df4cc..ec9846a7ecd1 100644
--- a/audio/xmms-sapplug/Makefile
+++ b/audio/xmms-sapplug/Makefile
@@ -29,7 +29,7 @@ OPTIONS_DEFINE= OPTIMIZED_CFLAGS
.include <bsd.port.options.mk>
-_CLANG!= clang --version | ${HEAD} -1 | ${SED} -e 's/.*clang version \([0-9]\)\.\([0-9]\).*/\1\2/'
+_CLANG!= ${CC} --version | ${HEAD} -1 | ${SED} -e 's/.*clang version \([0-9]\)\.\([0-9]\).*/\1\2/'
.if ${CXX:T} != "clang++" && !defined(_CLANG)
CXXFLAGS+= --no-exceptions