aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-05-17 16:32:45 +0800
committersobomax <sobomax@FreeBSD.org>2002-05-17 16:32:45 +0800
commit86bf25dac9c42006005e9b8efe0729efb3558228 (patch)
treebed66e9e086d95883170827978d6e3641c29aa6a
parentca46f51855e6468e1f2334486592231f4967d5f3 (diff)
downloadfreebsd-ports-gnome-86bf25dac9c42006005e9b8efe0729efb3558228.tar.gz
freebsd-ports-gnome-86bf25dac9c42006005e9b8efe0729efb3558228.tar.zst
freebsd-ports-gnome-86bf25dac9c42006005e9b8efe0729efb3558228.zip
Disable svgalib dependency when building on arch other than i386. Hopefully
this would enable to get even more packages for alpha. Prompted by: kris
-rw-r--r--devel/sdl12/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/devel/sdl12/Makefile b/devel/sdl12/Makefile
index 2d34f664ffbe..84c6888d6e38 100644
--- a/devel/sdl12/Makefile
+++ b/devel/sdl12/Makefile
@@ -50,10 +50,6 @@ CONFIGURE_ARGS+=--disable-video-opengl
USE_MESA= yes
CONFIGURE_ARGS+=--enable-video-opengl
.endif
-.if !defined(WITHOUT_SVGALIB)
-LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
-CONFIGURE_ARGS+=--enable-video-svga
-.endif
.if exists(/usr/include/libusbhid.h)
CONFIGURE_ENV+= USB_LIBS=-lusbhid
CFLAGS+= -DHAVE_LIBUSBHID_H
@@ -65,6 +61,15 @@ CONFIGURE_ENV+= USB_LIBS=-lusb
MAN3!= ${CAT} ${FILESDIR}/man3
+.if (${ARCH} != "i386")
+WITHOUT_SVGALIB= yes
+.endif
+
+.if !defined(WITHOUT_SVGALIB)
+LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
+CONFIGURE_ARGS+=--enable-video-svga
+.endif
+
pre-configure:
@${FIND} ${WRKSRC} -type f -name Makefile.in | ${XARGS} ${TOUCH}