aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2004-09-01 23:38:42 +0800
committerhq <hq@FreeBSD.org>2004-09-01 23:38:42 +0800
commit8751a0c99e22f98143a91e48e642271ba1437507 (patch)
tree32e8433a32baab4da1b3578a7672d21798dae649
parent7a8f5fb36e62f23b3daf01237bf6e4e8a0f2b9b3 (diff)
downloadfreebsd-ports-gnome-8751a0c99e22f98143a91e48e642271ba1437507.tar.gz
freebsd-ports-gnome-8751a0c99e22f98143a91e48e642271ba1437507.tar.zst
freebsd-ports-gnome-8751a0c99e22f98143a91e48e642271ba1437507.zip
Fix permissions issue caused by last commit.
Approved by: glewis (mentor)
-rw-r--r--java/jdom/Makefile2
-rw-r--r--textproc/xalan-j/Makefile1
2 files changed, 3 insertions, 0 deletions
diff --git a/java/jdom/Makefile b/java/jdom/Makefile
index 96fbe0c26356..ec36ec32c7f9 100644
--- a/java/jdom/Makefile
+++ b/java/jdom/Makefile
@@ -41,10 +41,12 @@ do-install:
@${ECHO_MSG} " [ DONE ]"
.if !defined(NOPORTDOCS)
@${ECHO_MSG} -n ">> Installing samples in ${EXAMPLESDIR}..."
+ @${MKDIR} ${EXAMPLESDIR}
@cd ${WRKSRC}/build/samples/ && ${FIND} . \
| ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR} > /dev/null 2>&1
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
+ @${MKDIR} ${DOCSDIR}/apidocs
@cd ${WRKSRC}/build/ && ${FIND} apidocs \
| ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > /dev/null 2>&1
@${INSTALL_DATA} ${OTHERDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
diff --git a/textproc/xalan-j/Makefile b/textproc/xalan-j/Makefile
index 5bf910ea51f5..8eb39d908ae9 100644
--- a/textproc/xalan-j/Makefile
+++ b/textproc/xalan-j/Makefile
@@ -41,6 +41,7 @@ do-install:
@${ECHO_MSG} " [ DONE ]"
.if !defined(NOPORTDOCS)
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
+ @${MKDIR} ${DOCSDIR}
@cd ${WRKSRC}/build/docs && ${FIND} ${PORTDOCS} \
| ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > /dev/null 2>&1
@${ECHO_MSG} " [ DONE ]"