aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradridg <adridg@FreeBSD.org>2019-02-18 05:22:16 +0800
committeradridg <adridg@FreeBSD.org>2019-02-18 05:22:16 +0800
commit878967ad555024d168692c2b275d6f4e43072c57 (patch)
treee143bdcb27ad3eae77b349d8555be619e9b01bfa
parent13635343312a22368dd422e4cf00bef2130dd144 (diff)
downloadfreebsd-ports-gnome-878967ad555024d168692c2b275d6f4e43072c57.tar.gz
freebsd-ports-gnome-878967ad555024d168692c2b275d6f4e43072c57.tar.zst
freebsd-ports-gnome-878967ad555024d168692c2b275d6f4e43072c57.zip
Update www/falkon to the latest release.
Release notes https://www.falkon.org/2018/05/08/falkon-301-released/ There's one bit of trickery here, which handles QtWebEngine < 5.10 mixed with newer Qt -- just the situation the ports tree is in today. Thanks to Ken Moore for providing partial patches for OPTION KWALLET. PR: 235681 235680 234692 Reported by: Nuno Teixeira, Ken Moore
-rw-r--r--www/falkon/Makefile18
-rw-r--r--www/falkon/distinfo6
-rw-r--r--www/falkon/files/patch-src_lib_webengine_webview.cpp18
-rw-r--r--www/falkon/pkg-descr2
-rw-r--r--www/falkon/pkg-plist135
5 files changed, 137 insertions, 42 deletions
diff --git a/www/falkon/Makefile b/www/falkon/Makefile
index 5fb04b66ad66..0a9a0e7d8b98 100644
--- a/www/falkon/Makefile
+++ b/www/falkon/Makefile
@@ -1,10 +1,9 @@
# $FreeBSD$
PORTNAME= falkon
-DISTVERSION= 3.0.0
-PORTREVISION= 5
+DISTVERSION= 3.0.1
CATEGORIES= www
-MASTER_SITES= KDE/stable/falkon/${DISTVERSION:R}/src/
+MASTER_SITES= KDE/stable/falkon/${DISTVERSION}/
MAINTAINER= kde@FreeBSD.org
COMMENT= Web browser based on WebKit engine and Qt Framework
@@ -13,17 +12,24 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
USES= cmake desktop-file-utils kde:5 qt:5 ssl tar:xz
-USE_KDE= wallet
+USE_KDE= ecm_build i18n wallet
USE_QT= core dbus declarative gui location network printsupport \
sql webchannel webengine widgets x11extras \
- buildtools_build qmake_build
+ buildtools_build qmake_build linguist_build
USE_XORG= xcb
USE_LDCONFIG= yes
-OPTIONS_DEFINE= GNOMEKEYRING
+OPTIONS_DEFINE= GNOMEKEYRING KWALLET
+OPTIONS_DEFAULT= KWALLET
OPTIONS_SUB= YES
+
+KWALLET_DESC= Integration with KDE Wallet
+KWALLET_USE= KDE=wallet
+KWALLET_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_KF5Wallet=ON
+
+GNOMEKEYRING_DESC= Integration with GNOME Keyring
GNOMEKEYRING_CMAKE_BOOL= BUILD_KEYRING
GNOMEKEYRING_USE= GNOME=glib20
GNOMEKEYRING_LIB_DEPENDS= libgnome-keyring.so:security/libgnome-keyring
diff --git a/www/falkon/distinfo b/www/falkon/distinfo
index 62a52c3a50fb..1c3416d320be 100644
--- a/www/falkon/distinfo
+++ b/www/falkon/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1520162599
-SHA256 (falkon-3.0.0.tar.xz) = 4e42a091e6ae434d7c3146adb876a8a5dc29d9354560087a905a0bd7fb58d7a6
-SIZE (falkon-3.0.0.tar.xz) = 1985800
+TIMESTAMP = 1550423437
+SHA256 (falkon-3.0.1.tar.xz) = 7b6ed54986543dd5462602943fb824df12f15d2061996310c4c4b891433f1a83
+SIZE (falkon-3.0.1.tar.xz) = 2219444
diff --git a/www/falkon/files/patch-src_lib_webengine_webview.cpp b/www/falkon/files/patch-src_lib_webengine_webview.cpp
new file mode 100644
index 000000000000..28b21c568e34
--- /dev/null
+++ b/www/falkon/files/patch-src_lib_webengine_webview.cpp
@@ -0,0 +1,18 @@
+As long as we ship QtWebEngine 5.9 with a newer rest-of-Qt,
+basing checks on the Qt version for deciding what QtWebEngine
+features to use is going to break.
+
+Hit the code with a hammer. When QtWebEngine 5.12 lands, remove this patch.
+
+--- src/lib/webengine/webview.cpp.orig 2018-05-08 14:18:50 UTC
++++ src/lib/webengine/webview.cpp
+@@ -495,7 +495,8 @@ void WebView::copyLinkToClipboard()
+
+ void WebView::savePageAs()
+ {
+-#if QT_VERSION >= QT_VERSION_CHECK(5, 10, 0)
++#if 0
++// #if QT_VERSION >= QT_VERSION_CHECK(5, 10, 0)
+ page()->runJavaScript(QSL("document.contentType"), WebPage::SafeJsWorld, [this](const QVariant &res) {
+ const QSet<QString> webPageTypes = {
+ QSL("text/html"),
diff --git a/www/falkon/pkg-descr b/www/falkon/pkg-descr
index f275a373abcf..7a8516641fc7 100644
--- a/www/falkon/pkg-descr
+++ b/www/falkon/pkg-descr
@@ -11,4 +11,4 @@ RSS feeds with an included RSS reader, block ads with a builtin AdBlock plugin,
block Flash content with Click2Flash and edit the local CA Certificates
database with an SSL Manager.
-WWW: https://userbase.kde.org/Falkon
+WWW: https://www.falkon.org/
diff --git a/www/falkon/pkg-plist b/www/falkon/pkg-plist
index a5229dda4511..79f2c195273f 100644
--- a/www/falkon/pkg-plist
+++ b/www/falkon/pkg-plist
@@ -1,12 +1,12 @@
bin/falkon
lib/libFalkonPrivate.so.3
-lib/libFalkonPrivate.so.3.0.0
+lib/libFalkonPrivate.so.3.0.1
%%QT_PLUGINDIR%%/falkon/AutoScroll.so
%%QT_PLUGINDIR%%/falkon/FlashCookieManager.so
%%GNOMEKEYRING%%%%QT_PLUGINDIR%%/falkon/GnomeKeyringPasswords.so
%%QT_PLUGINDIR%%/falkon/GreaseMonkey.so
%%QT_PLUGINDIR%%/falkon/ImageFinder.so
-%%QT_PLUGINDIR%%/falkon/KWalletPasswords.so
+%%KWALLET%%%%QT_PLUGINDIR%%/falkon/KWalletPasswords.so
%%QT_PLUGINDIR%%/falkon/MouseGestures.so
%%QT_PLUGINDIR%%/falkon/PIM.so
%%QT_PLUGINDIR%%/falkon/StatusBarIcons.so
@@ -146,7 +146,6 @@ share/icons/hicolor/scalable/apps/falkon.svg
share/locale/ar/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/ar/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/ar/LC_MESSAGES/falkon_greasemonkey_qt.qm
-share/locale/ar/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/ar/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/ar/LC_MESSAGES/falkon_pim_qt.qm
share/locale/ar/LC_MESSAGES/falkon_qt.qm
@@ -157,6 +156,8 @@ share/locale/ca/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/ca/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/ca/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/ca/LC_MESSAGES/falkon_greasemonkey_qt.qm
+share/locale/ca/LC_MESSAGES/falkon_hellopython.mo
+share/locale/ca/LC_MESSAGES/falkon_imagefinder_qt.qm
share/locale/ca/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/ca/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/ca/LC_MESSAGES/falkon_pim_qt.qm
@@ -164,21 +165,50 @@ share/locale/ca/LC_MESSAGES/falkon_qt.qm
share/locale/ca/LC_MESSAGES/falkon_statusbaricons_qt.qm
share/locale/ca/LC_MESSAGES/falkon_tabmanager_qt.qm
share/locale/ca/LC_MESSAGES/falkon_testplugin_qt.qm
+share/locale/ca/LC_MESSAGES/falkon_verticaltabs_qt.qm
+share/locale/ca@valencia/LC_MESSAGES/falkon_autoscroll_qt.qm
+share/locale/ca@valencia/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
+share/locale/ca@valencia/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
+share/locale/ca@valencia/LC_MESSAGES/falkon_greasemonkey_qt.qm
+share/locale/ca@valencia/LC_MESSAGES/falkon_hellopython.mo
+share/locale/ca@valencia/LC_MESSAGES/falkon_imagefinder_qt.qm
+share/locale/ca@valencia/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
+share/locale/ca@valencia/LC_MESSAGES/falkon_mousegestures_qt.qm
+share/locale/ca@valencia/LC_MESSAGES/falkon_pim_qt.qm
+share/locale/ca@valencia/LC_MESSAGES/falkon_qt.qm
+share/locale/ca@valencia/LC_MESSAGES/falkon_statusbaricons_qt.qm
+share/locale/ca@valencia/LC_MESSAGES/falkon_tabmanager_qt.qm
+share/locale/ca@valencia/LC_MESSAGES/falkon_testplugin_qt.qm
+share/locale/ca@valencia/LC_MESSAGES/falkon_verticaltabs_qt.qm
share/locale/cs/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/cs/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/cs/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/cs/LC_MESSAGES/falkon_greasemonkey_qt.qm
-share/locale/cs/LC_MESSAGES/falkon_imagefinder_qt.qm
-share/locale/cs/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
+share/locale/cs/LC_MESSAGES/falkon_hellopython.mo
share/locale/cs/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/cs/LC_MESSAGES/falkon_pim_qt.qm
share/locale/cs/LC_MESSAGES/falkon_qt.qm
share/locale/cs/LC_MESSAGES/falkon_statusbaricons_qt.qm
+share/locale/cs/LC_MESSAGES/falkon_tabmanager_qt.qm
share/locale/cs/LC_MESSAGES/falkon_testplugin_qt.qm
+share/locale/cs/LC_MESSAGES/falkon_verticaltabs_qt.qm
+share/locale/da/LC_MESSAGES/falkon_autoscroll_qt.qm
+share/locale/da/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
+share/locale/da/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
+share/locale/da/LC_MESSAGES/falkon_greasemonkey_qt.qm
+share/locale/da/LC_MESSAGES/falkon_hellopython.mo
+share/locale/da/LC_MESSAGES/falkon_mousegestures_qt.qm
+share/locale/da/LC_MESSAGES/falkon_pim_qt.qm
+share/locale/da/LC_MESSAGES/falkon_qt.qm
+share/locale/da/LC_MESSAGES/falkon_statusbaricons_qt.qm
+share/locale/da/LC_MESSAGES/falkon_tabmanager_qt.qm
+share/locale/da/LC_MESSAGES/falkon_testplugin_qt.qm
+share/locale/da/LC_MESSAGES/falkon_verticaltabs_qt.qm
share/locale/de/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/de/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/de/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/de/LC_MESSAGES/falkon_greasemonkey_qt.qm
+share/locale/de/LC_MESSAGES/falkon_hellopython.mo
share/locale/de/LC_MESSAGES/falkon_imagefinder_qt.qm
share/locale/de/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/de/LC_MESSAGES/falkon_mousegestures_qt.qm
@@ -187,23 +217,36 @@ share/locale/de/LC_MESSAGES/falkon_qt.qm
share/locale/de/LC_MESSAGES/falkon_statusbaricons_qt.qm
share/locale/de/LC_MESSAGES/falkon_tabmanager_qt.qm
share/locale/de/LC_MESSAGES/falkon_testplugin_qt.qm
+share/locale/de/LC_MESSAGES/falkon_verticaltabs_qt.qm
share/locale/el/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/el/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/el/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/el/LC_MESSAGES/falkon_greasemonkey_qt.qm
-share/locale/el/LC_MESSAGES/falkon_imagefinder_qt.qm
-share/locale/el/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/el/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/el/LC_MESSAGES/falkon_pim_qt.qm
share/locale/el/LC_MESSAGES/falkon_qt.qm
share/locale/el/LC_MESSAGES/falkon_statusbaricons_qt.qm
share/locale/el/LC_MESSAGES/falkon_tabmanager_qt.qm
share/locale/el/LC_MESSAGES/falkon_testplugin_qt.qm
-share/locale/en/LC_MESSAGES/falkon_qt.qm
+share/locale/en_GB/LC_MESSAGES/falkon_autoscroll_qt.qm
+share/locale/en_GB/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
+share/locale/en_GB/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
+share/locale/en_GB/LC_MESSAGES/falkon_greasemonkey_qt.qm
+share/locale/en_GB/LC_MESSAGES/falkon_hellopython.mo
+share/locale/en_GB/LC_MESSAGES/falkon_imagefinder_qt.qm
+share/locale/en_GB/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
+share/locale/en_GB/LC_MESSAGES/falkon_mousegestures_qt.qm
+share/locale/en_GB/LC_MESSAGES/falkon_pim_qt.qm
+share/locale/en_GB/LC_MESSAGES/falkon_qt.qm
+share/locale/en_GB/LC_MESSAGES/falkon_statusbaricons_qt.qm
+share/locale/en_GB/LC_MESSAGES/falkon_tabmanager_qt.qm
+share/locale/en_GB/LC_MESSAGES/falkon_testplugin_qt.qm
+share/locale/en_GB/LC_MESSAGES/falkon_verticaltabs_qt.qm
share/locale/es/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/es/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/es/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/es/LC_MESSAGES/falkon_greasemonkey_qt.qm
+share/locale/es/LC_MESSAGES/falkon_hellopython.mo
share/locale/es/LC_MESSAGES/falkon_imagefinder_qt.qm
share/locale/es/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/es/LC_MESSAGES/falkon_mousegestures_qt.qm
@@ -212,12 +255,11 @@ share/locale/es/LC_MESSAGES/falkon_qt.qm
share/locale/es/LC_MESSAGES/falkon_statusbaricons_qt.qm
share/locale/es/LC_MESSAGES/falkon_tabmanager_qt.qm
share/locale/es/LC_MESSAGES/falkon_testplugin_qt.qm
+share/locale/es/LC_MESSAGES/falkon_verticaltabs_qt.qm
share/locale/eu/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/eu/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/eu/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/eu/LC_MESSAGES/falkon_greasemonkey_qt.qm
-share/locale/eu/LC_MESSAGES/falkon_imagefinder_qt.qm
-share/locale/eu/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/eu/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/eu/LC_MESSAGES/falkon_pim_qt.qm
share/locale/eu/LC_MESSAGES/falkon_qt.qm
@@ -227,17 +269,28 @@ share/locale/eu/LC_MESSAGES/falkon_testplugin_qt.qm
share/locale/fa/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/fa/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/fa/LC_MESSAGES/falkon_greasemonkey_qt.qm
-share/locale/fa/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/fa/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/fa/LC_MESSAGES/falkon_pim_qt.qm
share/locale/fa/LC_MESSAGES/falkon_qt.qm
share/locale/fa/LC_MESSAGES/falkon_statusbaricons_qt.qm
share/locale/fa/LC_MESSAGES/falkon_tabmanager_qt.qm
share/locale/fa/LC_MESSAGES/falkon_testplugin_qt.qm
+share/locale/fi/LC_MESSAGES/falkon_autoscroll_qt.qm
+share/locale/fi/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
+share/locale/fi/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
+share/locale/fi/LC_MESSAGES/falkon_greasemonkey_qt.qm
+share/locale/fi/LC_MESSAGES/falkon_mousegestures_qt.qm
+share/locale/fi/LC_MESSAGES/falkon_pim_qt.qm
+share/locale/fi/LC_MESSAGES/falkon_qt.qm
+share/locale/fi/LC_MESSAGES/falkon_statusbaricons_qt.qm
+share/locale/fi/LC_MESSAGES/falkon_tabmanager_qt.qm
+share/locale/fi/LC_MESSAGES/falkon_testplugin_qt.qm
+share/locale/fi/LC_MESSAGES/falkon_verticaltabs_qt.qm
share/locale/fr/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/fr/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/fr/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/fr/LC_MESSAGES/falkon_greasemonkey_qt.qm
+share/locale/fr/LC_MESSAGES/falkon_hellopython.mo
share/locale/fr/LC_MESSAGES/falkon_imagefinder_qt.qm
share/locale/fr/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/fr/LC_MESSAGES/falkon_mousegestures_qt.qm
@@ -247,11 +300,23 @@ share/locale/fr/LC_MESSAGES/falkon_statusbaricons_qt.qm
share/locale/fr/LC_MESSAGES/falkon_tabmanager_qt.qm
share/locale/fr/LC_MESSAGES/falkon_testplugin_qt.qm
share/locale/fr/LC_MESSAGES/falkon_verticaltabs_qt.qm
+share/locale/gl/LC_MESSAGES/falkon_autoscroll_qt.qm
+share/locale/gl/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
+share/locale/gl/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
+share/locale/gl/LC_MESSAGES/falkon_greasemonkey_qt.qm
+share/locale/gl/LC_MESSAGES/falkon_hellopython.mo
+share/locale/gl/LC_MESSAGES/falkon_imagefinder_qt.qm
+share/locale/gl/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
+share/locale/gl/LC_MESSAGES/falkon_mousegestures_qt.qm
+share/locale/gl/LC_MESSAGES/falkon_pim_qt.qm
+share/locale/gl/LC_MESSAGES/falkon_qt.qm
+share/locale/gl/LC_MESSAGES/falkon_statusbaricons_qt.qm
+share/locale/gl/LC_MESSAGES/falkon_tabmanager_qt.qm
+share/locale/gl/LC_MESSAGES/falkon_testplugin_qt.qm
+share/locale/gl/LC_MESSAGES/falkon_verticaltabs_qt.qm
share/locale/hu/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/hu/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/hu/LC_MESSAGES/falkon_greasemonkey_qt.qm
-share/locale/hu/LC_MESSAGES/falkon_imagefinder_qt.qm
-share/locale/hu/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/hu/LC_MESSAGES/falkon_pim_qt.qm
share/locale/hu/LC_MESSAGES/falkon_qt.qm
share/locale/hu/LC_MESSAGES/falkon_testplugin_qt.qm
@@ -259,6 +324,7 @@ share/locale/id/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/id/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/id/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/id/LC_MESSAGES/falkon_greasemonkey_qt.qm
+share/locale/id/LC_MESSAGES/falkon_hellopython.mo
share/locale/id/LC_MESSAGES/falkon_imagefinder_qt.qm
share/locale/id/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/id/LC_MESSAGES/falkon_mousegestures_qt.qm
@@ -267,12 +333,11 @@ share/locale/id/LC_MESSAGES/falkon_qt.qm
share/locale/id/LC_MESSAGES/falkon_statusbaricons_qt.qm
share/locale/id/LC_MESSAGES/falkon_tabmanager_qt.qm
share/locale/id/LC_MESSAGES/falkon_testplugin_qt.qm
+share/locale/id/LC_MESSAGES/falkon_verticaltabs_qt.qm
share/locale/is/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/is/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/is/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/is/LC_MESSAGES/falkon_greasemonkey_qt.qm
-share/locale/is/LC_MESSAGES/falkon_imagefinder_qt.qm
-share/locale/is/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/is/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/is/LC_MESSAGES/falkon_pim_qt.qm
share/locale/is/LC_MESSAGES/falkon_qt.qm
@@ -283,6 +348,7 @@ share/locale/it/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/it/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/it/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/it/LC_MESSAGES/falkon_greasemonkey_qt.qm
+share/locale/it/LC_MESSAGES/falkon_hellopython.mo
share/locale/it/LC_MESSAGES/falkon_imagefinder_qt.qm
share/locale/it/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/it/LC_MESSAGES/falkon_mousegestures_qt.qm
@@ -291,18 +357,18 @@ share/locale/it/LC_MESSAGES/falkon_qt.qm
share/locale/it/LC_MESSAGES/falkon_statusbaricons_qt.qm
share/locale/it/LC_MESSAGES/falkon_tabmanager_qt.qm
share/locale/it/LC_MESSAGES/falkon_testplugin_qt.qm
+share/locale/it/LC_MESSAGES/falkon_verticaltabs_qt.qm
share/locale/ja/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/ja/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/ja/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/ja/LC_MESSAGES/falkon_greasemonkey_qt.qm
-share/locale/ja/LC_MESSAGES/falkon_imagefinder_qt.qm
-share/locale/ja/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/ja/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/ja/LC_MESSAGES/falkon_pim_qt.qm
share/locale/ja/LC_MESSAGES/falkon_qt.qm
share/locale/ja/LC_MESSAGES/falkon_statusbaricons_qt.qm
share/locale/ja/LC_MESSAGES/falkon_tabmanager_qt.qm
share/locale/ja/LC_MESSAGES/falkon_testplugin_qt.qm
+share/locale/ja/LC_MESSAGES/falkon_verticaltabs_qt.qm
share/locale/ka/LC_MESSAGES/falkon_greasemonkey_qt.qm
share/locale/ka/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/ka/LC_MESSAGES/falkon_qt.qm
@@ -311,7 +377,6 @@ share/locale/lv/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/lv/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/lv/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/lv/LC_MESSAGES/falkon_greasemonkey_qt.qm
-share/locale/lv/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/lv/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/lv/LC_MESSAGES/falkon_pim_qt.qm
share/locale/lv/LC_MESSAGES/falkon_qt.qm
@@ -322,8 +387,6 @@ share/locale/nb/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/nb/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/nb/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/nb/LC_MESSAGES/falkon_greasemonkey_qt.qm
-share/locale/nb/LC_MESSAGES/falkon_imagefinder_qt.qm
-share/locale/nb/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/nb/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/nb/LC_MESSAGES/falkon_pim_qt.qm
share/locale/nb/LC_MESSAGES/falkon_qt.qm
@@ -334,6 +397,7 @@ share/locale/nl/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/nl/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/nl/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/nl/LC_MESSAGES/falkon_greasemonkey_qt.qm
+share/locale/nl/LC_MESSAGES/falkon_hellopython.mo
share/locale/nl/LC_MESSAGES/falkon_imagefinder_qt.qm
share/locale/nl/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/nl/LC_MESSAGES/falkon_mousegestures_qt.qm
@@ -347,6 +411,8 @@ share/locale/pl/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/pl/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/pl/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/pl/LC_MESSAGES/falkon_greasemonkey_qt.qm
+share/locale/pl/LC_MESSAGES/falkon_hellopython.mo
+share/locale/pl/LC_MESSAGES/falkon_imagefinder_qt.qm
share/locale/pl/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/pl/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/pl/LC_MESSAGES/falkon_pim_qt.qm
@@ -354,10 +420,12 @@ share/locale/pl/LC_MESSAGES/falkon_qt.qm
share/locale/pl/LC_MESSAGES/falkon_statusbaricons_qt.qm
share/locale/pl/LC_MESSAGES/falkon_tabmanager_qt.qm
share/locale/pl/LC_MESSAGES/falkon_testplugin_qt.qm
+share/locale/pl/LC_MESSAGES/falkon_verticaltabs_qt.qm
share/locale/pt/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/pt/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/pt/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/pt/LC_MESSAGES/falkon_greasemonkey_qt.qm
+share/locale/pt/LC_MESSAGES/falkon_hellopython.mo
share/locale/pt/LC_MESSAGES/falkon_imagefinder_qt.qm
share/locale/pt/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/pt/LC_MESSAGES/falkon_mousegestures_qt.qm
@@ -368,16 +436,21 @@ share/locale/pt/LC_MESSAGES/falkon_tabmanager_qt.qm
share/locale/pt/LC_MESSAGES/falkon_testplugin_qt.qm
share/locale/pt/LC_MESSAGES/falkon_verticaltabs_qt.qm
share/locale/pt_BR/LC_MESSAGES/falkon_autoscroll_qt.qm
+share/locale/pt_BR/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
+share/locale/pt_BR/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/pt_BR/LC_MESSAGES/falkon_greasemonkey_qt.qm
+share/locale/pt_BR/LC_MESSAGES/falkon_hellopython.mo
share/locale/pt_BR/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/pt_BR/LC_MESSAGES/falkon_pim_qt.qm
share/locale/pt_BR/LC_MESSAGES/falkon_qt.qm
+share/locale/pt_BR/LC_MESSAGES/falkon_statusbaricons_qt.qm
+share/locale/pt_BR/LC_MESSAGES/falkon_tabmanager_qt.qm
share/locale/pt_BR/LC_MESSAGES/falkon_testplugin_qt.qm
+share/locale/pt_BR/LC_MESSAGES/falkon_verticaltabs_qt.qm
share/locale/ro/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/ro/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/ro/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/ro/LC_MESSAGES/falkon_greasemonkey_qt.qm
-share/locale/ro/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/ro/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/ro/LC_MESSAGES/falkon_qt.qm
share/locale/ro/LC_MESSAGES/falkon_testplugin_qt.qm
@@ -385,8 +458,6 @@ share/locale/ru/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/ru/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/ru/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/ru/LC_MESSAGES/falkon_greasemonkey_qt.qm
-share/locale/ru/LC_MESSAGES/falkon_imagefinder_qt.qm
-share/locale/ru/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/ru/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/ru/LC_MESSAGES/falkon_pim_qt.qm
share/locale/ru/LC_MESSAGES/falkon_qt.qm
@@ -394,19 +465,23 @@ share/locale/ru/LC_MESSAGES/falkon_statusbaricons_qt.qm
share/locale/ru/LC_MESSAGES/falkon_tabmanager_qt.qm
share/locale/ru/LC_MESSAGES/falkon_testplugin_qt.qm
share/locale/sk/LC_MESSAGES/falkon_autoscroll_qt.qm
+share/locale/sk/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/sk/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/sk/LC_MESSAGES/falkon_greasemonkey_qt.qm
+share/locale/sk/LC_MESSAGES/falkon_hellopython.mo
+share/locale/sk/LC_MESSAGES/falkon_imagefinder_qt.qm
share/locale/sk/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/sk/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/sk/LC_MESSAGES/falkon_pim_qt.qm
share/locale/sk/LC_MESSAGES/falkon_qt.qm
share/locale/sk/LC_MESSAGES/falkon_statusbaricons_qt.qm
+share/locale/sk/LC_MESSAGES/falkon_tabmanager_qt.qm
share/locale/sk/LC_MESSAGES/falkon_testplugin_qt.qm
+share/locale/sk/LC_MESSAGES/falkon_verticaltabs_qt.qm
share/locale/sr/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/sr/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/sr/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/sr/LC_MESSAGES/falkon_greasemonkey_qt.qm
-share/locale/sr/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/sr/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/sr/LC_MESSAGES/falkon_pim_qt.qm
share/locale/sr/LC_MESSAGES/falkon_qt.qm
@@ -417,7 +492,6 @@ share/locale/sr@ijekavian/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/sr@ijekavian/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/sr@ijekavian/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/sr@ijekavian/LC_MESSAGES/falkon_greasemonkey_qt.qm
-share/locale/sr@ijekavian/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/sr@ijekavian/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/sr@ijekavian/LC_MESSAGES/falkon_pim_qt.qm
share/locale/sr@ijekavian/LC_MESSAGES/falkon_qt.qm
@@ -428,7 +502,6 @@ share/locale/sr@ijekavianlatin/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/sr@ijekavianlatin/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/sr@ijekavianlatin/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/sr@ijekavianlatin/LC_MESSAGES/falkon_greasemonkey_qt.qm
-share/locale/sr@ijekavianlatin/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/sr@ijekavianlatin/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/sr@ijekavianlatin/LC_MESSAGES/falkon_pim_qt.qm
share/locale/sr@ijekavianlatin/LC_MESSAGES/falkon_qt.qm
@@ -439,7 +512,6 @@ share/locale/sr@latin/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/sr@latin/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/sr@latin/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/sr@latin/LC_MESSAGES/falkon_greasemonkey_qt.qm
-share/locale/sr@latin/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/sr@latin/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/sr@latin/LC_MESSAGES/falkon_pim_qt.qm
share/locale/sr@latin/LC_MESSAGES/falkon_qt.qm
@@ -450,6 +522,7 @@ share/locale/sv/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/sv/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/sv/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/sv/LC_MESSAGES/falkon_greasemonkey_qt.qm
+share/locale/sv/LC_MESSAGES/falkon_hellopython.mo
share/locale/sv/LC_MESSAGES/falkon_imagefinder_qt.qm
share/locale/sv/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/sv/LC_MESSAGES/falkon_mousegestures_qt.qm
@@ -463,8 +536,6 @@ share/locale/tr/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/tr/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/tr/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/tr/LC_MESSAGES/falkon_greasemonkey_qt.qm
-share/locale/tr/LC_MESSAGES/falkon_imagefinder_qt.qm
-share/locale/tr/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/tr/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/tr/LC_MESSAGES/falkon_pim_qt.qm
share/locale/tr/LC_MESSAGES/falkon_qt.qm
@@ -475,6 +546,7 @@ share/locale/uk/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/uk/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/uk/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/uk/LC_MESSAGES/falkon_greasemonkey_qt.qm
+share/locale/uk/LC_MESSAGES/falkon_hellopython.mo
share/locale/uk/LC_MESSAGES/falkon_imagefinder_qt.qm
share/locale/uk/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/uk/LC_MESSAGES/falkon_mousegestures_qt.qm
@@ -488,6 +560,7 @@ share/locale/zh_CN/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/zh_CN/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/zh_CN/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/zh_CN/LC_MESSAGES/falkon_greasemonkey_qt.qm
+share/locale/zh_CN/LC_MESSAGES/falkon_hellopython.mo
share/locale/zh_CN/LC_MESSAGES/falkon_imagefinder_qt.qm
share/locale/zh_CN/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/zh_CN/LC_MESSAGES/falkon_mousegestures_qt.qm
@@ -496,11 +569,11 @@ share/locale/zh_CN/LC_MESSAGES/falkon_qt.qm
share/locale/zh_CN/LC_MESSAGES/falkon_statusbaricons_qt.qm
share/locale/zh_CN/LC_MESSAGES/falkon_tabmanager_qt.qm
share/locale/zh_CN/LC_MESSAGES/falkon_testplugin_qt.qm
+share/locale/zh_CN/LC_MESSAGES/falkon_verticaltabs_qt.qm
share/locale/zh_HK/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/zh_HK/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/zh_HK/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/zh_HK/LC_MESSAGES/falkon_greasemonkey_qt.qm
-share/locale/zh_HK/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/zh_HK/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/zh_HK/LC_MESSAGES/falkon_pim_qt.qm
share/locale/zh_HK/LC_MESSAGES/falkon_qt.qm
@@ -511,8 +584,6 @@ share/locale/zh_TW/LC_MESSAGES/falkon_autoscroll_qt.qm
share/locale/zh_TW/LC_MESSAGES/falkon_flashcookiemanager_qt.qm
share/locale/zh_TW/LC_MESSAGES/falkon_gnomekeyringpasswords_qt.qm
share/locale/zh_TW/LC_MESSAGES/falkon_greasemonkey_qt.qm
-share/locale/zh_TW/LC_MESSAGES/falkon_imagefinder_qt.qm
-share/locale/zh_TW/LC_MESSAGES/falkon_kwalletpasswords_qt.qm
share/locale/zh_TW/LC_MESSAGES/falkon_mousegestures_qt.qm
share/locale/zh_TW/LC_MESSAGES/falkon_pim_qt.qm
share/locale/zh_TW/LC_MESSAGES/falkon_qt.qm