aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-07-28 21:15:35 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-07-28 21:15:35 +0800
commit879d6e54f680ab7867f2af5077ac26a3c1ae149e (patch)
treef930beee97f40cc324e0422d754761307966bc96
parent69a9087f588fa3398904dd024957695e723ba2b6 (diff)
downloadfreebsd-ports-gnome-879d6e54f680ab7867f2af5077ac26a3c1ae149e.tar.gz
freebsd-ports-gnome-879d6e54f680ab7867f2af5077ac26a3c1ae149e.tar.zst
freebsd-ports-gnome-879d6e54f680ab7867f2af5077ac26a3c1ae149e.zip
Add p5-Statistics-CaseResampling 0.15
The purpose of this (XS) module is to calculate the median (or in principle also other statistics) with confidence intervals on a sample. To do that, it uses a technique called bootstrapping. In a nutshell, it resamples the sample a lot of times and for each resample, it calculates the median. From the distribution of medians, it then calculates the confidence limits. In order to implement the confidence limit calculation, various other functions had to be implemented efficiently (both algorithmically efficient and done in C). These functions may be useful in their own right and are thus exposed to Perl. Most notably, this exposes a median (and general selection) algorithm that works in linear time as opposed to the trivial implementation that requires O(n*log(n)). WWW: https://metacpan.org/release/Statistics-CaseResampling
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Statistics-CaseResampling/Makefile22
-rw-r--r--math/p5-Statistics-CaseResampling/distinfo3
-rw-r--r--math/p5-Statistics-CaseResampling/pkg-descr14
-rw-r--r--math/p5-Statistics-CaseResampling/pkg-plist3
5 files changed, 43 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 450ed98371a8..27788817bcca 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -595,6 +595,7 @@
SUBDIR += p5-Set-Window
SUBDIR += p5-Statistics-Basic
SUBDIR += p5-Statistics-Benford
+ SUBDIR += p5-Statistics-CaseResampling
SUBDIR += p5-Statistics-ChiSquare
SUBDIR += p5-Statistics-Contingency
SUBDIR += p5-Statistics-Descriptive
diff --git a/math/p5-Statistics-CaseResampling/Makefile b/math/p5-Statistics-CaseResampling/Makefile
new file mode 100644
index 000000000000..78ed296a9d85
--- /dev/null
+++ b/math/p5-Statistics-CaseResampling/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Statistics-CaseResampling
+PORTVERSION= 0.15
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Efficient resampling and calculation of medians with confidence intervals
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+USE_PERL5= configure
+USES= perl5
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Statistics/CaseResampling/CaseResampling.so
+
+.include <bsd.port.mk>
diff --git a/math/p5-Statistics-CaseResampling/distinfo b/math/p5-Statistics-CaseResampling/distinfo
new file mode 100644
index 000000000000..94f3eb488dd8
--- /dev/null
+++ b/math/p5-Statistics-CaseResampling/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532715420
+SHA256 (Statistics-CaseResampling-0.15.tar.gz) = 851c43bd6f10d32289522a50c6a209c3b246cfd3eb566773e6861eda04a49087
+SIZE (Statistics-CaseResampling-0.15.tar.gz) = 58153
diff --git a/math/p5-Statistics-CaseResampling/pkg-descr b/math/p5-Statistics-CaseResampling/pkg-descr
new file mode 100644
index 000000000000..81eb7b534108
--- /dev/null
+++ b/math/p5-Statistics-CaseResampling/pkg-descr
@@ -0,0 +1,14 @@
+The purpose of this (XS) module is to calculate the median (or in principle also
+other statistics) with confidence intervals on a sample. To do that, it uses a
+technique called bootstrapping. In a nutshell, it resamples the sample a lot of
+times and for each resample, it calculates the median. From the distribution of
+medians, it then calculates the confidence limits.
+
+In order to implement the confidence limit calculation, various other functions
+had to be implemented efficiently (both algorithmically efficient and done in
+C). These functions may be useful in their own right and are thus exposed to
+Perl. Most notably, this exposes a median (and general selection) algorithm that
+works in linear time as opposed to the trivial implementation that requires
+O(n*log(n)).
+
+WWW: https://metacpan.org/release/Statistics-CaseResampling
diff --git a/math/p5-Statistics-CaseResampling/pkg-plist b/math/p5-Statistics-CaseResampling/pkg-plist
new file mode 100644
index 000000000000..476949a88011
--- /dev/null
+++ b/math/p5-Statistics-CaseResampling/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_ARCH%%/Statistics/CaseResampling.pm
+%%SITE_ARCH%%/auto/Statistics/CaseResampling/CaseResampling.so
+%%PERL5_MAN3%%/Statistics::CaseResampling.3.gz