aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-04-16 02:59:37 +0800
committermiwi <miwi@FreeBSD.org>2007-04-16 02:59:37 +0800
commit87ecd7362c0a754db65fed0db3db000c350f7d43 (patch)
tree4cfa13e8ab7fc662427286e2315c387883c53572
parent834677c959b8983d02ac70ef5030438d2bf236a7 (diff)
downloadfreebsd-ports-gnome-87ecd7362c0a754db65fed0db3db000c350f7d43.tar.gz
freebsd-ports-gnome-87ecd7362c0a754db65fed0db3db000c350f7d43.tar.zst
freebsd-ports-gnome-87ecd7362c0a754db65fed0db3db000c350f7d43.zip
C/C++ preprocessor expands macros and processes '#if', '#include' and
some other directives. MCPP is an alternative C/C++ preprocessor with the highest conformance, implementated by Kiyoshi Matsui. MCPP is especially useful for debugging the source program which use complicated macros and also useful for checking portability of the source. It supports multiple standards: K&R, ISO C90, ISO C99, and ISO C++98. Though mcpp could be built as a replacement of GCC's resident proprocessor or as a subroutine called from some other main program, this package installs only a stand-alone program named 'mcpp' which behaves independent from GCC. WWW: http://mcpp.sourceforge.net/ - Kiyoshi Matsui <kmatsui@t3.rim.or.jp> PR: ports/111588 Submitted by: Kiyoshi Matsui <kmatsui at t3.rim.or.jp>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/mcpp/Makefile31
-rw-r--r--devel/mcpp/distinfo3
-rw-r--r--devel/mcpp/pkg-descr17
4 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 53bfc2dd06c3..4a2de57378b0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -688,6 +688,7 @@
SUBDIR += maketool
SUBDIR += maven
SUBDIR += maven2
+ SUBDIR += mcpp
SUBDIR += memcheck
SUBDIR += menhir
SUBDIR += mercator
diff --git a/devel/mcpp/Makefile b/devel/mcpp/Makefile
new file mode 100644
index 000000000000..e203148ee1f2
--- /dev/null
+++ b/devel/mcpp/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: mcpp
+# Date created: 06 April 2007
+# Whom: Kiyoshi Matsui <kmatsui@t3.rim.or.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mcpp
+PORTVERSION= 2.6.3
+CATEGORIES= devel
+MASTER_SITES= http://prdownloads.sourceforge.net/mcpp/ \
+ http://jaist.dl.sourceforge.net/sourceforge/mcpp/
+
+MAINTAINER= kmatsui@t3.rim.or.jp
+COMMENT= Alternative C/C++ preprocessor
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+MAN1= mcpp.1
+
+PLIST_FILES= bin/mcpp \
+ share/doc/mcpp/LICENSE \
+ share/doc/mcpp/NEWS \
+ share/doc/mcpp/README \
+ share/doc/mcpp/doc-jp/mcpp-manual.html \
+ share/doc/mcpp/doc/mcpp-manual.html
+PLIST_DIRS= share/doc/mcpp/doc-jp \
+ share/doc/mcpp/doc \
+ share/doc/mcpp
+
+.include <bsd.port.mk>
diff --git a/devel/mcpp/distinfo b/devel/mcpp/distinfo
new file mode 100644
index 000000000000..756096dcdb5d
--- /dev/null
+++ b/devel/mcpp/distinfo
@@ -0,0 +1,3 @@
+MD5 (mcpp-2.6.3.tar.gz) = ae64027a2d474f31656ad44ef656ca21
+SHA256 (mcpp-2.6.3.tar.gz) = ea9af7252efa76ef81508232ea2b0c2f55c1c2720086c668201c805d49dbc414
+SIZE (mcpp-2.6.3.tar.gz) = 1301041
diff --git a/devel/mcpp/pkg-descr b/devel/mcpp/pkg-descr
new file mode 100644
index 000000000000..4284924c4c0f
--- /dev/null
+++ b/devel/mcpp/pkg-descr
@@ -0,0 +1,17 @@
+C/C++ preprocessor expands macros and processes '#if', '#include' and
+some other directives.
+
+MCPP is an alternative C/C++ preprocessor with the highest conformance,
+implementated by Kiyoshi Matsui. MCPP is especially useful for
+debugging the source program which use complicated macros and also
+useful for checking portability of the source. It supports multiple
+standards: K&R, ISO C90, ISO C99, and ISO C++98.
+
+Though mcpp could be built as a replacement of GCC's resident
+proprocessor or as a subroutine called from some other main program,
+this package installs only a stand-alone program named 'mcpp' which
+behaves independent from GCC.
+
+WWW: http://mcpp.sourceforge.net/
+
+- Kiyoshi Matsui <kmatsui@t3.rim.or.jp>