aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-12-30 07:10:05 +0800
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-12-30 07:10:05 +0800
commit882731be034c820199c649eaed5950e7ca291d45 (patch)
tree390b31d97098e65f140a66357f8dda0fbf92875d
parent604fcef035f3f04c3c877a350a4b0db0e595604d (diff)
downloadfreebsd-ports-gnome-882731be034c820199c649eaed5950e7ca291d45.tar.gz
freebsd-ports-gnome-882731be034c820199c649eaed5950e7ca291d45.tar.zst
freebsd-ports-gnome-882731be034c820199c649eaed5950e7ca291d45.zip
A gravity game with addictive gameplay and bad implementation
You are the hyperspace delivery boy, use your spaceship to travel between space bases in strange places where few people have been before you. A fun to play gravity game with built in level editor. All in glorious 70s style vector graphics. WWW: http://sourceforge.net/projects/osgg/
-rw-r--r--games/Makefile1
-rw-r--r--games/osgg/Makefile39
-rw-r--r--games/osgg/distinfo3
-rw-r--r--games/osgg/pkg-descr11
-rw-r--r--games/osgg/pkg-plist14
5 files changed, 68 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 9777761bd611..2fb5ab8b8650 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -575,6 +575,7 @@
SUBDIR += openyahtzee
SUBDIR += optimax
SUBDIR += orbital_eunuchs_sniper
+ SUBDIR += osgg
SUBDIR += outerspace
SUBDIR += p5-Acme-GuessNumber
SUBDIR += p5-Algorithm-Pair-Best
diff --git a/games/osgg/Makefile b/games/osgg/Makefile
new file mode 100644
index 000000000000..08923f50e81f
--- /dev/null
+++ b/games/osgg/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: osgg
+# Date created: 29 Dec 2008
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= osgg
+DISTVERSION= 0.9beta
+CATEGORIES= games
+MASTER_SITES= SF
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= OldSkool Gravity Game
+
+USE_BZIP2= yes
+USE_SDL= sdl image ttf
+USE_GL= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-patch:
+ @${RM} -f ${WRKSRC}/osgg
+ @${REINPLACE_CMD} -e 's|"[a-z]*.txt"|DATADIR&|' ${WRKSRC}/main.cpp
+
+do-build:
+ cd ${WRKSRC} && ${CXX} ${CXXFLAGS} `${SDL_CONFIG} --libs --cflags` \
+ -lGL -lSDL_image -lSDL_ttf -DDATADIR="\"${DATADIR}/\"" \
+ -o osgg main.cpp text.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/osgg ${PREFIX}/bin/
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.txt ${WRKSRC}/Bandal.ttf \
+ ${WRKSRC}/icon.png ${DATADIR}
+ ${MKDIR} ${DATADIR}/levels
+ ${INSTALL_DATA} ${WRKSRC}/levels/* ${DATADIR}/levels
+
+.include <bsd.port.mk>
diff --git a/games/osgg/distinfo b/games/osgg/distinfo
new file mode 100644
index 000000000000..5dbfaa2c9eaa
--- /dev/null
+++ b/games/osgg/distinfo
@@ -0,0 +1,3 @@
+MD5 (osgg-0.9beta.tar.bz2) = a503ea88c4038e701a7a981bf8406db8
+SHA256 (osgg-0.9beta.tar.bz2) = d18180b5b5a1b0af2426f068da4196742d6ac6699931352e51f0abb0639692c4
+SIZE (osgg-0.9beta.tar.bz2) = 169139
diff --git a/games/osgg/pkg-descr b/games/osgg/pkg-descr
new file mode 100644
index 000000000000..40839b0a26cc
--- /dev/null
+++ b/games/osgg/pkg-descr
@@ -0,0 +1,11 @@
+A gravity game with addictive gameplay and bad implementation
+
+You are the hyperspace delivery boy, use your spaceship to travel
+between space bases in strange places where few people have been
+before you.
+
+A fun to play gravity game with built in level editor.
+
+All in glorious 70s style vector graphics.
+
+WWW: http://sourceforge.net/projects/osgg/
diff --git a/games/osgg/pkg-plist b/games/osgg/pkg-plist
new file mode 100644
index 000000000000..7f0e99d89ffd
--- /dev/null
+++ b/games/osgg/pkg-plist
@@ -0,0 +1,14 @@
+bin/osgg
+%%DATADIR%%/Bandal.ttf
+%%DATADIR%%/base.txt
+%%DATADIR%%/enemy.txt
+%%DATADIR%%/icon.png
+%%DATADIR%%/levels/0.level
+%%DATADIR%%/levels/1.level
+%%DATADIR%%/levels/2.level
+%%DATADIR%%/levels/3.level
+%%DATADIR%%/levels/4.level
+%%DATADIR%%/levels/5.level
+%%DATADIR%%/ship.txt
+@dirrm %%DATADIR%%/levels
+@dirrm %%DATADIR%%