aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2015-02-16 05:45:52 +0800
committerpgj <pgj@FreeBSD.org>2015-02-16 05:45:52 +0800
commit88fa02773f7159cc3921a909da6c7ff565781610 (patch)
treeb2c9f0728c1f2e7ec0a3c0de374addc732bb1d09
parent1f5ca9994f09baa41347608b3654d4f8a2bc60bd (diff)
downloadfreebsd-ports-gnome-88fa02773f7159cc3921a909da6c7ff565781610.tar.gz
freebsd-ports-gnome-88fa02773f7159cc3921a909da6c7ff565781610.tar.zst
freebsd-ports-gnome-88fa02773f7159cc3921a909da6c7ff565781610.zip
Add new port: devel/hs-ShellCheck
The goals of ShellCheck are: * To point out and clarify typical beginner's syntax issues, that causes a shell to give cryptic error messages. * To point out and clarify typical intermediate level semantic problems, that causes a shell to behave strangely and counter-intuitively. * To point out subtle caveats, corner cases and pitfalls, that may cause an advanced user's otherwise working script to fail under future circumstances. WWW: http://www.shellcheck.net/ PR: 197302 Submitted by: luca.pizzamiglio@gmail.com Obtained from: FreeBSD Haskell
-rw-r--r--devel/hs-ShellCheck/Makefile18
-rw-r--r--devel/hs-ShellCheck/distinfo2
-rw-r--r--devel/hs-ShellCheck/files/patch-ShellCheck.cabal28
-rw-r--r--devel/hs-ShellCheck/pkg-descr13
-rw-r--r--lang/ghc/bsd.hackage.mk1
5 files changed, 62 insertions, 0 deletions
diff --git a/devel/hs-ShellCheck/Makefile b/devel/hs-ShellCheck/Makefile
new file mode 100644
index 000000000000..8eb695171dbb
--- /dev/null
+++ b/devel/hs-ShellCheck/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= ShellCheck
+PORTVERSION= 0.3.5
+CATEGORIES= devel haskell
+
+MAINTAINER= luca.pizzamiglio@gmail.com
+COMMENT= Shell script analysis tool
+
+LICENSE= AGPLv3
+
+USE_CABAL= json>=0.7 parsec QuickCheck>=2.6 regex-posix>=0.95.2 \
+ regex-compat>=0.95.1 tf-random>=0.5
+
+EXECUTABLE= shellcheck
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-ShellCheck/distinfo b/devel/hs-ShellCheck/distinfo
new file mode 100644
index 000000000000..31b621660d6e
--- /dev/null
+++ b/devel/hs-ShellCheck/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/ShellCheck-0.3.5.tar.gz) = 9289fda0b3683f4e7c2c003f875a9e308897368fe956ed924a76cafc2fdc9974
+SIZE (cabal/ShellCheck-0.3.5.tar.gz) = 77173
diff --git a/devel/hs-ShellCheck/files/patch-ShellCheck.cabal b/devel/hs-ShellCheck/files/patch-ShellCheck.cabal
new file mode 100644
index 000000000000..0783474e383e
--- /dev/null
+++ b/devel/hs-ShellCheck/files/patch-ShellCheck.cabal
@@ -0,0 +1,28 @@
+--- ShellCheck.cabal.orig 2014-11-10 01:30:00.000000000 +0100
++++ ShellCheck.cabal 2015-02-03 18:19:38.355225341 +0100
+@@ -42,7 +42,7 @@
+ mtl,
+ parsec,
+ regex-compat,
+- QuickCheck >= 2.7.4
++ QuickCheck >= 2.6
+ exposed-modules:
+ ShellCheck.Analytics
+ ShellCheck.AST
+@@ -64,7 +64,7 @@
+ parsec,
+ regex-compat,
+ transformers,
+- QuickCheck >= 2.7.4
++ QuickCheck >= 2.6
+ main-is: shellcheck.hs
+
+ test-suite test-shellcheck
+@@ -79,6 +79,6 @@
+ parsec,
+ regex-compat,
+ transformers,
+- QuickCheck >= 2.7.4
++ QuickCheck >= 2.6
+ main-is: test/shellcheck.hs
+
diff --git a/devel/hs-ShellCheck/pkg-descr b/devel/hs-ShellCheck/pkg-descr
new file mode 100644
index 000000000000..32dceedce7df
--- /dev/null
+++ b/devel/hs-ShellCheck/pkg-descr
@@ -0,0 +1,13 @@
+The goals of ShellCheck are:
+
+ * To point out and clarify typical beginner's syntax issues, that causes
+ a shell to give cryptic error messages.
+
+ * To point out and clarify typical intermediate level semantic problems,
+ that causes a shell to behave strangely and counter-intuitively.
+
+ * To point out subtle caveats, corner cases and pitfalls, that may cause
+ an advanced user's otherwise working script to fail under future
+ circumstances.
+
+WWW: http://www.shellcheck.net/
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index e755a70b3c86..01617fc46ef8 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -345,6 +345,7 @@ setenv_port= devel/hs-setenv
SHA_port= security/hs-SHA # executable
shake_port= devel/hs-shake # executable
shakespeare_port= www/hs-shakespeare
+ShellCheck_port= devel/hs-ShellCheck # executable
show_port= devel/hs-show
silently_port= devel/hs-silently
simple-reflect_port= devel/hs-simple-reflect