aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2005-02-04 06:05:25 +0800
committerhq <hq@FreeBSD.org>2005-02-04 06:05:25 +0800
commit8923f18df28c804433826f41e3e903672af423ea (patch)
tree2d06999868de91efd562b366b79bd4d0ba81f0cd
parentad3c781c281cdece86d20f777dae3e9e8b49bb1b (diff)
downloadfreebsd-ports-gnome-8923f18df28c804433826f41e3e903672af423ea.tar.gz
freebsd-ports-gnome-8923f18df28c804433826f41e3e903672af423ea.tar.zst
freebsd-ports-gnome-8923f18df28c804433826f41e3e903672af423ea.zip
- Update to bsd.java.mk 2.0
- Use JAVALIBDIR - CP -> INSTALL_DATA - Merge do-install and post-install
-rw-r--r--net/java-beepcore/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/net/java-beepcore/Makefile b/net/java-beepcore/Makefile
index d2e8b77e4353..0ca470932e97 100644
--- a/net/java-beepcore/Makefile
+++ b/net/java-beepcore/Makefile
@@ -17,28 +17,30 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= An implementation of BEEP core and BEEP mapping for TCP in Java
-RUN_DEPENDS= ${LOCALBASE}/share/java/classes/xercesImpl.jar:${PORTSDIR}/textproc/xerces-j
+RUN_DEPENDS= ${JAVALIBDIR}/xercesImpl.jar:${PORTSDIR}/textproc/xerces-j
-USE_JAVA= 1.3+
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
NO_BUILD= yes
-NO_BUILD_DEPENDS_JAVA= yes
-
.if !defined(NOPORTDOCS)
PORTDOCS= *
.endif
do-install:
${INSTALL_DATA} ${WRKSRC}/lib/beep*.jar ${JAVAJARDIR}
- ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/example \
+ && ${FIND} -s . -type d -exec ${MKDIR} ${EXAMPLESDIR}/{} \; \
+ && ${FIND} -s . -type f -exec ${INSTALL_DATA} {} ${EXAMPLESDIR}/{} \;
${INSTALL_DATA} ${WRKSRC}/lib/example.jar ${EXAMPLESDIR}
- ${CP} -R ${WRKSRC}/example/* ${EXAMPLESDIR}
post-install:
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.txt ${WRKSRC}/*.htm ${DOCSDIR}
.if !defined(NOPORTDOCS)
- ${CP} -R ${WRKSRC}/doc/* ${DOCSDIR}
+ cd ${WRKSRC}/doc \
+ && ${FIND} -s . -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
+ && ${FIND} -s . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
.endif
.include <bsd.port.mk>