aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarkus <markus@FreeBSD.org>2004-08-14 08:19:30 +0800
committermarkus <markus@FreeBSD.org>2004-08-14 08:19:30 +0800
commit89af480840cc4aa1556e05bca7306aa4074ce187 (patch)
tree46ff9355bde0fe08ee9e203681bd7dc7bece322d
parent7fa5d7f7d7f0447645602c6441bba77cbb929da1 (diff)
downloadfreebsd-ports-gnome-89af480840cc4aa1556e05bca7306aa4074ce187.tar.gz
freebsd-ports-gnome-89af480840cc4aa1556e05bca7306aa4074ce187.tar.zst
freebsd-ports-gnome-89af480840cc4aa1556e05bca7306aa4074ce187.zip
- Fix build with gcc 3.4 [1]
- Fix build on amd64 Reported by: pointyhat via kris [1]
-rw-r--r--deskutils/krefty/Makefile2
-rw-r--r--deskutils/krefty/files/patch-krefty_part.cpp10
2 files changed, 11 insertions, 1 deletions
diff --git a/deskutils/krefty/Makefile b/deskutils/krefty/Makefile
index a6567db4cd66..439268c4a311 100644
--- a/deskutils/krefty/Makefile
+++ b/deskutils/krefty/Makefile
@@ -22,7 +22,7 @@ post-extract:
@${TOUCH} ${WRKSRC}/config.h.in
post-patch:
- @${REINPLACE_CMD} -e 's|-O2||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ @${REINPLACE_CMD} -e 's|-O2|-fPIC|g; s|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/${CONFIGURE_SCRIPT}
post-install:
diff --git a/deskutils/krefty/files/patch-krefty_part.cpp b/deskutils/krefty/files/patch-krefty_part.cpp
new file mode 100644
index 000000000000..cfbfb7d1031a
--- /dev/null
+++ b/deskutils/krefty/files/patch-krefty_part.cpp
@@ -0,0 +1,10 @@
+--- src/krefty_part.cpp.orig Sat Aug 14 02:13:08 2004
++++ src/krefty_part.cpp Sat Aug 14 02:13:22 2004
+@@ -197,6 +197,6 @@
+ {
+ return new KreftyPartFactory;
+ }
+-};
++}
+
+ #include "krefty_part.moc"