aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-07-21 06:25:22 +0800
committerbapt <bapt@FreeBSD.org>2012-07-21 06:25:22 +0800
commit8ac7ad7d1a65c91a178c62284eb3eeb03153bb2a (patch)
tree8fc0bdb4629a42a365145b869e70947e79d43e55
parent7ccc1145c9e00efe708f1e6e987b9f6cb456be15 (diff)
downloadfreebsd-ports-gnome-8ac7ad7d1a65c91a178c62284eb3eeb03153bb2a.tar.gz
freebsd-ports-gnome-8ac7ad7d1a65c91a178c62284eb3eeb03153bb2a.tar.zst
freebsd-ports-gnome-8ac7ad7d1a65c91a178c62284eb3eeb03153bb2a.zip
Convert to new options framework
-rw-r--r--textproc/senna/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/textproc/senna/Makefile b/textproc/senna/Makefile
index 1183c312dce2..3029be27e03b 100644
--- a/textproc/senna/Makefile
+++ b/textproc/senna/Makefile
@@ -25,24 +25,26 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
SENNA_HOME?= /var/senna
-OPTIONS= MECAB "use mecab for morphological analysis" on \
- NFKC "use nfkc based utf8 normalization" on
+OPTIONS_DEFINE= MECAB NFKC
+OPTIONS_DEFAULT= MECAB NFKC
+MECAB_DESC= use mecab for morphological analysis
+NFKC_DESC= use nfkc based utf8 normalization
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
BROKEN= Does not compile on ${ARCH}
.endif
-.if defined(WITH_MECAB)
+.if ${PORT_OPTIONS:MMECAB}
CONFIGURE_ARGS+= --with-mecab
LIB_DEPENDS+= mecab:${PORTSDIR}/japanese/mecab
.else
CONFIGURE_ARGS+= --without-mecab
.endif
-.if !defined(WITH_NFKC)
+.if ${PORT_OPTIONS:MNFKC}
CONFIGURE_ARGS+= --disable-nfkc
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>