aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-01-31 02:46:33 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-01-31 02:46:33 +0800
commit8ae0202d7b0d96316920ff49c547c37465d0f833 (patch)
tree2934c23618a5d306c0e4cf556a13c37595418a74
parent247c2662222fc88b0c063a64a6be4956320761a2 (diff)
downloadfreebsd-ports-gnome-8ae0202d7b0d96316920ff49c547c37465d0f833.tar.gz
freebsd-ports-gnome-8ae0202d7b0d96316920ff49c547c37465d0f833.tar.zst
freebsd-ports-gnome-8ae0202d7b0d96316920ff49c547c37465d0f833.zip
Peg-E is a peg solitaire game in which you jump over pieces in order
to remove them from the board, ultimately trying to eliminate all but one. The boards are randomly generated, with 100 levels of difficulty. The game auto-saves, and has undo-redo capability. Pieces can move horizontally, vertically, and diagonally. WWW: http://gottcode.org/peg-e/
-rw-r--r--games/Makefile1
-rw-r--r--games/peg-e/Makefile32
-rw-r--r--games/peg-e/distinfo3
-rw-r--r--games/peg-e/pkg-descr7
-rw-r--r--games/peg-e/pkg-plist8
5 files changed, 51 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index f49e61468670..c694e74d0e90 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -604,6 +604,7 @@
SUBDIR += pengupop
SUBDIR += pentix
SUBDIR += pets
+ SUBDIR += peg-e
SUBDIR += phalanx
SUBDIR += phpua-bf
SUBDIR += phpua-cod
diff --git a/games/peg-e/Makefile b/games/peg-e/Makefile
new file mode 100644
index 000000000000..9c4b3be4fb7f
--- /dev/null
+++ b/games/peg-e/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: peg-e
+# Date created: 28 Jan 2009
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= peg-e
+PORTVERSION= 1.0.0
+CATEGORIES= games
+MASTER_SITES= http://gottcode.org/peg-e/ \
+ http://mirror.amdmi3.ru/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Peg elimination game
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+
+QT_COMPONENTS= corelib gui moc_build opengl qmake_build rcc_build xml
+QT_COMPONENTS= corelib gui moc_build qmake_build rcc_build
+WANT_GNOME= yes
+INSTALLS_ICONS= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} \
+ PREFIX=${PREFIX} -spec ${QMAKESPEC} ${PORTNAME}.pro
+
+.include <bsd.port.mk>
diff --git a/games/peg-e/distinfo b/games/peg-e/distinfo
new file mode 100644
index 000000000000..39e51eff95fd
--- /dev/null
+++ b/games/peg-e/distinfo
@@ -0,0 +1,3 @@
+MD5 (peg-e-1.0.0-src.tar.bz2) = 93bba1a3ac85b0be370998359ddbed91
+SHA256 (peg-e-1.0.0-src.tar.bz2) = 23c8ceb68c9ed42b09df5612a153e5a07ea7c14c88275858794df3db569a234f
+SIZE (peg-e-1.0.0-src.tar.bz2) = 51363
diff --git a/games/peg-e/pkg-descr b/games/peg-e/pkg-descr
new file mode 100644
index 000000000000..9c1ba2dec411
--- /dev/null
+++ b/games/peg-e/pkg-descr
@@ -0,0 +1,7 @@
+Peg-E is a peg solitaire game in which you jump over pieces in order
+to remove them from the board, ultimately trying to eliminate all
+but one. The boards are randomly generated, with 100 levels of
+difficulty. The game auto-saves, and has undo-redo capability.
+Pieces can move horizontally, vertically, and diagonally.
+
+WWW: http://gottcode.org/peg-e/
diff --git a/games/peg-e/pkg-plist b/games/peg-e/pkg-plist
new file mode 100644
index 000000000000..961b34a2551a
--- /dev/null
+++ b/games/peg-e/pkg-plist
@@ -0,0 +1,8 @@
+bin/peg-e
+share/applications/peg-e.desktop
+share/icons/hicolor/48x48/apps/peg-e.png
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications