aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-08-31 07:40:56 +0800
committerbapt <bapt@FreeBSD.org>2013-08-31 07:40:56 +0800
commit8b60dc81103286c6c94aacb99e23e2e3edd4a996 (patch)
tree2818e3f115e7082a0619829afd4dfd176a6c3120
parentba979ed2bbcdede56163ea8879357234ae87a295 (diff)
downloadfreebsd-ports-gnome-8b60dc81103286c6c94aacb99e23e2e3edd4a996.tar.gz
freebsd-ports-gnome-8b60dc81103286c6c94aacb99e23e2e3edd4a996.tar.zst
freebsd-ports-gnome-8b60dc81103286c6c94aacb99e23e2e3edd4a996.zip
Eradicate USE_GNOME=pkgconfig in x11-toolkits
While here: - Convert USE_GMAKE to USES=gmake
-rw-r--r--x11-toolkits/gnocl/Makefile4
-rw-r--r--x11-toolkits/shared-desktop-ontologies/Makefile3
-rw-r--r--x11-toolkits/swt-devel/Makefile3
-rw-r--r--x11-toolkits/swt/Makefile3
4 files changed, 7 insertions, 6 deletions
diff --git a/x11-toolkits/gnocl/Makefile b/x11-toolkits/gnocl/Makefile
index a6822085b6b7..1c11d3eb84cb 100644
--- a/x11-toolkits/gnocl/Makefile
+++ b/x11-toolkits/gnocl/Makefile
@@ -16,9 +16,9 @@ LIB_DEPENDS= canberra:${PORTSDIR}/audio/libcanberra \
notify:${PORTSDIR}/devel/libnotify \
gtkimageview:${PORTSDIR}/x11-toolkits/gtkimageview
-USE_GMAKE= yes
USE_BZIP2= yes
-USE_GNOME= gtk20 libglade2 pkgconfig
+USES= gmake pkgconfig
+USE_GNOME= gtk20 libglade2
USE_TCL= 84+
USE_LDCONFIG= yes
CFLAGS+= -I${TCL_INCLUDEDIR} -L${TCL_LIBDIR}
diff --git a/x11-toolkits/shared-desktop-ontologies/Makefile b/x11-toolkits/shared-desktop-ontologies/Makefile
index fc7664b379ba..b7e8ffbea67b 100644
--- a/x11-toolkits/shared-desktop-ontologies/Makefile
+++ b/x11-toolkits/shared-desktop-ontologies/Makefile
@@ -12,8 +12,7 @@ CMAKE_ARGS+= -DPKGCONFIG_INSTALL_DIR:PATH="libdata/pkgconfig/"
INSTALL_TARGET= install
USE_BZIP2= yes
-USES= cmake
-USE_GNOME= pkgconfig
+USES= cmake pkgconfig
post-patch:
@${REINPLACE_CMD} -e 's|share/cmake/SharedDesktopOntologies|lib/cmake/SharedDesktopOntologies|' \
diff --git a/x11-toolkits/swt-devel/Makefile b/x11-toolkits/swt-devel/Makefile
index 7526b0b7c5c0..b507b00c22e9 100644
--- a/x11-toolkits/swt-devel/Makefile
+++ b/x11-toolkits/swt-devel/Makefile
@@ -23,7 +23,8 @@ OUTPUT_JAR= ${PORTNAME}${PKGNAMESUFFIX}.jar
USE_ZIP= yes
USE_GL= yes
-USE_GNOME= gtk20 pkgconfig
+USES= pkgconfig
+USE_GNOME= gtk20
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
diff --git a/x11-toolkits/swt/Makefile b/x11-toolkits/swt/Makefile
index 5a668ef38a2f..124a78ba0dd8 100644
--- a/x11-toolkits/swt/Makefile
+++ b/x11-toolkits/swt/Makefile
@@ -24,7 +24,8 @@ OUTPUT_JAR= swt.jar
USE_ZIP= yes
USE_GL= yes
-USE_GNOME= gtk20 pkgconfig
+USES= pkgconfig
+USE_GNOME= gtk20
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native