aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2003-02-12 09:11:28 +0800
committernaddy <naddy@FreeBSD.org>2003-02-12 09:11:28 +0800
commit8ba99a93b528dd3f99973354e8b848b6cafe46af (patch)
treef9cffc171863af56931a922acd41d244900f24b8
parent4c603117b11685f14dd4dacbe489c9740f67ff0c (diff)
downloadfreebsd-ports-gnome-8ba99a93b528dd3f99973354e8b848b6cafe46af.tar.gz
freebsd-ports-gnome-8ba99a93b528dd3f99973354e8b848b6cafe46af.tar.zst
freebsd-ports-gnome-8ba99a93b528dd3f99973354e8b848b6cafe46af.zip
Fix breakage introduced with recent security update.
PR: 47776 Submitted by: tmm
-rw-r--r--print/gv/Makefile2
-rw-r--r--print/gv/files/patch-source::ps.c26
2 files changed, 27 insertions, 1 deletions
diff --git a/print/gv/Makefile b/print/gv/Makefile
index 0bd72391b7c2..c45ae71e9d43 100644
--- a/print/gv/Makefile
+++ b/print/gv/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gv
PORTVERSION= 3.5.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
MASTER_SITES= ftp://ftpthep.physik.uni-mainz.de/pub/gv/unix/ \
${MASTER_SITE_TEX_CTAN}
diff --git a/print/gv/files/patch-source::ps.c b/print/gv/files/patch-source::ps.c
new file mode 100644
index 000000000000..88bd6361c2bc
--- /dev/null
+++ b/print/gv/files/patch-source::ps.c
@@ -0,0 +1,26 @@
+--- source/ps.c.orig Sat Feb 1 00:56:20 2003
++++ source/ps.c Sat Feb 1 01:17:43 2003
+@@ -1770,8 +1770,6 @@
+ (DSCcomment(line) && iscomment(line+2,(comment)))
+ #define IS_BEGIN(comment) \
+ (iscomment(line+7,(comment)))
+-#define IS_END(comment) \
+- (iscomment(line+5,(comment)))
+ #define SKIP_WHILE(cond) \
+ while (readline(fd, &line, NULL, &nbytes) && (cond)) *line_lenP += nbytes;\
+ skipped=1;
+@@ -1808,10 +1806,10 @@
+ #endif
+ if (!IS_COMMENT("Begin")) {} /* Do nothing */
+ else if IS_BEGIN("Document:") { /* Skip the EPS without handling its content */
+- while (line && !IS_END("Document")) {
+- line = ps_io_fgetchars(fd,-1);
+- if (line) *line_lenP += FD_LINE_LEN;
+- }
++ while ((line = ps_io_fgetchars(fd,-1)) && !IS_COMMENT("EndDocument"))
++ *line_lenP += FD_LINE_LEN;
++ nbytes = line ? FD_LINE_LEN : 0;
++ skipped = 1;
+ }
+ else if IS_BEGIN("Feature:") SKIP_UNTIL_1("EndFeature")
+ #ifdef USE_ACROREAD_WORKAROUND