aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2010-12-17 02:47:56 +0800
committerbapt <bapt@FreeBSD.org>2010-12-17 02:47:56 +0800
commit8bd5c04480d2de92fc171aa8541a99d2496eb461 (patch)
tree81af85352b2e1efacea77405781fbd7517b7886e
parent131717cc7a280e2493ae7870180987af59a88916 (diff)
downloadfreebsd-ports-gnome-8bd5c04480d2de92fc171aa8541a99d2496eb461.tar.gz
freebsd-ports-gnome-8bd5c04480d2de92fc171aa8541a99d2496eb461.tar.zst
freebsd-ports-gnome-8bd5c04480d2de92fc171aa8541a99d2496eb461.zip
- Prepare for devel/icu4 deletion
- fix py-icu with icu4.6 - fix portsgresql*server with icu 4.6 - remove now useless icu patch from webkit
-rw-r--r--databases/postgresql83-server/Makefile3
-rw-r--r--databases/postgresql84-server/Makefile17
-rw-r--r--databases/postgresql84-server/files/extra-patch-icu44
-rw-r--r--databases/postgresql90-server/Makefile16
-rw-r--r--databases/postgresql91-server/Makefile16
-rw-r--r--databases/postgresql92-server/Makefile16
-rw-r--r--devel/py-icu/Makefile12
-rw-r--r--devel/py-icu/files/patch-icu-4.6163
-rw-r--r--www/webkit-gtk2/Makefile12
-rw-r--r--www/webkit-gtk2/files/extra-patch-WebCore_platform_text_TextBreakIterator.h15
10 files changed, 188 insertions, 86 deletions
diff --git a/databases/postgresql83-server/Makefile b/databases/postgresql83-server/Makefile
index e111cb932dad..286cd08b9d3d 100644
--- a/databases/postgresql83-server/Makefile
+++ b/databases/postgresql83-server/Makefile
@@ -282,9 +282,10 @@ pre-su-install:
.if !defined(NO_BUILD)
post-patch:
@${REINPLACE_CMD} s/@PTHREAD_LIBS@// ${WRKSRC}/src/Makefile.global.in
-. if defined(WITH_ICU) || defined(WITH_ICU4)
+. if defined(WITH_ICU)
@${REINPLACE_CMD} -E -e \
"s|^(m4_if.*)2.6[0-9](.*Autoconf version )2.6[0-9]|\1${AUTOCONF_VERSION}\2${AUTOCONF_VERSION}|g" \
+ -e "s|_43|_46|g" \
${WRKSRC}/configure.in
. endif
diff --git a/databases/postgresql84-server/Makefile b/databases/postgresql84-server/Makefile
index df3d2dbddb02..fdd1e474d77e 100644
--- a/databases/postgresql84-server/Makefile
+++ b/databases/postgresql84-server/Makefile
@@ -97,28 +97,19 @@ OPTIONS+= DEBUG "Builds with debugging symbols" off
OPTIONS+= GSSAPI "BUild with GSSAPI support" on
# See http://people.freebsd.org/~girgen/postgresql-icu/README.html for more info
-OPTIONS+= ICU "Use ICU 4.6 for unicode collation (server)" off
-OPTIONS+= ICU4 "Use ICU 4.4 for unicode collation (server)" off
+OPTIONS+= ICU "Use ICU for unicode collation (server)" off
# See http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/76999 for more info
# (requires dump/restore if modified.)
OPTIONS+= INTDATE "Builds with 64-bit date/time type (server)" on
-. if defined(WITH_ICU) && defined(WITH_ICU4)
-IGNORE= options WITH_ICU and WITH_ICU4 are mutually exclusive
-. endif
-
-. if (defined(SERVER_ONLY) && (defined(WITH_ICU) || defined(WITH_ICU4))) || make(makesum)
+. if (defined(SERVER_ONLY) && defined(WITH_ICU)) || make(makesum)
USE_AUTOTOOLS= autoconf
CONFIGURE_ARGS+=--with-icu
PATCH_SITES+= http://people.freebsd.org/~girgen/postgresql-icu/:icu
PATCHFILES+= pg-840-icu-2009-09-15.diff.gz:icu
-. if defined(WITH_ICU4)
-LIB_DEPENDS+= icudata.44:${PORTSDIR}/devel/icu4
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-icu4
-. else
LIB_DEPENDS+= icudata.46:${PORTSDIR}/devel/icu
-. endif
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-icu4
. endif
PATCH_DIST_STRIP=-p1
@@ -295,7 +286,7 @@ pre-su-install:
.if !defined(NO_BUILD)
post-patch:
@${REINPLACE_CMD} s/@PTHREAD_LIBS@// ${WRKSRC}/src/Makefile.global.in
-. if defined(WITH_ICU) || defined(WITH_ICU4)
+. if defined(WITH_ICU)
@${REINPLACE_CMD} -E -e \
"s|^(m4_if.*)2.6[0-9](.*Autoconf version )2.6[0-9]|\1${AUTOCONF_VERSION}\2${AUTOCONF_VERSION}|g" \
${WRKSRC}/configure.in
diff --git a/databases/postgresql84-server/files/extra-patch-icu4 b/databases/postgresql84-server/files/extra-patch-icu4
index 9eda633fda4a..f233b8889778 100644
--- a/databases/postgresql84-server/files/extra-patch-icu4
+++ b/databases/postgresql84-server/files/extra-patch-icu4
@@ -8,7 +8,7 @@
- AC_CHECK_LIB(icui18n, ucol_open_3_6, [], [
- AC_CHECK_LIB(icui18n, ucol_open_3_4, [], [AC_MSG_ERROR([library 'icui18n' is required for ICU])])
- ])
-+ AC_CHECK_LIB(icui18n, ucol_open_44, [], [
++ AC_CHECK_LIB(icui18n, ucol_open_46, [], [
+ AC_CHECK_LIB(icui18n, ucol_open_3_8, [], [
+ AC_CHECK_LIB(icui18n, ucol_open_3_6, [], [
+ AC_CHECK_LIB(icui18n, ucol_open_3_4, [], [AC_MSG_ERROR([library 'icui18n' is required for ICU])])
@@ -19,7 +19,7 @@
- AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_6, [], [
- AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_4, [], [AC_MSG_ERROR([library 'icuuc' is required for ICU])])
- ])
-+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_44, [], [
++ AC_CHECK_LIB(icuuc, ucnv_fromUChars_46, [], [
+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_8, [], [
+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_6, [], [
+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_4, [], [AC_MSG_ERROR([library 'icuuc' is required for ICU])])
diff --git a/databases/postgresql90-server/Makefile b/databases/postgresql90-server/Makefile
index dc3eb4f1c7a1..77abdb59c3d1 100644
--- a/databases/postgresql90-server/Makefile
+++ b/databases/postgresql90-server/Makefile
@@ -97,27 +97,18 @@ OPTIONS+= DEBUG "Builds with debugging symbols" off
OPTIONS+= GSSAPI "BUild with GSSAPI support" on
# See http://people.freebsd.org/~girgen/postgresql-icu/README.html for more info
-OPTIONS+= ICU "Use ICU 4.6 for unicode collation (server)" off
-OPTIONS+= ICU4 "Use ICU 4.4 for unicode collation (server)" off
+OPTIONS+= ICU "Use ICU for unicode collation (server)" off
# See http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/76999 for more info
# (requires dump/restore if modified.)
OPTIONS+= INTDATE "Builds with 64-bit date/time type (server)" on
-. if defined(WITH_ICU) && defined(WITH_ICU4)
-IGNORE= options WITH_ICU and WITH_ICU4 are mutually exclusive
-. endif
-
-. if (defined(SERVER_ONLY) && (defined(WITH_ICU) || defined(WITH_ICU4))) || make(makesum)
+. if (defined(SERVER_ONLY) && defined(WITH_ICU)) || make(makesum)
USE_AUTOTOOLS= autoconf
CONFIGURE_ARGS+=--with-icu
PATCH_SITES+= http://people.freebsd.org/~girgen/postgresql-icu/:icu
PATCHFILES+= pg-900-icu-2010-09-19.diff.gz:icu
-. if defined(WITH_ICU4)
-LIB_DEPENDS+= icudata.44:${PORTSDIR}/devel/icu4
-. else
LIB_DEPENDS+= icudata.46:${PORTSDIR}/devel/icu
-. endif
. endif
PATCH_DIST_STRIP=-p1
@@ -325,9 +316,10 @@ pre-su-install:
.if !defined(NO_BUILD)
post-patch:
@${REINPLACE_CMD} s/@PTHREAD_LIBS@// ${WRKSRC}/src/Makefile.global.in
-. if defined(WITH_ICU) || defined(WITH_ICU4)
+. if defined(WITH_ICU)
@${REINPLACE_CMD} -E -e \
"s|^(m4_if.*)2.6[0-9](.*Autoconf version )2.6[0-9]|\1${AUTOCONF_VERSION}\2${AUTOCONF_VERSION}|g" \
+ -e "s|_44|_46|g" \
${WRKSRC}/configure.in
. endif
diff --git a/databases/postgresql91-server/Makefile b/databases/postgresql91-server/Makefile
index dc3eb4f1c7a1..77abdb59c3d1 100644
--- a/databases/postgresql91-server/Makefile
+++ b/databases/postgresql91-server/Makefile
@@ -97,27 +97,18 @@ OPTIONS+= DEBUG "Builds with debugging symbols" off
OPTIONS+= GSSAPI "BUild with GSSAPI support" on
# See http://people.freebsd.org/~girgen/postgresql-icu/README.html for more info
-OPTIONS+= ICU "Use ICU 4.6 for unicode collation (server)" off
-OPTIONS+= ICU4 "Use ICU 4.4 for unicode collation (server)" off
+OPTIONS+= ICU "Use ICU for unicode collation (server)" off
# See http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/76999 for more info
# (requires dump/restore if modified.)
OPTIONS+= INTDATE "Builds with 64-bit date/time type (server)" on
-. if defined(WITH_ICU) && defined(WITH_ICU4)
-IGNORE= options WITH_ICU and WITH_ICU4 are mutually exclusive
-. endif
-
-. if (defined(SERVER_ONLY) && (defined(WITH_ICU) || defined(WITH_ICU4))) || make(makesum)
+. if (defined(SERVER_ONLY) && defined(WITH_ICU)) || make(makesum)
USE_AUTOTOOLS= autoconf
CONFIGURE_ARGS+=--with-icu
PATCH_SITES+= http://people.freebsd.org/~girgen/postgresql-icu/:icu
PATCHFILES+= pg-900-icu-2010-09-19.diff.gz:icu
-. if defined(WITH_ICU4)
-LIB_DEPENDS+= icudata.44:${PORTSDIR}/devel/icu4
-. else
LIB_DEPENDS+= icudata.46:${PORTSDIR}/devel/icu
-. endif
. endif
PATCH_DIST_STRIP=-p1
@@ -325,9 +316,10 @@ pre-su-install:
.if !defined(NO_BUILD)
post-patch:
@${REINPLACE_CMD} s/@PTHREAD_LIBS@// ${WRKSRC}/src/Makefile.global.in
-. if defined(WITH_ICU) || defined(WITH_ICU4)
+. if defined(WITH_ICU)
@${REINPLACE_CMD} -E -e \
"s|^(m4_if.*)2.6[0-9](.*Autoconf version )2.6[0-9]|\1${AUTOCONF_VERSION}\2${AUTOCONF_VERSION}|g" \
+ -e "s|_44|_46|g" \
${WRKSRC}/configure.in
. endif
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index dc3eb4f1c7a1..77abdb59c3d1 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -97,27 +97,18 @@ OPTIONS+= DEBUG "Builds with debugging symbols" off
OPTIONS+= GSSAPI "BUild with GSSAPI support" on
# See http://people.freebsd.org/~girgen/postgresql-icu/README.html for more info
-OPTIONS+= ICU "Use ICU 4.6 for unicode collation (server)" off
-OPTIONS+= ICU4 "Use ICU 4.4 for unicode collation (server)" off
+OPTIONS+= ICU "Use ICU for unicode collation (server)" off
# See http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/76999 for more info
# (requires dump/restore if modified.)
OPTIONS+= INTDATE "Builds with 64-bit date/time type (server)" on
-. if defined(WITH_ICU) && defined(WITH_ICU4)
-IGNORE= options WITH_ICU and WITH_ICU4 are mutually exclusive
-. endif
-
-. if (defined(SERVER_ONLY) && (defined(WITH_ICU) || defined(WITH_ICU4))) || make(makesum)
+. if (defined(SERVER_ONLY) && defined(WITH_ICU)) || make(makesum)
USE_AUTOTOOLS= autoconf
CONFIGURE_ARGS+=--with-icu
PATCH_SITES+= http://people.freebsd.org/~girgen/postgresql-icu/:icu
PATCHFILES+= pg-900-icu-2010-09-19.diff.gz:icu
-. if defined(WITH_ICU4)
-LIB_DEPENDS+= icudata.44:${PORTSDIR}/devel/icu4
-. else
LIB_DEPENDS+= icudata.46:${PORTSDIR}/devel/icu
-. endif
. endif
PATCH_DIST_STRIP=-p1
@@ -325,9 +316,10 @@ pre-su-install:
.if !defined(NO_BUILD)
post-patch:
@${REINPLACE_CMD} s/@PTHREAD_LIBS@// ${WRKSRC}/src/Makefile.global.in
-. if defined(WITH_ICU) || defined(WITH_ICU4)
+. if defined(WITH_ICU)
@${REINPLACE_CMD} -E -e \
"s|^(m4_if.*)2.6[0-9](.*Autoconf version )2.6[0-9]|\1${AUTOCONF_VERSION}\2${AUTOCONF_VERSION}|g" \
+ -e "s|_44|_46|g" \
${WRKSRC}/configure.in
. endif
diff --git a/devel/py-icu/Makefile b/devel/py-icu/Makefile
index 699afbbd51e8..2c25ff4fda2e 100644
--- a/devel/py-icu/Makefile
+++ b/devel/py-icu/Makefile
@@ -7,7 +7,7 @@
PORTNAME= icu
PORTVERSION= 1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_CHEESESHOP}
MASTER_SITE_SUBDIR= source/P/PyICU
@@ -28,14 +28,6 @@ MAKE_ENV+= \
PYICU_LFLAGS="-L${PREFIX}/lib" \
PYICU_LIBRARIES="icui18n:icuuc:icudata"
-OPTIONS= ICU4 "Use ICU 4.x instead of 4.6" off
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_ICU4) || exists(${LOCALBASE}/lib/libicudata.so.44)
-LIB_DEPENDS+= icudata:${PORTSDIR}/devel/icu4
-.else
LIB_DEPENDS+= icudata:${PORTSDIR}/devel/icu
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/py-icu/files/patch-icu-4.6 b/devel/py-icu/files/patch-icu-4.6
new file mode 100644
index 000000000000..547d81d61b86
--- /dev/null
+++ b/devel/py-icu/files/patch-icu-4.6
@@ -0,0 +1,163 @@
+--- ./common.cpp.orig 2010-12-16 17:23:58.891824000 +0100
++++ ./common.cpp 2010-12-16 17:25:58.722360225 +0100
+@@ -1133,9 +1133,14 @@
+
+ int isUnicodeString(PyObject *arg)
+ {
++#if U_ICU_VERSION_HEX < 0x04060000
+ return (PyObject_TypeCheck(arg, &UObjectType) &&
+ (((t_uobject *) arg)->object->getDynamicClassID() ==
+ UnicodeString::getStaticClassID()));
++#else
++ return (PyObject_TypeCheck(arg, &UObjectType) &&
++ dynamic_cast<UnicodeString *>(((t_uobject *) arg)->object) != NULL);
++#endif
+ }
+
+ int32_t toUChar32(UnicodeString& u, UChar32 *c, UErrorCode& status)
+--- ./common.h.orig 2010-03-29 20:04:02.000000000 +0200
++++ ./common.h 2010-12-16 18:59:09.154326449 +0100
+@@ -117,6 +117,34 @@
+ #include <unicode/selfmt.h>
+ #endif
+
++#if U_ICU_VERSION_HEX >= 0x04060000
++#include <typeinfo>
++#endif
++
++#if U_ICU_VERSION_HEX < 0x04060000
++typedef UClassID classid;
++#else
++typedef const char *classid;
++#endif
++
++enum {
++ UObject_ID,
++ Replaceable_ID,
++ MeasureUnit_ID,
++ Measure_ID,
++ StringEnumeration_ID,
++ ForwardCharacterIterator_ID,
++ CharacterIterator_ID,
++ BreakIterator_ID,
++ Format_ID,
++ MeasureFormat_ID,
++ DateFormat_ID,
++ Calendar_ID,
++ Collator_ID,
++ UnicodeMatcher_ID,
++ SearchIterator_ID
++};
++
+ U_NAMESPACE_USE
+
+ /* lifted from ustrenum.h */
+@@ -138,24 +166,6 @@
+ extern PyObject *PyExc_ICUError;
+ extern PyObject *PyExc_InvalidArgsError;
+
+-enum {
+- UObject_ID,
+- Replaceable_ID,
+- MeasureUnit_ID,
+- Measure_ID,
+- StringEnumeration_ID,
+- ForwardCharacterIterator_ID,
+- CharacterIterator_ID,
+- BreakIterator_ID,
+- Format_ID,
+- MeasureFormat_ID,
+- DateFormat_ID,
+- Calendar_ID,
+- Collator_ID,
+- UnicodeMatcher_ID,
+- SearchIterator_ID
+-};
+-
+ void _init_common(PyObject *m);
+
+ class ICUException {
+@@ -214,14 +224,14 @@
+ int32_t toUChar32(UnicodeString& u, UChar32 *c, UErrorCode& status);
+ UnicodeString fromUChar32(UChar32 c);
+
+-int isInstance(PyObject *arg, UClassID id, PyTypeObject *type);
+-void registerType(PyTypeObject *type, UClassID id);
++int isInstance(PyObject *arg, classid id, PyTypeObject *type);
++void registerType(PyTypeObject *type, classid id);
+
+ Formattable *toFormattable(PyObject *arg);
+ Formattable *toFormattableArray(PyObject *arg, int *len,
+- UClassID id, PyTypeObject *type);
++ classid id, PyTypeObject *type);
+
+-UObject **pl2cpa(PyObject *arg, int *len, UClassID id, PyTypeObject *type);
++UObject **pl2cpa(PyObject *arg, int *len, classid id, PyTypeObject *type);
+ PyObject *cpa2pl(UObject **array, int len, PyObject *(*wrap)(UObject *, int));
+
+ PyObject *PyErr_SetArgsError(PyObject *self, char *name, PyObject *args);
+--- ./macros.h.orig 2010-04-18 01:49:23.000000000 +0200
++++ ./macros.h 2010-12-16 19:01:11.229839485 +0100
+@@ -271,12 +271,20 @@
+ /* tp_itemsize */ 0, \
+ };
+
++#if U_ICU_VERSION_HEX < 0x04060000
+ #define TYPE_CLASSID(name) \
+ name::getStaticClassID(), &name##Type
+
+ #define TYPE_ID(name) \
+ (UClassID) (name##_ID), &name##Type
++#else
++#define TYPE_CLASSID(className) \
++ typeid(className).name(), &className##Type
++#define TYPE_ID(className) \
++ typeid(className).name(), &className##Type
++#endif
+
++#if U_ICU_VERSION_HEX < 0x04060000
+ #define INSTALL_TYPE(name, module) \
+ if (PyType_Ready(&name##Type) == 0) \
+ { \
+@@ -284,6 +292,16 @@
+ PyModule_AddObject(module, #name, (PyObject *) &name##Type); \
+ registerType(&name##Type, (UClassID) name##_ID); \
+ }
++#else
++#define INSTALL_TYPE(className, module) \
++ if (PyType_Ready(&className##Type) == 0) \
++ { \
++ Py_INCREF(&className##Type); \
++ PyModule_AddObject(module, #className, \
++ (PyObject *) &className##Type); \
++ registerType(&className##Type, typeid(className).name()); \
++ }
++#endif
+
+ #define INSTALL_STRUCT(name, module) \
+ if (PyType_Ready(&name##Type) == 0) \
+@@ -292,6 +310,16 @@
+ PyModule_AddObject(module, #name, (PyObject *) &name##Type); \
+ }
+
++#if U_ICU_VERSION_HEX >= 0x04060000
++#define REGISTER_TYPE(className, module) \
++ if (PyType_Ready(&className##Type) == 0) \
++ { \
++ Py_INCREF(&className##Type); \
++ PyModule_AddObject(module, #className, \
++ (PyObject *) &className##Type); \
++ registerType(&className##Type, typeid(className).name()); \
++ }
++#else
+ #define REGISTER_TYPE(name, module) \
+ if (PyType_Ready(&name##Type) == 0) \
+ { \
+@@ -299,6 +327,7 @@
+ PyModule_AddObject(module, #name, (PyObject *) &name##Type); \
+ registerType(&name##Type, name::getStaticClassID()); \
+ }
++#endif
+
+ #define INSTALL_CONSTANTS_TYPE(name, module) \
+ if (PyType_Ready(&name##Type) == 0) \
diff --git a/www/webkit-gtk2/Makefile b/www/webkit-gtk2/Makefile
index 54a75ca8f226..20f03e550a50 100644
--- a/www/webkit-gtk2/Makefile
+++ b/www/webkit-gtk2/Makefile
@@ -8,7 +8,7 @@
PORTNAME= webkit
PORTVERSION= 1.2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://webkitgtk.org/
PKGNAMESUFFIX= -gtk2
@@ -21,7 +21,8 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
LIB_DEPENDS= enchant.1:${PORTSDIR}/textproc/enchant \
curl.6:${PORTSDIR}/ftp/curl \
sqlite3.8:${PORTSDIR}/databases/sqlite3 \
- soup-2.4.1:${PORTSDIR}/devel/libsoup
+ soup-2.4.1:${PORTSDIR}/devel/libsoup \
+ icutu.46:${PORTSDIR}/devel/icu
USE_GETTEXT= yes
WANT_GSTREAMER= yes
@@ -53,13 +54,6 @@ OPTIONS= VIDEO "Enable video support" on \
.include <bsd.port.pre.mk>
-.if exists (${LOCALBASE}/lib/libicutu.so.44)
-LIB_DEPENDS+= icutu.44:${PORTSDIR}/devel/icu4
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-WebCore_platform_text_TextBreakIterator.h
-.else
-LIB_DEPENDS+= icutu.46:${PORTSDIR}/devel/icu
-.endif
-
.if defined(WITH_VIDEO)
USE_GSTREAMER+= yes
CONFIGURE_ARGS+=--enable-video
diff --git a/www/webkit-gtk2/files/extra-patch-WebCore_platform_text_TextBreakIterator.h b/www/webkit-gtk2/files/extra-patch-WebCore_platform_text_TextBreakIterator.h
deleted file mode 100644
index a865035350a4..000000000000
--- a/www/webkit-gtk2/files/extra-patch-WebCore_platform_text_TextBreakIterator.h
+++ /dev/null
@@ -1,15 +0,0 @@
-Pr 143718, fix build with icu 4.3
-
---- WebCore/platform/text/TextBreakIterator.h.orig 2009-09-22 18:29:21.000000000 +0300
-+++ WebCore/platform/text/TextBreakIterator.h 2010-02-10 08:49:59.000000000 +0200
-@@ -26,7 +26,7 @@
-
- namespace WebCore {
-
-- class TextBreakIterator;
-+ typedef struct UBreakIterator TextBreakIterator;
-
- // Note: The returned iterator is good only until you get another iterator.
-
-
-