aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2016-10-28 17:41:05 +0800
committerolgeni <olgeni@FreeBSD.org>2016-10-28 17:41:05 +0800
commit8c8efb7061881164a6e37930f3d39c0f029684e4 (patch)
treecb373b746d6b92687aa12c80485b8f15e1961444
parent4c3526cb7b23c5cbbf76653c486e8a03e556dd1b (diff)
downloadfreebsd-ports-gnome-8c8efb7061881164a6e37930f3d39c0f029684e4.tar.gz
freebsd-ports-gnome-8c8efb7061881164a6e37930f3d39c0f029684e4.tar.zst
freebsd-ports-gnome-8c8efb7061881164a6e37930f3d39c0f029684e4.zip
Add net/py-rabbitpy, a RabbitMQ client library for Python.
-rw-r--r--net/Makefile1
-rw-r--r--net/py-rabbitpy/Makefile21
-rw-r--r--net/py-rabbitpy/distinfo3
-rw-r--r--net/py-rabbitpy/pkg-descr7
4 files changed, 32 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 6df7710f6291..84ac87daae79 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1022,6 +1022,7 @@
SUBDIR += py-pyzmq
SUBDIR += py-qt4-network
SUBDIR += py-qt5-network
+ SUBDIR += py-rabbitpy
SUBDIR += py-radix
SUBDIR += py-raet
SUBDIR += py-rainbowstream
diff --git a/net/py-rabbitpy/Makefile b/net/py-rabbitpy/Makefile
new file mode 100644
index 000000000000..ed3879bc63ce
--- /dev/null
+++ b/net/py-rabbitpy/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= rabbitpy
+PORTVERSION= 1.0.0
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= RabbitMQ client library for Python
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pamqp>0:net/py-pamqp
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pamqp>0:net/py-pamqp
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/net/py-rabbitpy/distinfo b/net/py-rabbitpy/distinfo
new file mode 100644
index 000000000000..9394ed3d502c
--- /dev/null
+++ b/net/py-rabbitpy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1477642209
+SHA256 (rabbitpy-1.0.0.tar.gz) = 54d33746d0c6a686417cd354346803945df0740b39fb92842d259387100db126
+SIZE (rabbitpy-1.0.0.tar.gz) = 41453
diff --git a/net/py-rabbitpy/pkg-descr b/net/py-rabbitpy/pkg-descr
new file mode 100644
index 000000000000..a92c0e490893
--- /dev/null
+++ b/net/py-rabbitpy/pkg-descr
@@ -0,0 +1,7 @@
+A pure python, thread-safe, minimalistic and Pythonic BSD Licensed
+AMQP/RabbitMQ library that supports Python 2.6+ and Python 3.2+.
+rabbitpy aims to provide a simple and easy to use API for interfacing
+with RabbitMQ, minimizing the programming overhead often found in
+other libraries.
+
+WWW: https://github.com/gmr/rabbitpy