aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2011-02-26 22:07:33 +0800
committerkuriyama <kuriyama@FreeBSD.org>2011-02-26 22:07:33 +0800
commit8cbd783bc38c96dc576beafd7ec20e0b807bf073 (patch)
tree9dc662f9e526d0ab0c28645099cd9b255ae463c5
parentce2e3588309eae185afe5baa9a404cf0a6f4a969 (diff)
downloadfreebsd-ports-gnome-8cbd783bc38c96dc576beafd7ec20e0b807bf073.tar.gz
freebsd-ports-gnome-8cbd783bc38c96dc576beafd7ec20e0b807bf073.tar.zst
freebsd-ports-gnome-8cbd783bc38c96dc576beafd7ec20e0b807bf073.zip
Data::Page::NoTotalEntries is a generic pager object, so it's very
similar with Data::Page. But so Data::Page::NoTotalEntries doesn't support $pager->total_entries and other some methods. WWW: http://search.cpan.org/dist/Data-Page-NoTotalEntries/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-Page-NoTotalEntries/Makefile27
-rw-r--r--devel/p5-Data-Page-NoTotalEntries/distinfo2
-rw-r--r--devel/p5-Data-Page-NoTotalEntries/pkg-descr5
-rw-r--r--devel/p5-Data-Page-NoTotalEntries/pkg-plist8
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ae9bffec4d69..822c1625ef4c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1419,6 +1419,7 @@
SUBDIR += p5-Data-Model
SUBDIR += p5-Data-ObjectDriver
SUBDIR += p5-Data-OptList
+ SUBDIR += p5-Data-Page-NoTotalEntries
SUBDIR += p5-Data-ParseBinary
SUBDIR += p5-Data-Path
SUBDIR += p5-Data-Properties
diff --git a/devel/p5-Data-Page-NoTotalEntries/Makefile b/devel/p5-Data-Page-NoTotalEntries/Makefile
new file mode 100644
index 000000000000..47f4ab086dfa
--- /dev/null
+++ b/devel/p5-Data-Page-NoTotalEntries/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Data::Page::NoTotalEntries
+# Date created: 26 Feb 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Page-NoTotalEntries
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/T/TO/TOKUHIROM
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for paging results without total entries
+
+RUN_DEPENDS= \
+ p5-Class-Accessor-Lite>=0.05:${PORTSDIR}/devel/p5-Class-Accessor-Lite
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Page::NoTotalEntries.3 \
+ Data::Page::README.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-Page-NoTotalEntries/distinfo b/devel/p5-Data-Page-NoTotalEntries/distinfo
new file mode 100644
index 000000000000..4d86534e5f09
--- /dev/null
+++ b/devel/p5-Data-Page-NoTotalEntries/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Data-Page-NoTotalEntries-0.02.tar.gz) = 75feb9fa0d952049e26942307eba2da5dd478041c433ebd544a973bce0c314a1
+SIZE (Data-Page-NoTotalEntries-0.02.tar.gz) = 21068
diff --git a/devel/p5-Data-Page-NoTotalEntries/pkg-descr b/devel/p5-Data-Page-NoTotalEntries/pkg-descr
new file mode 100644
index 000000000000..bce60b568cae
--- /dev/null
+++ b/devel/p5-Data-Page-NoTotalEntries/pkg-descr
@@ -0,0 +1,5 @@
+Data::Page::NoTotalEntries is a generic pager object, so it's very
+similar with Data::Page. But so Data::Page::NoTotalEntries doesn't
+support $pager->total_entries and other some methods.
+
+WWW: http://search.cpan.org/dist/Data-Page-NoTotalEntries/
diff --git a/devel/p5-Data-Page-NoTotalEntries/pkg-plist b/devel/p5-Data-Page-NoTotalEntries/pkg-plist
new file mode 100644
index 000000000000..c387224e728c
--- /dev/null
+++ b/devel/p5-Data-Page-NoTotalEntries/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Page/NoTotalEntries/.packlist
+%%SITE_PERL%%/Data/Page/NoTotalEntries.pm
+%%SITE_PERL%%/Data/Page/README.pod
+@dirrmtry %%SITE_PERL%%/Data/Page
+@dirrmtry %%SITE_PERL%%/Data
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Page/NoTotalEntries
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Page
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data