aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-11-26 02:57:36 +0800
committerarved <arved@FreeBSD.org>2003-11-26 02:57:36 +0800
commit8d02851893088fbd6325b8f856c6d36f021ad541 (patch)
treead68cb4baecad65ecf87a115e660ceeeef6a54a8
parentb9e41154e2f7142e8e0b30e14a0c731c1d95e6d6 (diff)
downloadfreebsd-ports-gnome-8d02851893088fbd6325b8f856c6d36f021ad541.tar.gz
freebsd-ports-gnome-8d02851893088fbd6325b8f856c6d36f021ad541.tar.zst
freebsd-ports-gnome-8d02851893088fbd6325b8f856c6d36f021ad541.zip
- AMD64 has no APM
- Revert logic, i386 seems to be the only ARCH with APM Submitted by: Adriaan de Groot Approved by: portmgr (marcus)
-rw-r--r--archivers/ark/Makefile6
-rw-r--r--comms/kremotecontrol/Makefile6
-rw-r--r--deskutils/kcharselect/Makefile6
-rw-r--r--math/kcalc/Makefile6
-rw-r--r--misc/kdeutils3/Makefile6
-rw-r--r--misc/kdeutils4/Makefile6
-rw-r--r--security/kgpg-kde4/Makefile6
-rw-r--r--security/kwallet/Makefile6
-rw-r--r--sysutils/kdf/Makefile6
-rw-r--r--sysutils/kfloppy/Makefile6
-rw-r--r--sysutils/sweeper/Makefile6
11 files changed, 33 insertions, 33 deletions
diff --git a/archivers/ark/Makefile b/archivers/ark/Makefile
index 859e72f5166a..9377ff6c1376 100644
--- a/archivers/ark/Makefile
+++ b/archivers/ark/Makefile
@@ -28,10 +28,10 @@ USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
-#klaptop doesn't like alpha and ia64 because they don't support apm
-.if (${MACHINE_ARCH} == "alpha") || (${MACHINE_ARCH} == "ia64")
+#klaptop needs APM, which is i386 only
+.if ${MACHINE_ARCH} != "i386"
WITHOUT_KLAPTOP =yes
-.endif # ${MACHINE_ARCH} == "alpha"
+.endif
.if defined(WITHOUT_KLAPTOP)
DO_NOT_COMPILE+=klaptopdaemon
diff --git a/comms/kremotecontrol/Makefile b/comms/kremotecontrol/Makefile
index 859e72f5166a..9377ff6c1376 100644
--- a/comms/kremotecontrol/Makefile
+++ b/comms/kremotecontrol/Makefile
@@ -28,10 +28,10 @@ USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
-#klaptop doesn't like alpha and ia64 because they don't support apm
-.if (${MACHINE_ARCH} == "alpha") || (${MACHINE_ARCH} == "ia64")
+#klaptop needs APM, which is i386 only
+.if ${MACHINE_ARCH} != "i386"
WITHOUT_KLAPTOP =yes
-.endif # ${MACHINE_ARCH} == "alpha"
+.endif
.if defined(WITHOUT_KLAPTOP)
DO_NOT_COMPILE+=klaptopdaemon
diff --git a/deskutils/kcharselect/Makefile b/deskutils/kcharselect/Makefile
index 859e72f5166a..9377ff6c1376 100644
--- a/deskutils/kcharselect/Makefile
+++ b/deskutils/kcharselect/Makefile
@@ -28,10 +28,10 @@ USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
-#klaptop doesn't like alpha and ia64 because they don't support apm
-.if (${MACHINE_ARCH} == "alpha") || (${MACHINE_ARCH} == "ia64")
+#klaptop needs APM, which is i386 only
+.if ${MACHINE_ARCH} != "i386"
WITHOUT_KLAPTOP =yes
-.endif # ${MACHINE_ARCH} == "alpha"
+.endif
.if defined(WITHOUT_KLAPTOP)
DO_NOT_COMPILE+=klaptopdaemon
diff --git a/math/kcalc/Makefile b/math/kcalc/Makefile
index 859e72f5166a..9377ff6c1376 100644
--- a/math/kcalc/Makefile
+++ b/math/kcalc/Makefile
@@ -28,10 +28,10 @@ USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
-#klaptop doesn't like alpha and ia64 because they don't support apm
-.if (${MACHINE_ARCH} == "alpha") || (${MACHINE_ARCH} == "ia64")
+#klaptop needs APM, which is i386 only
+.if ${MACHINE_ARCH} != "i386"
WITHOUT_KLAPTOP =yes
-.endif # ${MACHINE_ARCH} == "alpha"
+.endif
.if defined(WITHOUT_KLAPTOP)
DO_NOT_COMPILE+=klaptopdaemon
diff --git a/misc/kdeutils3/Makefile b/misc/kdeutils3/Makefile
index 859e72f5166a..9377ff6c1376 100644
--- a/misc/kdeutils3/Makefile
+++ b/misc/kdeutils3/Makefile
@@ -28,10 +28,10 @@ USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
-#klaptop doesn't like alpha and ia64 because they don't support apm
-.if (${MACHINE_ARCH} == "alpha") || (${MACHINE_ARCH} == "ia64")
+#klaptop needs APM, which is i386 only
+.if ${MACHINE_ARCH} != "i386"
WITHOUT_KLAPTOP =yes
-.endif # ${MACHINE_ARCH} == "alpha"
+.endif
.if defined(WITHOUT_KLAPTOP)
DO_NOT_COMPILE+=klaptopdaemon
diff --git a/misc/kdeutils4/Makefile b/misc/kdeutils4/Makefile
index 859e72f5166a..9377ff6c1376 100644
--- a/misc/kdeutils4/Makefile
+++ b/misc/kdeutils4/Makefile
@@ -28,10 +28,10 @@ USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
-#klaptop doesn't like alpha and ia64 because they don't support apm
-.if (${MACHINE_ARCH} == "alpha") || (${MACHINE_ARCH} == "ia64")
+#klaptop needs APM, which is i386 only
+.if ${MACHINE_ARCH} != "i386"
WITHOUT_KLAPTOP =yes
-.endif # ${MACHINE_ARCH} == "alpha"
+.endif
.if defined(WITHOUT_KLAPTOP)
DO_NOT_COMPILE+=klaptopdaemon
diff --git a/security/kgpg-kde4/Makefile b/security/kgpg-kde4/Makefile
index 859e72f5166a..9377ff6c1376 100644
--- a/security/kgpg-kde4/Makefile
+++ b/security/kgpg-kde4/Makefile
@@ -28,10 +28,10 @@ USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
-#klaptop doesn't like alpha and ia64 because they don't support apm
-.if (${MACHINE_ARCH} == "alpha") || (${MACHINE_ARCH} == "ia64")
+#klaptop needs APM, which is i386 only
+.if ${MACHINE_ARCH} != "i386"
WITHOUT_KLAPTOP =yes
-.endif # ${MACHINE_ARCH} == "alpha"
+.endif
.if defined(WITHOUT_KLAPTOP)
DO_NOT_COMPILE+=klaptopdaemon
diff --git a/security/kwallet/Makefile b/security/kwallet/Makefile
index 859e72f5166a..9377ff6c1376 100644
--- a/security/kwallet/Makefile
+++ b/security/kwallet/Makefile
@@ -28,10 +28,10 @@ USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
-#klaptop doesn't like alpha and ia64 because they don't support apm
-.if (${MACHINE_ARCH} == "alpha") || (${MACHINE_ARCH} == "ia64")
+#klaptop needs APM, which is i386 only
+.if ${MACHINE_ARCH} != "i386"
WITHOUT_KLAPTOP =yes
-.endif # ${MACHINE_ARCH} == "alpha"
+.endif
.if defined(WITHOUT_KLAPTOP)
DO_NOT_COMPILE+=klaptopdaemon
diff --git a/sysutils/kdf/Makefile b/sysutils/kdf/Makefile
index 859e72f5166a..9377ff6c1376 100644
--- a/sysutils/kdf/Makefile
+++ b/sysutils/kdf/Makefile
@@ -28,10 +28,10 @@ USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
-#klaptop doesn't like alpha and ia64 because they don't support apm
-.if (${MACHINE_ARCH} == "alpha") || (${MACHINE_ARCH} == "ia64")
+#klaptop needs APM, which is i386 only
+.if ${MACHINE_ARCH} != "i386"
WITHOUT_KLAPTOP =yes
-.endif # ${MACHINE_ARCH} == "alpha"
+.endif
.if defined(WITHOUT_KLAPTOP)
DO_NOT_COMPILE+=klaptopdaemon
diff --git a/sysutils/kfloppy/Makefile b/sysutils/kfloppy/Makefile
index 859e72f5166a..9377ff6c1376 100644
--- a/sysutils/kfloppy/Makefile
+++ b/sysutils/kfloppy/Makefile
@@ -28,10 +28,10 @@ USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
-#klaptop doesn't like alpha and ia64 because they don't support apm
-.if (${MACHINE_ARCH} == "alpha") || (${MACHINE_ARCH} == "ia64")
+#klaptop needs APM, which is i386 only
+.if ${MACHINE_ARCH} != "i386"
WITHOUT_KLAPTOP =yes
-.endif # ${MACHINE_ARCH} == "alpha"
+.endif
.if defined(WITHOUT_KLAPTOP)
DO_NOT_COMPILE+=klaptopdaemon
diff --git a/sysutils/sweeper/Makefile b/sysutils/sweeper/Makefile
index 859e72f5166a..9377ff6c1376 100644
--- a/sysutils/sweeper/Makefile
+++ b/sysutils/sweeper/Makefile
@@ -28,10 +28,10 @@ USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
-#klaptop doesn't like alpha and ia64 because they don't support apm
-.if (${MACHINE_ARCH} == "alpha") || (${MACHINE_ARCH} == "ia64")
+#klaptop needs APM, which is i386 only
+.if ${MACHINE_ARCH} != "i386"
WITHOUT_KLAPTOP =yes
-.endif # ${MACHINE_ARCH} == "alpha"
+.endif
.if defined(WITHOUT_KLAPTOP)
DO_NOT_COMPILE+=klaptopdaemon