aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2017-02-06 20:55:02 +0800
committerbrnrd <brnrd@FreeBSD.org>2017-02-06 20:55:02 +0800
commit8d08a0479a6a488372fbb98a7314a63c0111704d (patch)
treea783f003aad8c0f7415aec3a43f424dbbff45113
parentc7df66d2313fad29d554b93ee47d3dcc6f77b54b (diff)
downloadfreebsd-ports-gnome-8d08a0479a6a488372fbb98a7314a63c0111704d.tar.gz
freebsd-ports-gnome-8d08a0479a6a488372fbb98a7314a63c0111704d.tar.zst
freebsd-ports-gnome-8d08a0479a6a488372fbb98a7314a63c0111704d.zip
security/sslscan: Update to 1.11.8
- Update to 1.11.8 - Add USES= ssl - Re-roll patches - Fix build with libressl-devel PR: 213652 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl> Approved by: maintainer time-out
-rw-r--r--security/sslscan/Makefile5
-rw-r--r--security/sslscan/distinfo6
-rw-r--r--security/sslscan/files/patch-Makefile6
-rw-r--r--security/sslscan/files/patch-sslscan.c23
4 files changed, 28 insertions, 12 deletions
diff --git a/security/sslscan/Makefile b/security/sslscan/Makefile
index d16eb1ffc9d7..a35092438a11 100644
--- a/security/sslscan/Makefile
+++ b/security/sslscan/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sslscan
-PORTVERSION= 1.11.6
+PORTVERSION= 1.11.8
DISTVERSIONSUFFIX= -${GH_ACCOUNT}
CATEGORIES= security
@@ -11,8 +11,7 @@ COMMENT= SSLScan is a fast SSL port scanner
LICENSE= GPLv3
-USES= gmake
-USE_OPENSSL= yes
+USES= gmake ssl
USE_GITHUB= yes
GH_ACCOUNT= rbsec
diff --git a/security/sslscan/distinfo b/security/sslscan/distinfo
index 63359dda0a48..05940fb50780 100644
--- a/security/sslscan/distinfo
+++ b/security/sslscan/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1464783619
-SHA256 (rbsec-sslscan-1.11.6-rbsec_GH0.tar.gz) = 18932a78ad968dc5859b8cc72c84e64a46367887eb9302eaf13069bb9da1e08d
-SIZE (rbsec-sslscan-1.11.6-rbsec_GH0.tar.gz) = 50002
+TIMESTAMP = 1486214215
+SHA256 (rbsec-sslscan-1.11.8-rbsec_GH0.tar.gz) = 1449f8bb45d323b322cb070a74d8dcc57b43ca2dba0560e7a16151efc8b3d911
+SIZE (rbsec-sslscan-1.11.8-rbsec_GH0.tar.gz) = 51583
diff --git a/security/sslscan/files/patch-Makefile b/security/sslscan/files/patch-Makefile
index 4f74eb392f54..93f03df1b6d6 100644
--- a/security/sslscan/files/patch-Makefile
+++ b/security/sslscan/files/patch-Makefile
@@ -1,4 +1,4 @@
---- Makefile.orig 2016-03-24 21:02:55 UTC
+--- Makefile.orig 2016-11-06 13:27:11 UTC
+++ Makefile
@@ -3,7 +3,7 @@ ifndef CC
CC=gcc
@@ -21,9 +21,9 @@
MAN1DIR = $(MANDIR)/man1
WARNINGS = -Wall -Wformat=2
-@@ -68,6 +68,9 @@ install:
- ifeq ($(OS), Darwin)
+@@ -70,6 +70,9 @@ ifeq ($(OS), Darwin)
install sslscan $(DESTDIR)$(BINDIR)/sslscan;
+ install -d $(DESTDIR)$(MAN1DIR)/;
install sslscan.1 $(DESTDIR)$(MAN1DIR)/sslscan.1;
+else ifeq ($(OS), FreeBSD)
+ install -s -m 755 sslscan $(DESTDIR)$(BINDIR)
diff --git a/security/sslscan/files/patch-sslscan.c b/security/sslscan/files/patch-sslscan.c
index b6e516371e70..f0bae4b33cd4 100644
--- a/security/sslscan/files/patch-sslscan.c
+++ b/security/sslscan/files/patch-sslscan.c
@@ -1,6 +1,6 @@
---- sslscan.c.orig 2016-03-24 21:02:55 UTC
+--- sslscan.c.orig 2016-11-06 13:27:11 UTC
+++ sslscan.c
-@@ -788,7 +788,7 @@ int testCompression(struct sslCheckOptio
+@@ -829,7 +829,7 @@ int testCompression(struct sslCheckOptio
#endif
{
printf("%sOpenSSL version does not support compression%s\n", COL_RED, RESET);
@@ -9,7 +9,24 @@
}
// Disconnect SSL over socket
-@@ -1291,7 +1291,11 @@ int testCipher(struct sslCheckOptions *o
+@@ -1155,14 +1155,14 @@ int testRenegotiation(struct sslCheckOpt
+ printf_verbose("Attempting SSL_do_handshake(ssl)\n");
+ SSL_do_handshake(ssl); // Send renegotiation request to server //TODO :: XXX hanging here
+
+- if (ssl->state == SSL_ST_OK)
++ if (SSL_get_state(ssl) == SSL_ST_OK)
+ {
+ res = SSL_do_handshake(ssl); // Send renegotiation request to server
+ if( res != 1 )
+ {
+ printf_error("\n\nSSL_do_handshake() call failed\n");
+ }
+- if (ssl->state == SSL_ST_OK)
++ if (SSL_get_state(ssl) == SSL_ST_OK)
+ {
+ /* our renegotiation is complete */
+ renOut->supported = true;
+@@ -1504,7 +1504,11 @@ int testCipher(struct sslCheckOptions *o
return false;
}