aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2013-03-27 07:25:19 +0800
committerdelphij <delphij@FreeBSD.org>2013-03-27 07:25:19 +0800
commit8d1afddbb9e577f22d38f5df0b6261574b339316 (patch)
tree31f33ba98cedfc78b4854e436ac75283ff61a97a
parentb006df98503fc011ea476e5ce98d086adb714f1a (diff)
downloadfreebsd-ports-gnome-8d1afddbb9e577f22d38f5df0b6261574b339316.tar.gz
freebsd-ports-gnome-8d1afddbb9e577f22d38f5df0b6261574b339316.tar.zst
freebsd-ports-gnome-8d1afddbb9e577f22d38f5df0b6261574b339316.zip
In validate target, use unexpand and sed to make sure that we are using
consistent space style. Reviewed by: stas, simon
-rw-r--r--security/vuxml/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/security/vuxml/Makefile b/security/vuxml/Makefile
index ca13a1182141..76508e38ed97 100644
--- a/security/vuxml/Makefile
+++ b/security/vuxml/Makefile
@@ -80,6 +80,17 @@ validate: tidy
else \
return 1; \
fi
+ @${ECHO_MSG} Checking for space/tab...
+ @unexpand "${VUXML_FILE}" | ${SED} 's,[[:space:]]*$$,,g' > "${VUXML_FILE}.unexpanded"
+ @if ${DIFF} -u "${VUXML_FILE}" "${VUXML_FILE}.unexpanded"; \
+ then \
+ ${ECHO_MSG} ... seems okay; \
+ ${RM} "${VUXML_FILE}.unexpanded"; \
+ else \
+ ${ECHO_MSG} ... see above; \
+ ${ECHO_CMD} Consider using ${VUXML_FILE}.unexpanded for final commit; \
+ return 1; \
+ fi
tidy: vuln.xml
@if [ ! -e ${LOCALBASE}/share/xml/dtd/vuxml/catalog.xml ]; \