aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlth <lth@FreeBSD.org>2006-11-29 05:11:47 +0800
committerlth <lth@FreeBSD.org>2006-11-29 05:11:47 +0800
commit8d3554c243002338fb3ecb147f03a4c141de1f33 (patch)
tree75142a2d4173369fcf0db82fb81c46035824f2e5
parent24abdad5255d88eaac157c04832f2b8056a3d908 (diff)
downloadfreebsd-ports-gnome-8d3554c243002338fb3ecb147f03a4c141de1f33.tar.gz
freebsd-ports-gnome-8d3554c243002338fb3ecb147f03a4c141de1f33.tar.zst
freebsd-ports-gnome-8d3554c243002338fb3ecb147f03a4c141de1f33.zip
- Fixed OSVERSION check [1]
- Fixed IGNORE spelling Noticed by: pointyhat via kris [1]
-rw-r--r--devel/p4/Makefile8
-rw-r--r--devel/p4d/Makefile8
-rw-r--r--devel/p4ftpd/Makefile8
-rw-r--r--devel/p4p/Makefile8
-rw-r--r--devel/p4web/Makefile8
-rw-r--r--devel/perforce/Makefile8
6 files changed, 36 insertions, 12 deletions
diff --git a/devel/p4/Makefile b/devel/p4/Makefile
index 2038fcaceeac..2d55b14d7999 100644
--- a/devel/p4/Makefile
+++ b/devel/p4/Makefile
@@ -70,14 +70,18 @@ PLATFORM= freebsd54x86
.elif ${OSVERSION} > 400000
PLATFORM= freebsd4
.else
-INGORE= only supported on FreeBSD 4.x and greater
+IGNORE= only supported on FreeBSD 4.x and greater
.endif
.endif
+.if (${ARCH} == amd64) && (${OSVERSION} < 504000)
+IGNORE= amd64 is only supported on FreeBSD 5.4 and later
+.endif
+
# Add compatability dependencies.
.if ${OSVERSION} > 600000
LIB_DEPENDS+= c_r.5:${PORTSDIR}/misc/compat5x
-.elif (${OSVERSION} < 540000) && (${OSVERSION} > 500000)
+.elif (${OSVERSION} < 504000) && (${OSVERSION} > 500000)
LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
.endif
diff --git a/devel/p4d/Makefile b/devel/p4d/Makefile
index 2038fcaceeac..2d55b14d7999 100644
--- a/devel/p4d/Makefile
+++ b/devel/p4d/Makefile
@@ -70,14 +70,18 @@ PLATFORM= freebsd54x86
.elif ${OSVERSION} > 400000
PLATFORM= freebsd4
.else
-INGORE= only supported on FreeBSD 4.x and greater
+IGNORE= only supported on FreeBSD 4.x and greater
.endif
.endif
+.if (${ARCH} == amd64) && (${OSVERSION} < 504000)
+IGNORE= amd64 is only supported on FreeBSD 5.4 and later
+.endif
+
# Add compatability dependencies.
.if ${OSVERSION} > 600000
LIB_DEPENDS+= c_r.5:${PORTSDIR}/misc/compat5x
-.elif (${OSVERSION} < 540000) && (${OSVERSION} > 500000)
+.elif (${OSVERSION} < 504000) && (${OSVERSION} > 500000)
LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
.endif
diff --git a/devel/p4ftpd/Makefile b/devel/p4ftpd/Makefile
index 2038fcaceeac..2d55b14d7999 100644
--- a/devel/p4ftpd/Makefile
+++ b/devel/p4ftpd/Makefile
@@ -70,14 +70,18 @@ PLATFORM= freebsd54x86
.elif ${OSVERSION} > 400000
PLATFORM= freebsd4
.else
-INGORE= only supported on FreeBSD 4.x and greater
+IGNORE= only supported on FreeBSD 4.x and greater
.endif
.endif
+.if (${ARCH} == amd64) && (${OSVERSION} < 504000)
+IGNORE= amd64 is only supported on FreeBSD 5.4 and later
+.endif
+
# Add compatability dependencies.
.if ${OSVERSION} > 600000
LIB_DEPENDS+= c_r.5:${PORTSDIR}/misc/compat5x
-.elif (${OSVERSION} < 540000) && (${OSVERSION} > 500000)
+.elif (${OSVERSION} < 504000) && (${OSVERSION} > 500000)
LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
.endif
diff --git a/devel/p4p/Makefile b/devel/p4p/Makefile
index 2038fcaceeac..2d55b14d7999 100644
--- a/devel/p4p/Makefile
+++ b/devel/p4p/Makefile
@@ -70,14 +70,18 @@ PLATFORM= freebsd54x86
.elif ${OSVERSION} > 400000
PLATFORM= freebsd4
.else
-INGORE= only supported on FreeBSD 4.x and greater
+IGNORE= only supported on FreeBSD 4.x and greater
.endif
.endif
+.if (${ARCH} == amd64) && (${OSVERSION} < 504000)
+IGNORE= amd64 is only supported on FreeBSD 5.4 and later
+.endif
+
# Add compatability dependencies.
.if ${OSVERSION} > 600000
LIB_DEPENDS+= c_r.5:${PORTSDIR}/misc/compat5x
-.elif (${OSVERSION} < 540000) && (${OSVERSION} > 500000)
+.elif (${OSVERSION} < 504000) && (${OSVERSION} > 500000)
LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
.endif
diff --git a/devel/p4web/Makefile b/devel/p4web/Makefile
index 2038fcaceeac..2d55b14d7999 100644
--- a/devel/p4web/Makefile
+++ b/devel/p4web/Makefile
@@ -70,14 +70,18 @@ PLATFORM= freebsd54x86
.elif ${OSVERSION} > 400000
PLATFORM= freebsd4
.else
-INGORE= only supported on FreeBSD 4.x and greater
+IGNORE= only supported on FreeBSD 4.x and greater
.endif
.endif
+.if (${ARCH} == amd64) && (${OSVERSION} < 504000)
+IGNORE= amd64 is only supported on FreeBSD 5.4 and later
+.endif
+
# Add compatability dependencies.
.if ${OSVERSION} > 600000
LIB_DEPENDS+= c_r.5:${PORTSDIR}/misc/compat5x
-.elif (${OSVERSION} < 540000) && (${OSVERSION} > 500000)
+.elif (${OSVERSION} < 504000) && (${OSVERSION} > 500000)
LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
.endif
diff --git a/devel/perforce/Makefile b/devel/perforce/Makefile
index 2038fcaceeac..2d55b14d7999 100644
--- a/devel/perforce/Makefile
+++ b/devel/perforce/Makefile
@@ -70,14 +70,18 @@ PLATFORM= freebsd54x86
.elif ${OSVERSION} > 400000
PLATFORM= freebsd4
.else
-INGORE= only supported on FreeBSD 4.x and greater
+IGNORE= only supported on FreeBSD 4.x and greater
.endif
.endif
+.if (${ARCH} == amd64) && (${OSVERSION} < 504000)
+IGNORE= amd64 is only supported on FreeBSD 5.4 and later
+.endif
+
# Add compatability dependencies.
.if ${OSVERSION} > 600000
LIB_DEPENDS+= c_r.5:${PORTSDIR}/misc/compat5x
-.elif (${OSVERSION} < 540000) && (${OSVERSION} > 500000)
+.elif (${OSVERSION} < 504000) && (${OSVERSION} > 500000)
LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
.endif