aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2010-12-07 14:13:59 +0800
committerglewis <glewis@FreeBSD.org>2010-12-07 14:13:59 +0800
commit8dbaa15aec5bd3ea1e9825752b47820bbb27b865 (patch)
tree5878859f992eb755708d1f15d9a98f55d2c4e8b8
parent1c2c9ceb05b839ef6c2431ca3d3079e4a6862744 (diff)
downloadfreebsd-ports-gnome-8dbaa15aec5bd3ea1e9825752b47820bbb27b865.tar.gz
freebsd-ports-gnome-8dbaa15aec5bd3ea1e9825752b47820bbb27b865.tar.zst
freebsd-ports-gnome-8dbaa15aec5bd3ea1e9825752b47820bbb27b865.zip
. Add a port of MyBatis for Java:
MyBatis is a first class persistence framework with support for custom SQL, stored procedures and advanced mappings. MyBatis eliminates almost all of the JDBC code and manual setting of parameters and retrieval of results. MyBatis can use simple XML or Annotations for configuration and map primitives, Map interfaces and Java POJOs (Plain Old Java Objects) to database records. WWW: http://www.mybatis.org/
-rw-r--r--databases/Makefile1
-rw-r--r--databases/java-mybatis/Makefile46
-rw-r--r--databases/java-mybatis/distinfo4
-rw-r--r--databases/java-mybatis/pkg-descr8
4 files changed, 59 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index ccadbab3c62f..5d4ef03602d4 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -119,6 +119,7 @@
SUBDIR += isql-viewer
SUBDIR += jakarta-commons-dbutils
SUBDIR += jasperreports
+ SUBDIR += java-mybatis
SUBDIR += jdb
SUBDIR += jdbc-oracle8i
SUBDIR += jdbc-oracle9i
diff --git a/databases/java-mybatis/Makefile b/databases/java-mybatis/Makefile
new file mode 100644
index 000000000000..74b552d3a6f5
--- /dev/null
+++ b/databases/java-mybatis/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: mybatis
+# Date created: 5 December 2010
+# Whom: glewis
+#
+# $FreeBSD$
+#
+
+PORTNAME= mybatis
+PORTVERSION= 3.0.3
+CATEGORIES= databases devel java
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= java-
+DISTFILES= ${PORTNAME}-${PORTVERSION}-bundle${EXTRACT_SUFX}
+.if !defined(NOPORTDOCS)
+DISTFILES+= ${USER_GUIDE}
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}-bundle${EXTRACT_SUFX}
+.endif
+
+MAINTAINER= glewis@FreeBSD.org
+COMMENT= SQL Mapping Framework
+
+USE_JAVA= yes
+USE_ZIP= yes
+LICENSE= ASL
+NO_BUILD= yes
+
+JAR_FILE= ${PORTNAME}-${PORTVERSION}.jar
+USER_GUIDE= MyBatis-${PORTVERSION}-User-Guide.pdf
+
+PLIST_FILES+= %%JAVAJARDIR%%/${JAR_FILE}
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/${JAR_FILE} ${JAVAJARDIR}
+.if !defined(NOPORTDOCS)
+ @-${MKDIR} ${DOCSDIR}
+.for f in LICENSE NOTICE
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+ @${INSTALL_DATA} ${DISTDIR}/${USER_GUIDE} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/java-mybatis/distinfo b/databases/java-mybatis/distinfo
new file mode 100644
index 000000000000..79d59cb93213
--- /dev/null
+++ b/databases/java-mybatis/distinfo
@@ -0,0 +1,4 @@
+SHA256 (mybatis-3.0.3-bundle.zip) = bc9285382a34385f2278446c23a2de92213c98d3357ecd758f4c97b88b865d80
+SIZE (mybatis-3.0.3-bundle.zip) = 3328302
+SHA256 (MyBatis-3.0.3-User-Guide.pdf) = b784682863b4b6148554fd46bfd3bca8cb21daa7dc63ddd8cd21ec5649921c71
+SIZE (MyBatis-3.0.3-User-Guide.pdf) = 533603
diff --git a/databases/java-mybatis/pkg-descr b/databases/java-mybatis/pkg-descr
new file mode 100644
index 000000000000..bfdec8fa0884
--- /dev/null
+++ b/databases/java-mybatis/pkg-descr
@@ -0,0 +1,8 @@
+MyBatis is a first class persistence framework with support for custom
+SQL, stored procedures and advanced mappings. MyBatis eliminates almost
+all of the JDBC code and manual setting of parameters and retrieval of
+results. MyBatis can use simple XML or Annotations for configuration and
+map primitives, Map interfaces and Java POJOs (Plain Old Java Objects)
+to database records.
+
+WWW: http://www.mybatis.org/