aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-05-11 06:40:06 +0800
committermiwi <miwi@FreeBSD.org>2009-05-11 06:40:06 +0800
commit8de58d860ff38202a64563a5ce85a307915369bd (patch)
treeb7d5c1d0d61ec501feb7488f9a5f3827ffc1ce54
parent5e979ba57dc955832327db8bded347e5bf2617e3 (diff)
downloadfreebsd-ports-gnome-8de58d860ff38202a64563a5ce85a307915369bd.tar.gz
freebsd-ports-gnome-8de58d860ff38202a64563a5ce85a307915369bd.tar.zst
freebsd-ports-gnome-8de58d860ff38202a64563a5ce85a307915369bd.zip
Parcellite is a lightweight GTK+ clipboard manager. This is a stripped down,
basic-features-only clipboard manager with a small memory footprint for those who like simplicity. WWW: http://parcellite.sourceforge.net PR: ports/134255 Submitted by: Joey Mingrone <joey at mingrone.org>
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/parcellite/Makefile30
-rw-r--r--deskutils/parcellite/distinfo3
-rw-r--r--deskutils/parcellite/files/patch-po_Makefile.in.in19
-rw-r--r--deskutils/parcellite/pkg-descr5
-rw-r--r--deskutils/parcellite/pkg-plist12
6 files changed, 70 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 567a27b9df84..1c50013bf10a 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -193,6 +193,7 @@
SUBDIR += p5-Goo
SUBDIR += p5-ZConf-Runner
SUBDIR += pal
+ SUBDIR += parcellite
SUBDIR += phpgroupware
SUBDIR += phpicalendar
SUBDIR += phprojekt
diff --git a/deskutils/parcellite/Makefile b/deskutils/parcellite/Makefile
new file mode 100644
index 000000000000..07285e0c5b31
--- /dev/null
+++ b/deskutils/parcellite/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: parcellite
+# Date created: 29 April 2009
+# Whom: Joey Mingrone <joey@mingrone.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= parcellite
+PORTVERSION= 0.9.1
+CATEGORIES= deskutils
+MASTER_SITES= SF
+
+MAINTAINER= joey@mingrone.org
+COMMENT= A lightweight GTK+ clipboard manager
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+MAN1= parcellite.1
+
+.include <bsd.port.mk>
diff --git a/deskutils/parcellite/distinfo b/deskutils/parcellite/distinfo
new file mode 100644
index 000000000000..27144342bdaf
--- /dev/null
+++ b/deskutils/parcellite/distinfo
@@ -0,0 +1,3 @@
+MD5 (parcellite-0.9.1.tar.gz) = 099d1ccc9fa1e59d3e3b19b77a90a8fb
+SHA256 (parcellite-0.9.1.tar.gz) = 37a438bfc58f953acf327d72adcb6c6e7940c2794b27c451187ece6398486464
+SIZE (parcellite-0.9.1.tar.gz) = 260434
diff --git a/deskutils/parcellite/files/patch-po_Makefile.in.in b/deskutils/parcellite/files/patch-po_Makefile.in.in
new file mode 100644
index 000000000000..389951be00b2
--- /dev/null
+++ b/deskutils/parcellite/files/patch-po_Makefile.in.in
@@ -0,0 +1,19 @@
+*** po/Makefile.in.in.orig Tue May 5 19:45:52 2009
+--- po/Makefile.in.in Tue May 5 19:46:58 2009
+***************
+*** 34,40 ****
+ datarootdir = @datarootdir@
+ libdir = @libdir@
+ DATADIRNAME = @DATADIRNAME@
+! itlocaledir = $(prefix)/$(DATADIRNAME)/locale
+ subdir = po
+ install_sh = @install_sh@
+ # Automake >= 1.8 provides @mkdir_p@.
+--- 34,40 ----
+ datarootdir = @datarootdir@
+ libdir = @libdir@
+ DATADIRNAME = @DATADIRNAME@
+! itlocaledir = $(datarootdir)/locale
+ subdir = po
+ install_sh = @install_sh@
+ # Automake >= 1.8 provides @mkdir_p@.
diff --git a/deskutils/parcellite/pkg-descr b/deskutils/parcellite/pkg-descr
new file mode 100644
index 000000000000..2af4ef1f7578
--- /dev/null
+++ b/deskutils/parcellite/pkg-descr
@@ -0,0 +1,5 @@
+Parcellite is a lightweight GTK+ clipboard manager. This is a stripped down,
+basic-features-only clipboard manager with a small memory footprint for those
+who like simplicity.
+
+WWW: http://parcellite.sourceforge.net
diff --git a/deskutils/parcellite/pkg-plist b/deskutils/parcellite/pkg-plist
new file mode 100644
index 000000000000..842bdc168559
--- /dev/null
+++ b/deskutils/parcellite/pkg-plist
@@ -0,0 +1,12 @@
+bin/parcellite
+etc/xdg/autostart/parcellite-startup.desktop
+%%NLS%%share/locale/de/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/es/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/parcellite.mo
+share/applications/parcellite.desktop
+@dirrmtry share/applications
+@dirrmtry etc/xdg/autostart/
+@dirrmtry etc/xdg/